Bug 62254 - Hotplug not properly starting network for xircom_cb pcmcia network
Hotplug not properly starting network for xircom_cb pcmcia network
Status: CLOSED DUPLICATE of bug 61705
Product: Red Hat Public Beta
Classification: Retired
Component: hotplug (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-28 16:10 EST by E Blaufuss
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-28 22:31:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description E Blaufuss 2002-03-28 16:10:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
When I insert the xircom_cm pcmcia card, the module seems to be
properly loaded by the pcmcia services, but hotplug seems to 
fail to notice this, and fails to start the network.
If I type "ifup eth0", network starts right up.

Here is the end of my messages file:

Mar 28 15:47:25 libra kernel: cs: cb_alloc(bus 2): vendor 0x115d, device 0x0003
Mar 28 15:47:25 libra kernel: PCI: Enabling device 02:00.0 (0000 -> 0003)
Mar 28 15:47:25 libra kernel: PCI: Setting latency timer of device 02:00.0 to
64Mar 28 15:47:25 libra kernel: eth0: Xircom cardbus revision 3 at irq 11 
Mar 28 15:47:25 libra kernel: PCI: Enabling device 02:00.1 (0000 -> 0003)
Mar 28 15:47:25 libra /etc/hotplug/net.agent: invoke ifup eth0
Mar 28 15:47:25 libra kernel: ttyS04 at port 0x4080 (irq = 11) is a 16550A
Mar 28 15:47:25 libra cardmgr[2211]: initializing socket 0
Mar 28 15:47:25 libra cardmgr[2211]: socket 0: Xircom CBEM56G-100 CardBus 10/100
Ethernet + 56K Modem
Mar 28 15:47:25 libra /etc/hotplug/pci.agent: Setup xircom_cb for PCI slot 02:00.0
Mar 28 15:47:25 libra /etc/hotplug/pci.agent: missing kernel or user mode driver
xircom_cb 
Mar 28 15:47:25 libra /etc/hotplug/pci.agent: ... no modules for PCI slot 02:00.1

The module is properly loaded, and works fine.  Seems
to be a problem with the hotplug recognition of the loaded
module.  I tried to track it down, but had no luck.
Any fixes?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Uplug the Xircom card
2. Replug the Xircom card.  Card is recognized properly every time
but ifup command doesn't get done.
3.
	

Expected Results:  The network should be up after I plug in the card, without
needing to type ifup eth0.

Additional info:
Comment 1 Richard Maine 2002-03-28 18:31:34 EST
Likely related problem with a linksys 10/100 NE2000 clone.
Log shows hotplug/net.agent trying the "ifup eth0",
but nothing results from that. In my case, nothing like the
above messages from pci.agent.  Just nothing at all after
the ".../net/agent: invoke ifup eth0".

All works fine if I manually do "ifup eth0", which is what
makes me think it is related.
Comment 2 Bill Crawford 2002-03-28 22:31:12 EST
Duplicate of bug #61705.
Comment 3 Bill Nottingham 2002-04-01 15:31:51 EST

*** This bug has been marked as a duplicate of 61705 ***

Note You need to log in before you can comment on or make changes to this bug.