Bug 622730 - SANE no longer finds HP scanner
SANE no longer finds HP scanner
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 05:40 EDT by A. Folger
Modified: 2010-11-15 12:49 EST (History)
5 users (show)

See Also:
Fixed In Version: hplip-3.10.5-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 12:38:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hp-check.log (11.04 KB, text/plain)
2010-08-10 05:40 EDT, A. Folger
no flags Details

  None (edit)
Description A. Folger 2010-08-10 05:40:12 EDT
Created attachment 437821 [details]
hp-check.log

Description of problem:
I have a HP Photosmart C5380 all-in-one that has worked fine for quite a while, including scanning, but today, as I wanted to scan something, SANE wouldn't recognize the scanner.

[root@schmelkewon ~]# sane-find-scanner
<SNIPPED LINES BEGINNING WITH #>
found USB scanner (vendor=0x03f0 [HP], product=0x7111 [Photosmart C5300 series]) at libusb:001:003
<SNIPPED LINES BEGINNING WITH #>

[root@schmelkewon ~]# scanimage -L
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

[root@schmelkewon ~]#rpm -qa "hp*" sane*
hplip-common-3.10.5-1.fc13.x86_64
hplip-3.10.5-1.fc13.x86_64
sane-backends-libs-1.0.21-2.fc13.x86_64
hplip-libs-3.10.5-1.fc13.x86_64
sane-backends-1.0.21-2.fc13.x86_64
hpijs-3.10.5-1.fc13.x86_64
hplip-gui-3.10.5-1.fc13.x86_64

How reproducible:

Every time. Just run any scanner accessing app, such as GIMP, and try to access the XSANE dialog, or use the above text based commands.

Steps to Reproduce:
See above
  
Actual results:
Scanner is not recognized by (X)SANE.

Expected results:
Scanner is recognized by (X)SANE and accessible by apps interfacing with SANE.

Additional info:
This problem seems to show up in many bug reporting systems over the years, but most of the time, the solution is to use the corrected hplip or sane-backend. Since my system is entirely up to date, the error is thus upstream.
Comment 1 Nils Philippsen 2010-08-10 06:44:53 EDT
Your model should be supported by hplip/libsane-hpaio, I'll change the component accordingly. Please attach the files /etc/sane.d/dll.conf and /etc/sane.d/dll.d/hpaio to this report. Do you have the libsane-hpaio package installed?

(In reply to comment #0)
> Additional info:
> This problem seems to show up in many bug reporting systems over the years, but
> most of the time, the solution is to use the corrected hplip or sane-backend.
> Since my system is entirely up to date, the error is thus upstream.    

NB: In this context "upstream" usually means "the origin from which a piece of software is derived", the upstream for hplip/libsane-hpaio would be hplipopensource.com. Whether or not your issue is a problem in the original hplip package or Fedora modifications can't be said at the moment. I think you rather meant that the problem is in the software package and not your configuration.
Comment 2 A. Folger 2010-08-10 15:20:09 EDT
<blockquote>Do you have the libsane-hpaio package installed?</blockquote>

Ah, that was it. Thanks and sorry for filing this erroneous big report. I will end this with a little feature request: either hp-check (most appropriate), scanimage or sane-find-scanner should check for the presence of said package; this will make it easier for users to figure out what's missing.

<blockquote>NB: In this context "upstream" usually means "the origin from which a piece of software is derived", &st;SNIP&gt;  I think you rather meant that the problem is in the software package and not your configuration.</blockquote>

Correct. But considering my new feature request, it now can be said to be a real upstream issue ;-).

Thanks for the help!
Comment 3 Jiri Popelka 2010-08-11 05:21:17 EDT
Since hplip-3.10.5-3.fc13 hplip-gui requires libsane-hpaio.
See also bug #591636 (rhel6).

At the moment there's hplip-3.10.6-1.fc13 in testing repo.
If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.
You can provide feedback for this update here:
http://admin.fedoraproject.org/updates/hplip-3.10.6-1.fc13
Comment 4 A. Folger 2010-08-11 07:29:51 EDT
I just updated and tested the dependencies. libsane-hpio is now dependent on hpio-gui, so it looks like the problem is solved. Thanks!
Comment 5 Nils Philippsen 2010-08-11 07:50:03 EDT
(In reply to comment #2)
> <blockquote>Do you have the libsane-hpaio package installed?</blockquote>
> 
> Ah, that was it. Thanks and sorry for filing this erroneous big report. I will
> end this with a little feature request: either hp-check (most appropriate),
> scanimage or sane-find-scanner should check for the presence of said package;
> this will make it easier for users to figure out what's missing.

It's a slightly moot point (as hpio-gui requires libsane-hpaio now, alleviating the issue to some extent), but I'll mention this just for clarification: as sane-backends can't possibly know about external backend drivers (which aren't under its control), it can't really warn about them missing. Well, not without using a hardcoded list of "known suspects", which I don't want to maintain ;-).
Comment 6 A. Folger 2010-08-11 08:22:32 EDT
No, I don't expect sane-backend to do that, but hp-check, which is part of hpio-gui, should know when libsane-hpio is missing.
Comment 7 Jiri Popelka 2010-08-25 04:51:05 EDT
*** Bug 626984 has been marked as a duplicate of this bug. ***
Comment 8 Pavel Alexeev 2010-08-25 06:26:05 EDT
I have seen this bug, but problem still there, and I think it is another. Sorry.

Is there solution now?

Note You need to log in before you can comment on or make changes to this bug.