Bug 62275 - Won't run, package missing dependencies
Won't run, package missing dependencies
Status: CLOSED DUPLICATE of bug 62794
Product: Red Hat Public Beta
Classification: Retired
Component: apacheconf (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-03-28 19:14 EST by Todd Palmer
Modified: 2013-04-02 00:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-01 01:56:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Todd Palmer 2002-03-28 19:14:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
apacheconf will not run, fails w/ ImportError "no module named distutils" error

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.run /usr/share/apacheconf/apacheconf

Actual Results:  Traceback (innermost last):
  File "/usr/share/apacheconf/ApacheConf.py", line 36, in ?
    import ApacheGizmo
  File "/usr/share/apacheconf/ApacheGizmo.py", line 36, in ?
    import ApacheBase
  File "/usr/share/apacheconf/ApacheBase.py", line 9 in ?
    from xml.xslt.Processor import Processor
  File "/usr/lib/python1.5/site-packages/xml/xslt/__init__.py", line 18 in ?
    from distutils import version
ImportError: No module named distutils

Expected Results:  GUI should come up

Additional info:

The default script is running under Python 1.5, but I don't think distutils was 
automatically distributed w/ 1.5.  It also fails under python 2.1 
with "ImportError no module named gtk" and under 2.2 with "ImportError no 
module named GDK"
Comment 1 Nathan G. Grennan 2002-04-01 01:56:24 EST
Running under skipjack beta1 with all the updates from up2date I don't have this
problem. I would suspect outside packages overwriting/replacing a package to be
at work here. You might also want to rpm -V   apacheconf, python, etc.
Comment 2 Phil Knirsch 2002-04-11 09:53:57 EDT

*** This bug has been marked as a duplicate of 62794 ***

Note You need to log in before you can comment on or make changes to this bug.