Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 622799 - Problems with clvmd symlinks when using chkconfig.
Problems with clvmd symlinks when using chkconfig.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.1
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Corey Marthaler
: RHELNAK
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 09:01 EDT by Everett Bennett
Modified: 2010-11-10 16:08 EST (History)
22 users (show)

See Also:
Fixed In Version: lvm2-2.02.72-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 621947
: 622804 (view as bug list)
Environment:
Last Closed: 2010-11-10 16:08:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -qa --last output (439 bytes, text/plain)
2010-08-10 09:40 EDT, Everett Bennett
no flags Details
tar zcvf /tmp/rhel601_etc_rc_d.tgz etc/rc.d/ (120.90 KB, application/x-gzip)
2010-08-10 09:47 EDT, Everett Bennett
no flags Details
rpm -qa --last output (132.72 KB, text/plain)
2010-08-10 10:06 EDT, Everett Bennett
no flags Details

  None (edit)
Description Everett Bennett 2010-08-10 09:01:47 EDT
Description of problem:

The symlinks defined by chkconfig appear to be set improperly.

Version-Release number of selected component (if applicable):


root@rhel601 ~]# uname -a
Linux rhel601 2.6.32-44.2.el6.x86_64 #1 SMP Wed Jul 21 12:48:32 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux

[root@rhel601 ~]# rpm -qf /etc/rc.d/init.d/clvmd 
lvm2-cluster-2.02.69-1.el6.x86_64

Additional info:

In RHEL 5.5, cman is set to S21cman and K79cman, clvmd is set to S26clvmd and K74clvmd.

In RHEL 6.0 Beta2, cman is set to S24cman and K29cman; clvmd is set to S24clvmd and K76clvmd.

The 'S' links for clvmd should be S25 or higher.
Comment 2 Fabio Massimo Di Nitto 2010-08-10 09:17:25 EDT
hi,

I have been unable to reproduce this issue locally.

could you please attach a tarball of /etc/rc.d/, the list of packages installed
on the system (rpm -q -a will do), and if you still have the chkconfig sequence
to enable the different init scripts?

Thanks
Comment 3 RHEL Product and Program Management 2010-08-10 09:18:36 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 4 Everett Bennett 2010-08-10 09:40:48 EDT
Created attachment 437881 [details]
rpm -qa --last output

rpm -qa --last output
Comment 5 Everett Bennett 2010-08-10 09:47:03 EDT
Created attachment 437883 [details]
tar zcvf /tmp/rhel601_etc_rc_d.tgz etc/rc.d/

gtar ztvf rhel601_etc_rc_d.tgz  to unpack.
Comment 6 Fabio Massimo Di Nitto 2010-08-10 09:50:58 EDT
(In reply to comment #4)
> Created an attachment (id=437881) [details]
> rpm -qa --last output
> 
> rpm -qa --last output    

Hi Everett,

thanks for the quick response but I believe the attachment doesn´t contain the correct information.

Thanks
Fabio
Comment 7 Everett Bennett 2010-08-10 10:06:15 EDT
Created attachment 437890 [details]
rpm -qa --last output

rpm -qa --last output
Comment 8 Everett Bennett 2010-08-10 10:08:07 EDT
Hope this works......using mozilla 3.6.4 on FC 13.
When I try to select the file to attach a different file is attached.
Had to rename file.

Also, unable to enter the path to the file in the 'browse' field.

Here is the attachment again.

[intec@uxeverett tmp]$ head rhel601rpmqa.txt 
kernel-headers-2.6.32-44.2.el6                Tue 03 Aug 2010 03:45:03 PM EDT
perf-2.6.32-44.2.el6                          Tue 03 Aug 2010 03:45:01 PM EDT
kernel-devel-2.6.32-44.2.el6                  Tue 03 Aug 2010 03:44:20 PM EDT
kernel-2.6.32-44.2.el6                        Tue 03 Aug 2010 03:43:38 PM EDT
kernel-firmware-2.6.32-44.2.el6               Tue 03 Aug 2010 03:43:31 PM EDT
yum-plugin-versionlock-1.1.26-10.el6          Wed 28 Jul 2010 02:06:07 PM EDT
yum-plugin-aliases-1.1.26-10.el6              Wed 28 Jul 2010 02:06:07 PM EDT
yum-plugin-verify-1.1.26-10.el6               Wed 28 Jul 2010 02:06:06 PM EDT
yum-plugin-downloadonly-1.1.26-10.el6         Wed 28 Jul 2010 02:06:06 PM EDT
yum-presto-0.6.2-1.el6                        Wed 28 Jul 2010 02:06:03 PM EDT
Comment 9 Fabio Massimo Di Nitto 2010-08-10 10:14:23 EDT
(In reply to comment #8)
> Hope this works..

Yes thanks a lot for the information.

Fabio
Comment 12 Dan Williams 2010-08-10 14:16:44 EDT
NM cannot run at S10 because it requires dbus (22), which itself requires rsyslog (12).  NM might also implicitly depend on udev-post (26) though Idon't know what udev-post actually does.  Historically NM depended on HAL (26) but we havent' used HAL since F11, so the lowest # dep we need is 22 (dbus).
Comment 13 Dan Williams 2010-08-10 14:20:16 EDT
Besides; in the grand scheme of things, requiring some sort of "networking" is not what you want.  You want to require the resources that you *actually need*, not just "some network connection is up".  For example, if the service is bound to a specific IP address and not to 0.0.0.0, it really shouldn't be running until some interface has that IP address.  That's clearly not RHEL6 material, but that's the way most services should be working.  Unfortunately they don't, and thus they require a huge sledhammer where they only need a nail...

We can attempt to move NM to S23 (right after dbus), since it doesn't look like udev-post is anything interesting to NM.
Comment 20 Fabio Massimo Di Nitto 2010-08-10 14:52:04 EDT
Hi Everett,

we have been able to identify the different issues, and they will be addressed soon.

If you need a temporary workaround, please let me know and I'll gladly write down a quick set of steps to get everything back to work.
Comment 23 Everett Bennett 2010-08-11 11:40:51 EDT
Sure...you can provide the temp fix.  Is there a file somewhere that maps the link levels, etc?
Comment 24 Fabio Massimo Di Nitto 2010-08-11 13:21:55 EDT
Hi Everett,

(In reply to comment #23)
> Sure...you can provide the temp fix.  Is there a file somewhere that maps the
> link levels, etc?    

as a temporary workaround, please remove NetworkManager package (rpm -e NetworkManager), chkconfig cman off, chkconfig --del cman, chkconfig --add cman, chkconfig cman on. This should re-establish /etc/rc.d/rc3.d/S21cman.

Once all affected packages will be updated (lvm2-cluster, chkconfig) the problem will disappear permanently and NetworkManager can be reinstalled (but disabled since corosync/cman cannot operate with NM active).

There are also other options but this is the cleanest I can suggest till fixed packages will be availble.

One of the other options is to change /etc/rc.d/init.d/clvmd script and add cman to Required-Starts and Required-Stops: entries to look like:

Required-Starts: $localfs cman
Required-Stops: $localfs cman

chkconfig --del clvmd
chkconfig --add clvmd
chkconfig clvmd on

that should establish clvmd at S25clvmd in /etc/rc.d/rc3.d right after cman.

With this latest solution you will get a notice that init.d/clvmd will be saved when upgrading the package that contains the same change.

Fabio
Comment 26 Corey Marthaler 2010-08-25 17:28:55 EDT
Where are the S init level links for cman/clvmd? I don't see them in any of the /etc/rc.[0123456].d dirs, I only see the K levels.
Comment 27 Corey Marthaler 2010-08-25 18:01:28 EDT
lrwxrwxrwx. 1 root root 14 Aug 25 16:47 S21cman -> ../init.d/cman
lrwxrwxrwx. 1 root root 18 Aug 25 16:59 S22cmirrord -> ../init.d/cmirrord
lrwxrwxrwx. 1 root root 15 Aug 25 16:45 S24clvmd -> ../init.d/clvmd

lrwxrwxrwx. 1 root root 15 Aug 25 16:57 K76clvmd -> ../init.d/clvmd
lrwxrwxrwx. 1 root root 18 Aug 18 11:14 K78cmirrord -> ../init.d/cmirrord
lrwxrwxrwx. 1 root root 14 Aug 25 16:57 K79cman -> ../init.d/cman


Fix verified in the latest rpms.
2.6.32-59.1.el6.x86_64

lvm2-2.02.72-8.el6    BUILT: Wed Aug 18 10:41:52 CDT 2010
lvm2-libs-2.02.72-8.el6    BUILT: Wed Aug 18 10:41:52 CDT 2010
lvm2-cluster-2.02.72-8.el6    BUILT: Wed Aug 18 10:41:52 CDT 2010
udev-147-2.22.el6    BUILT: Fri Jul 23 07:21:33 CDT 2010
device-mapper-1.02.53-8.el6    BUILT: Wed Aug 18 10:41:52 CDT 2010
device-mapper-libs-1.02.53-8.el6    BUILT: Wed Aug 18 10:41:52 CDT 2010
device-mapper-event-1.02.53-8.el6    BUILT: Wed Aug 18 10:41:52 CDT 2010
device-mapper-event-libs-1.02.53-8.el6    BUILT: Wed Aug 18 10:41:52 CDT 2010
cmirror-2.02.72-8.el6    BUILT: Wed Aug 18 10:41:52 CDT 2010
Comment 28 releng-rhel@redhat.com 2010-11-10 16:08:41 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.