Bug 622846 - [PATCH] NVIDIA GPU audio-over-HDMI: Patch required to support recent GPUs
[PATCH] NVIDIA GPU audio-over-HDMI: Patch required to support recent GPUs
Status: CLOSED DUPLICATE of bug 592199
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.6
All Linux
high Severity high
: rc
: ---
Assigned To: John Feeney
desktop-bugs@redhat.com
:
Depends On: 619877
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 10:38 EDT by John Feeney
Modified: 2010-11-17 10:24 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 619877
Environment:
Last Closed: 2010-11-17 10:24:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Feeney 2010-08-10 10:38:41 EDT
+++ This bug was initially created as a clone of Bug #619877 +++

The kernel ALSA driver needs a patch applied to make audio-over-HDMI operate
correctly on most supported GPUs.

The exact patch is available at
http://git.alsa-project.org/?p=alsa-kernel.git;a=commitdiff;h=4289bc9c818ece46f8034616b232caaef4622984

It'd be great if this patch could be included in the standard Red Hat kernel(s)
for any/all recent or supported distro versions.

Note 1: I believe only the nvidia driver (not nv nor nouveau) support setting
up audio-over-HDMI.

Note 2: Very recent GPUs (Fermi class) are not yet supported by the driver. A
second patch will be forthcoming for this at some point in time, but we have to
validate operation under Linux before releasing this.    

Note: I also filed this against Fedora as bug 619873. I assume filing against both Red Hat and Fedora separately makes sense? If not, please do let me know. Thanks.

--- Additional comment from jfeeney@redhat.com on 2010-08-06 14:28:14 EDT ---

Stephen,

Yes, entering separate bzs for RHEL and Fedora was the proper way since each are handled somewhat separately. 

Thanks for the pointer to the patch. That makes it easier. 
  John Feeney

--- Additional comment from jfeeney@redhat.com on 2010-08-10 10:19:49 EDT ---

Stephen, 
We found your bugzilla so important that we hi-jacked it for RHEL6. I will open another bz that will be used to track it in RHEL5.6 as soon as I can. Thanks again.
  John
Comment 1 RHEL Product and Program Management 2010-08-10 11:00:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 John Feeney 2010-08-23 15:34:27 EDT
The fix for this is included in the ALSA update for RHEL5.6. See bz592199. Kernel rpms to test can be found at http://people.redhat.com/~jkysela/RHEL5.
Comment 5 Linda Wang 2010-11-17 10:24:11 EST

*** This bug has been marked as a duplicate of bug 592199 ***

Note You need to log in before you can comment on or make changes to this bug.