Bug 622879 - SELinux prevented yum from writing fedora-debuginfo.
Summary: SELinux prevented yum from writing fedora-debuginfo.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-10 16:29 UTC by masami256
Modified: 2010-08-19 11:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 11:44:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description masami256 2010-08-10 16:29:02 UTC
Summary:

SELinux prevented yum from writing fedora-debuginfo.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux prevented yum from writing fedora-debuginfo. If fedora-debuginfo is a
core file, you may want to allow this. If fedora-debuginfo is not a core file,
this could signal an intrusion attempt.

Allowing Access:

Changing the "allow_daemons_dump_core" boolean to true will allow this access:
"setsebool -P allow_daemons_dump_core=1."

Fix Command:

setsebool -P allow_daemons_dump_core=1

Additional Information:

Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:root_t:s0
Target Objects                fedora-debuginfo [ dir ]
Source                        yum
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          rawhidetest
Source RPM Packages           python-2.7-7.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.8.8-8.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   allow_daemons_dump_core
Host Name                     rawhidetest
Platform                      Linux rawhidetest 2.6.35-3.fc14.i686.PAE #1 SMP
                              Fri Aug 6 19:41:17 UTC 2010 i686 i686
Alert Count                   2
First Seen                    Wed 11 Aug 2010 12:18:19 AM JST
Last Seen                     Wed 11 Aug 2010 12:26:33 AM JST
Local ID                      a5994927-2a93-4671-b55b-7153c76a0d32
Line Numbers                  

Raw Audit Messages            

node=rawhidetest type=AVC msg=audit(1281453993.624:306): avc:  denied  { create } for  pid=2058 comm="yum" name="fedora-debuginfo" scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:root_t:s0 tclass=dir

node=rawhidetest type=SYSCALL msg=audit(1281453993.624:306): arch=40000003 syscall=39 success=yes exit=0 a0=994fd10 a1=1ed a2=a5112c a3=975a050 items=0 ppid=2057 pid=2058 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="yum" exe="/usr/bin/python" subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

P.S.
I wasn't able to report it via sealert because of the bug " [abrt] setroubleshoot-server-2.2.91-2.fc14: base.py:957:request:AttributeError: HTTPSConnection instance has no attribute 'getreply'" so that I copy and past it.
https://bugzilla.redhat.com/show_bug.cgi?id=622877

Comment 1 Daniel Walsh 2010-08-19 11:44:32 UTC
This is a report error.

yum -y update


Note You need to log in before you can comment on or make changes to this bug.