Bug 622881 - SELinux is preventing /usr/bin/python "write" access on system-config-firewall.
Summary: SELinux is preventing /usr/bin/python "write" access on system-config-firewall.
Keywords:
Status: CLOSED DUPLICATE of bug 621726
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-10 16:35 UTC by masami256
Modified: 2010-08-10 18:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-10 18:11:32 UTC


Attachments (Terms of Use)

Description masami256 2010-08-10 16:35:02 UTC
Summary:

SELinux is preventing /usr/bin/python "write" access on system-config-firewall.

Detailed Description:

SELinux denied access requested by system-config-f. It is not expected that this
access is required by system-config-f and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:firewallgui_t:s0-s0:c0.c1023
Target Context                system_u:object_r:usr_t:s0
Target Objects                system-config-firewall [ dir ]
Source                        system-config-f
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          rawhidetest
Source RPM Packages           python-2.7-7.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.8.8-8.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     rawhidetest
Platform                      Linux rawhidetest 2.6.35-3.fc14.i686.PAE #1 SMP
                              Fri Aug 6 19:41:17 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Wed 11 Aug 2010 01:22:07 AM JST
Last Seen                     Wed 11 Aug 2010 01:22:07 AM JST
Local ID                      cfc9baf2-fefd-46e7-b663-df5a73719b7a
Line Numbers                  

Raw Audit Messages            

node=rawhidetest type=AVC msg=audit(1281457327.911:21776): avc:  denied  { write } for  pid=1933 comm="system-config-f" name="system-config-firewall" dev=dm-0 ino=268186 scontext=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 tcontext=system_u:object_r:usr_t:s0 tclass=dir

node=rawhidetest type=SYSCALL msg=audit(1281457327.911:21776): arch=40000003 syscall=10 success=no exit=-13 a0=bfca941b a1=bfca941b a2=ec212c a3=bfcaa48b items=0 ppid=1932 pid=1933 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="system-config-f" exe="/usr/bin/python" subj=system_u:system_r:firewallgui_t:s0-s0:c0.c1023 key=(null)


P.S.
I wasn't able to report it via sealert because of the bug " [abrt]
setroubleshoot-server-2.2.91-2.fc14: base.py:957:request:AttributeError:
HTTPSConnection instance has no attribute 'getreply'" so that I copy and past
it.
https://bugzilla.redhat.com/show_bug.cgi?id=622877

Comment 1 Miroslav Grepl 2010-08-10 18:11:32 UTC

*** This bug has been marked as a duplicate of bug 621726 ***


Note You need to log in before you can comment on or make changes to this bug.