Bug 623221 - Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the sam...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
14
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
: Reopened
: 627430 628117 628226 (view as bug list)
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-08-11 12:21 EDT by Nicolas Mailhot
Modified: 2010-09-25 16:58 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 622167
Environment:
Last Closed: 2010-09-25 16:58:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-08-11 12:21:59 EDT
+++ This bug was initially created as a clone of Bug #622167 +++

$ empathy

Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...
Trace/breakpoint trap (core dumped)

$ gedit    

Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...
Trace/breakpoint trap (core dumped)

$ rpm -q empathy gedit
empathy-2.31.5.1-2.fc14.x86_64
gedit-1:2.31.5-1.fc14.x86_64

--- Additional comment from mclasen@redhat.com on 2010-08-10 09:40:22 EDT ---

While the warning comes from gtk, this is not a gtk bug.

--- Additional comment from nicolas.mailhot@laposte.net on 2010-08-10 10:31:19 EDT ---

Then what component should it be assigned to?

--- Additional comment from mclasen@redhat.com on 2010-08-11 10:55:34 EDT ---

Given that gedit and empathy are the applications where you see the mixed linking, I would recommend those.
Comment 1 Nicolas Mailhot 2010-08-13 14:09:58 EDT
This one still crashes
Comment 2 Brian Pepple 2010-08-25 21:49:23 EDT
*** Bug 627430 has been marked as a duplicate of this bug. ***
Comment 3 Brian Pepple 2010-08-27 22:02:01 EDT
*** Bug 628117 has been marked as a duplicate of this bug. ***
Comment 4 Brian Pepple 2010-08-28 14:29:40 EDT
*** Bug 628226 has been marked as a duplicate of this bug. ***
Comment 5 Couret Charles-Antoine 2010-08-29 23:10:49 EDT
I confirm this bug with Fedora 14 Alpha…
Comment 6 Andy Lawrence 2010-08-31 18:30:31 EDT
This might help narrow it down a bit:


Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
aborting...

Program received signal SIGTRAP, Trace/breakpoint trap.
g_logv (log_domain=0x382ec7abbb "Gtk", log_level=<value optimized out>, format=
    0x382ed07220 "GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported", args1=0x7fffffffd800) at gmessages.c:554


empathy-2.31.5.1-2.fc14.x86_64
empathy-debuginfo-2.31.5.1-2.fc14.x86_64
Comment 7 Brian Pepple 2010-08-31 18:35:41 EDT
Aware of the problem, but waiting for folks to appear in the f14 buildroot before fixing this.
Comment 8 cleiton Lima 2010-08-31 21:53:49 EDT
I reported the bug in Empathy's Bugzilla:

https://bugzilla.gnome.org/show_bug.cgi?id=628172

and

https://bugzilla.gnome.org/show_bug.cgi?id=627916
Comment 9 cleiton Lima 2010-09-02 23:13:05 EDT
Problem solved in the most recent update from updates-testing.
Comment 10 Brian Pepple 2010-09-25 16:58:04 EDT
Fixed in recent version. empathy-2.31.92-1.fc14.i686

Note You need to log in before you can comment on or make changes to this bug.