Bug 623237 - Date / Time Properties fails to set system time over network causing installs to fail if SELinux is turned off
Date / Time Properties fails to set system time over network causing installs...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 795594
  Show dependency treegraph
 
Reported: 2010-08-11 12:42 EDT by Dave Jones
Modified: 2013-01-10 01:08 EST (History)
4 users (show)

See Also:
Fixed In Version: python-slip-0.2.13-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 683867 795594 (view as bug list)
Environment:
Last Closed: 2010-09-02 16:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2010-08-11 12:42:51 EDT
Description of problem:
Attempting to ntp sync using firstboot to set the date & time gives an error dialog:
"Couldn't write either /etc/ntp.conf or /etc/sysconfig/network.
Configuration unchanged."
The install will not continue unless you think to UNcheck "Synchronize date and time over the network"

The same message appears if you try via System > Administration > Date & Time and check "Synchronize date and time over the network"

Version-Release number of selected component (if applicable):
# rpm -qa | grep -E "date|ntp"
system-config-date-1.9.59-1.fc13.noarch
ntpdate-4.2.6p1-2.fc13.i686
rdate-1.4-14.fc12.i686
python-dateutil-1.4.1-4.fc12.noarch
ntp-4.2.6p1-2.fc13.i686

How reproducible: Every time, tried on several installed F13s and a new/clean spin of F13 from fedora-kickstarts-0.13.5-1.fc13.noarch.  Changes to the deault scripts were to turn both the firewall and selinux off

Steps to Reproduce:
1. Open System > Administration > Date & Time (or run from firstboot after install)
2. check "Synchronize date and time over the network"
3. Click "OK"
  
Actual results:
Error box: "Couldn't write either /etc/ntp.conf or /etc/sysconfig/network.
Configuration unchanged."

Expected results:
Time & date set

Additional info: 
I've tried "NETWORKWAIT=yes" in /etc/sysconfig/network, no help
I've tried various combinations of starting & stopping ntp-releated services but the only useful one is to "chkconfig ntpd off" in a kickstart file, which causes "Synchronize date and time over the network" to be unchecked by default.
Comment 1 Nils Philippsen 2010-08-24 05:35:22 EDT
I can't reproduce that here. Please run system-config-date again, this time from the command line/terminal and post any error messages here, along with the output of these commands:

ls -l /etc/ntp.conf /etc/sysconfig/network
ls -lZ /etc/ntp.conf /etc/sysconfig/network

NB: You shouldn't (need to) turn off SELinux nowadays. Is there any particular reason why you felt you had to do that?
Comment 2 Dave Jones 2010-08-30 15:07:24 EDT
Hello Nils.

Sorry for the delayed response.  I was training for my RHCT last week (passed!) so I did not gave an opportunity to run your tests until today.

# system-config-date
Returns:
[Errno 61] No data available
When I check "Synchronize date and time over the network" and hit OK.

# ls -l /etc/ntp.conf /etc/sysconfig/network
-rw-r--r-- 1 root root 1915 Jun 16 10:02 /etc/ntp.conf
-rw-r--r-- 1 root root   41 Jun 16 09:48 /etc/sysconfig/network

# ls -lZ /etc/ntp.conf /etc/sysconfig/network
-rw-r--r-- root root ?                                /etc/ntp.conf
-rw-r--r-- root root ?                                /etc/sysconfig/network

FWIW, I turn off SELinux in kickstart because I pull all of the SELinux tools out of the build to keep the size under my self-imposed limit.  It seems like a cleaner solution to turn it off if it is not available.

Thanks,
Dave
Comment 3 Dave Jones 2010-08-30 18:09:15 EDT
Taking your hint, I let SELinux relable my disk and put it in "permissive" mode.
Once I did that, system-config-date & the ntp check box function correctly.

It appears system-config-date no longer works unless SELinux is enabled.
Comment 4 Dave Jones 2010-08-31 09:52:36 EDT
I put the default (?) SELinux stuff back in my build and it added about 27MB to the size.
That is a Bad Thing (tm).  I have about 9MB of free space for the build.
If there is a minimal SELinux installation that can be used that is less than 10MB then I will be happy to add it, otherwise I think system-config-date should be fixed to work without SELinux again.
Comment 5 Nils Philippsen 2010-08-31 12:02:21 EDT
Hi Dave, it seems as if some things were broken if SELinux is switched off, see bug #627788, so please try out if things work with python-slip-0.2.13:

https://admin.fedoraproject.org/updates/python-slip-0.2.13-1.fc13

This needs libselinux/libselinux-python, but shouldn't need a complete SELinux stack.
Comment 6 Dave Jones 2010-08-31 12:30:31 EDT
Hello Nils.

I updated the 3 python-slip files from your Koji link:
python-slip-0.2.13-1.fc13.noarch
python-slip-dbus-0.2.13-1.fc13.noarch
python-slip-gtk-0.2.13-1.fc13.noarch

I also have the following libselinux packages from the default repos:
libselinux-utils-2.0.90-5.fc13.i686
libselinux-2.0.90-5.fc13.i686
libselinux-python-2.0.90-5.fc13.i686

After applying the updates, system-config-date & the ntp checkbox seems to be working as designed.

I would say you could add # 623237 to the Bugs Fixed list for your patch.
Hopefully you can get it pushed to testing & updates in the not too distant future.

Thanks for the help!
Dave
Comment 7 Fedora Update System 2010-09-01 04:46:56 EDT
python-slip-0.2.13-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/python-slip-0.2.13-1.fc13
Comment 8 Fedora Update System 2010-09-01 04:47:17 EDT
python-slip-0.2.13-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/python-slip-0.2.13-1.fc12
Comment 9 Fedora Update System 2010-09-01 04:47:50 EDT
python-slip-0.2.13-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-slip-0.2.13-1.fc14
Comment 10 Dave Jones 2010-09-01 10:48:45 EDT
Quick update:  I am creating some test kickstart builds with the new packages.

So far, it looks like the anaconda installer does not like to run if SELinux is in permissive mode.  I am trying to create a new image with the python-slip updates and once dine I will try installing with SELinux in various modes.
Comment 11 Dave Jones 2010-09-01 18:31:08 EDT
Updating the packages after installing seems to work but I am having a bear of a time trying to get them to work in a live image.  The hard disk installer crashes not far into the install process.  (Bug 629320)
Comment 12 Dave Jones 2010-09-02 13:16:39 EDT
The crash on install is due to Bug 626780.

Making sure the kickstart does not update NetworkManager components past v. 0.8.1-1 seems to solve the issue.
Comment 13 Fedora Update System 2010-09-02 16:37:46 EDT
python-slip-0.2.13-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-10-01 08:25:10 EDT
python-slip-0.2.13-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-10-08 16:39:20 EDT
python-slip-0.2.13-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.