Bug 62327 - Enlightenment hangs
Enlightenment hangs
Status: CLOSED DUPLICATE of bug 62078
Product: Red Hat Linux
Classification: Retired
Component: enlightenment (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-29 13:20 EST by Need Real Name
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-31 15:04:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output from startx (31.78 KB, text/plain)
2002-03-29 13:22 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-03-29 13:20:15 EST
Description of Problem:
Enlightenment hangs or menues are unavailable. 

Version-Release number of selected component (if applicable):
This has occures on a fully patched (As of March 23, and patched again March 
29) 7.2 system. 

How Reproducible:
Start w/ a RedHat 7.2 system, and have enlighenment as your Window Manager(WM). 
In the .xinitrc file add "Eterm &" and "gkrellm &" and anything else you want. 
restart the WM. Eterm and gkrellm should start automaticly. Now fully patch the 
7.2 system (Patch level current as of March 29th). Restart the WM again, one of 
two results will occur: Enlightenment will start with the two applications 
running but there will be no menu access. OR, enlightenment will hang.

Steps to Reproduce:
1. Base Redhat 7.2 install w/ Enlightenment as WM, and Eterm, gkrellm, aim... 
in .xinitrc file. Enlightenment should work fine with the chosen applications 
opening appon log in. 
2. Fully patch the 7.2 system. Level the applications in the .xinitrc file. 
3. Restart the WM (log off or restart X), Now enlightenment should hang or the 
menus are unresponsive.

Actual Results:
enlightenment does not complete the log in process and the Enlightenment wm 
does not become available. Or If Enlightenment does get to full graphical mode, 
the point w/ one of the applications speciffied in the .xinitrc file is 
running, then all menues do not function.

Expected Results:
Full use of enlightenment with the pre-set applications running.

Additional Information: If you would like I will send an strace output from 
startx. hawkeye.md@comcast.net

not working: .xinitrc file 
#!/bin/sh
# Execute enlightenment. ALWAYS make sure this is at the end of this
# startup file - and ALWAYS run things before it with an & at the end.
# For example:
#   xterm &
gkrellm &
Eterm &
#   kpanel &
# It is suggested to use Enlightenment's Remember dialog for having apps
# spawned automatically on login.
exec /usr/bin/enlightenment

working .xinitrc file
#!/bin/sh
# Execute enlightenment. ALWAYS make sure this is at the end of this
# startup file - and ALWAYS run things before it with an & at the end.
# For example:
#   xterm &
#   kpanel &
# It is suggested to use Enlightenment's Remember dialog for having apps
# spawned automatically on login.
exec /usr/bin/enlightenment


 
Current rpms:
4Suite-0.11-2
a2ps-4.13b-15
aim-1.5.234-1
alchemist-1.0.18-1
alsa-lib-0.5.10-2mdk
anacron-2.3-17
apmd-3.0final-34
arpwatch-2.1a11-9
arts-2.2.2-2
ash-0.3.7-2
aspell-0.33.7-1
at-3.1.8-23
audiofile-0.2.1-2
audiofile-devel-0.2.1-2
aumix-2.7-5
authconfig-4.1.19-1
autoconf-2.13-14
autofs-3.1.7-21
automake-1.4p5-2
awesfx-0.4.3a-8
basesystem-7.0-2
bash-2.05-8
bc-1.06-5
bdflush-1.5-17
bind-utils-9.1.3-4
binutils-2.11.90.0.8-12
bison-1.28-7
bttvgrab-0.15.10-3mdk
byacc-1.9-19
bzip2-1.0.1-4
bzip2-devel-1.0.1-4
bzip2-libs-1.0.1-4
Canna-libs-3.5b2-50
cdda2wav-1.10-4
cdecl-2.5-20
cdlabelgen-1.5.0-9
cdp-0.33-21
cdparanoia-alpha9.8-2
cdrecord-1.10-4
cdrecord-devel-1.10-4
cheops-0.61-3
chkconfig-1.2.24-1
chkfontpath-1.9.5-2
cipe-1.4.5-6
common-licenses-1.0-5mdk
compat-egcs-6.2-1.1.2.16
compat-egcs-c6.2-1.1.2.16
compat-egcs-g77-6.2-1.1.2.16
compat-egcs-objc-6.2-1.1.2.16
compat-glibc-6.2-2.1.3.2
compat-libstdc6.2-2.9.0.16
console-tools-19990829-36
control-center-1.4.0.1-18
cpio-2.4.2-23
cpp-2.96-98
cracklib-2.7-12
cracklib-dicts-2.7-12
crontabs-1.10-1
ctags-5.0.1-2
curl-7.8-1
curl-devel-7.8-1
cvs-1.11.1p1-7
cyrus-sasl-1.5.24-23
cyrus-sasl-devel-1.5.24-23
cyrus-sasl-md5-1.5.24-23
cyrus-sasl-plain-1.5.24-23
dateconfig-0.7.4-6
db1-1.85-7
db1-devel-1.85-7
db2-2.4.14-7
db31-3.1.17-1
db3-3.2.9-4
db3-devel-3.2.9-4
db3-utils-3.2.9-4
ddd-3.3.1-5
dev-3.2-5
dev86-0.15.5-1
dhcpcd-1.3.18pl8-13
dialog-0.9a-5
diffstat-1.28-1
diffutils-2.7.2-2
docbook-dtd30-sgml-1.0-10
docbook-dtd31-sgml-1.0-10
docbook-dtd40-sgml-1.0-11
docbook-dtd41-sgml-1.0-10
docbook-style-dsssl-1.64-3
docbook-utils-0.6.9-2
docbook-utils-pdf-0.6.9-2
dos2unix-3.1-7
dosfstools-2.7-1
doxygen-1.2.8.1-1
dsniff-2.3-1
dump-0.4b25-1.72.0
e2fsprogs-1.26-1.72
e2fsprogs-devel-1.26-1.72
ed-0.2-21
efax-0.9-9
eject-2.0.9-2
emacs-20.7-41
enlightenment-0.16.4-11
esound-0.2.22-5
esound-devel-0.2.22-5
Eterm-0.9-7
exmh-2.4-2
expat-1.95.1-7
expat-devel-1.95.1-7
fam-2.6.4-11
file-3.35-2
filesystem-2.1.6-2
fileutils-4.1-4
findutils-4.1.7-1
finger-0.17-9
flex-2.5.4a-15
fnlib-0.5-9
foomatic-1.1-0.20011218.3
fortune-mod-1.0-16
fping-2.4b2-2
freetype-2.0.3-7
freetype-devel-2.0.3-7
ftp-0.17-12
ftpcopy-0.3.9-1
gal-0.8-6
gawk-3.1.0-3
gcc-2.96-98
gcc3-3.0.4-1
gcc3-c3.0.4-1
gcc3-g77-3.0.4-1
gcc3-java-3.0.4-1
gcc3-objc-3.0.4-1
gcc-c2.96-98
gcc-chill-2.96-98
gcc-g77-2.96-98
gcc-java-2.96-98
gcc-objc-2.96-98
GConf-1.0.4-3
gd-1.8.4-4
gdb-5.1-1
gdbm-1.8.0-10
gdbm-devel-1.8.0-10
gd-devel-1.8.4-4
gdk-pixbuf-0.11.0-8
gdk-pixbuf-gnome-0.11.0-8
gentoo-0.11.18-1
gettext-0.10.38-7
ghostscript-6.51-16
ghostscript-fonts-5.50-3
giftrans-1.12.2-9
gimp-1.2.1-7
gimp-devel-1.2.1-7
gkrellm-1.2.9-fr1
gkrellm-skins-20001202-1cl
glib10-1.0.6-10
glib-1.2.10-5
glibc-2.2.4-19.3
glibc-common-2.2.4-19.3
glibc-devel-2.2.4-19.3
glib-devel-1.2.10-5
gmp-3.1.1-4
gmp-devel-3.1.1-4
gnome-audio-1.0.0-12
gnome-core-1.4.0.4-38
gnome-libs-1.2.13-16
gnome-print-0.29-6
gnome-vfs-1.0.1-17
gnorpm-0.96-12.7x
gnupg-1.0.6-3
gphoto-0.4.3-13
gpm-1.19.3-20
gpm-devel-1.19.3-20
grep-2.4.2-7
groff-1.17.2-7.0.2
groff-perl-1.17.2-7.0.2
grub-0.90-11
gsm-1.0.10-3
gsm-devel-1.0.10-3
gtk1.0.6-10
gtk+1.2.10-11
gtk+devel-1.2.10-11
gtk-engines-0.11-3
gtkglarea-1.2.2-10
gtkhtml-0.9.2-9
Gtk-Perl-0.7008-3
guile-1.3.4-16
gzip-1.3-15
hdparm-4.1-2
hotplug-2001_04_24-11
htmlview-1.2.0-1
hwbrowser-0.3.5-2
ical-2.2-25
ImageMagick-5.3.8-3
ImageMagick-c5.3.8-3
ImageMagick-perl-5.3.8-3
imlib-1.9.13-2.7.x
imlib-devel-1.9.13-2.7.x
indent-2.2.6-2
indexhtml-7.2-1
info-4.0b-3
initscripts-6.43-1
ipchains-1.3.10-10
iproute-2.2.4-14
iptables-1.2.4-2
iputils-20001110-6
j2re-1.4.0-fcs
j2sdk-1.4.0-fcs
jadetex-3.11-4
jdk-1.3.1_01-fcs
john-1.6-5
jre-1.3.1_01-fcs
kbdconfig-1.9.14-1
kernel-2.4.7-10
kernel-2.4.9-13
kernel-2.4.9-21
kernel-2.4.9-31
kernel-headers-2.4.9-31
kernel-source-2.4.9-31
krb5-devel-1.2.2-13
krb5-libs-1.2.2-13
krbafs-1.0.9-2
krbafs-devel-1.0.9-2
ksconfig-1.9.8-4
ksymoops-2.4.1-1
kudzu-0.99.23-1
kudzu-devel-0.99.23-1
lclint-2.5q-4
less-358-21
lesstif-0.92.32-6
lesstif-devel-0.92.32-6
lha-1.00-17
libaa1-1.2-12mdk
libao-0.8.0-1
libao-devel-0.8.0-1
libcap-1.10-5
libdivxdecore-0.4.7-3
libdvdcss-1.0.0-fr1
libdvdread-0.9.2-fr2
libgal7-0.8-6
libgcc-3.0.4-1
libgcj-2.96-28
libgcj3-3.0.4-1
libgcj3-devel-3.0.4-1
libgcj-devel-2.96-28
libghttp-1.0.9-2
libglade-0.16-4
libgnomeprint15-0.29-6
libjpeg-6b-16
libjpeg-devel-6b-16
libmng-1.0.2-1
libmng-devel-1.0.2-1
libnet-1.0.2-7mdk
libnids-1.16-1
libogg-1.0rc2-1
libogg-devel-1.0rc2-1
libpcap-0.6.2-9
libpng-1.0.12-2
libpng-devel-1.0.12-2
libPropList-0.10.1-8
librep-0.13.6-5
libstdc2.96-98
libstdc3.0.4-1
libstdcdevel-3.0.4-1
libstdcdevel-2.96-98
libtermcap-2.0.8-28
libtermcap-devel-2.0.8-28
libtiff-3.5.5-13
libtiff-devel-3.5.5-13
libtool-1.4-8
libtool-libs-1.4-8
libungif-4.1.0-9
libungif-devel-4.1.0-9
libunicode-0.4-6
libuser-0.32-1
libvorbis-1.0rc2-2
libvorbis-devel-1.0rc2-2
libxml-1.8.14-2
libxml2-2.4.10-0.7x.2
libxml-devel-1.8.14-2
libxslt-1.0.7-2
lilo-21.4.4-14
links-0.96-2
locale_config-0.3.2-1
lockdev-1.0.0-14
lockdev-devel-1.0.0-14
logrotate-3.5.9-1
logwatch-2.1.1-3
lokkit-0.50-6
losetup-2.11g-5
LPRng-3.7.4-28
lsof-4.51-2
ltrace-0.3.10-7
lv-4.49.4-3
lynx-2.8.4-17
m4-1.4.1-5
make-3.79.1-8
MAKEDEV-3.2-5
man-1.5i2-6
man-pages-1.39-2
mc-4.5.51-36
memprof-0.4.1-5
Mesa-3.4.2-10
Mesa-devel-3.4.2-10
mgapdesk-1.00-7
micq-0.4.6.p1-2
mikmod-3.1.6-12
mingetty-0.9.4-18
mkbootdisk-1.4.2-3
mkinitrd-3.2.6-1
mkisofs-1.10-4
mkkickstart-2.4-1
mktemp-1.5-11
mkxauth-1.7-16
mm-1.1.3-1
mm-devel-1.1.3-1
modutils-2.4.13-0.7.1
mount-2.11g-5
mouseconfig-4.23-1
mozilla-0.9.2.1-2
mozilla-psm-0.9.2.1-2
mpage-2.5.1-7
mpg321-0.1.5-1
mtools-3.9.8-2
mt-st-0.6-1
mtv-1.0.6.8-1
napshare-1.0-1mdk
nc-1.10-11
ncftp-3.0.3-6
ncompress-4.2.4-24
ncurses4-5.0-5
ncurses-5.2-12
ncurses-devel-5.2-12
netconfig-0.8.11-7
netpbm-9.14-2
netpbm-devel-9.14-2
netpbm-progs-9.14-2
netscape-common-4.78-2
netscape-communicator-4.78-2
net-tools-1.60-3
newt-0.50.33-1
newt-devel-0.50.33-1
nfs-utils-0.3.1-13.7.2.1
ngrep-1.40.1-1
njamd-0.8.1-2
nkf-1.92-6
nmap-2.54BETA22-3
nmap-frontend-2.54BETA22-3
nmh-1.0.4-9
ntp-4.1.0-4
ntsysv-1.2.24-1
oaf-0.6.5-10
Omni-0.5.0-4
openjade-1.3-17
openldap12-1.2.12-4
openldap-2.0.21-1
openldap-clients-2.0.21-1
openldap-devel-2.0.21-1
openldap-servers-2.0.21-1
openssh-3.1p1-2
openssh-askpass-3.1p1-2
openssh-clients-3.1p1-2
openssh-server-3.1p1-2
openssl095a-0.9.5a-11
openssl096-0.9.6-6
openssl-0.9.6b-8
openssl-devel-0.9.6b-8
openssl-perl-0.9.6b-8
ORBit-0.5.8-4
pam-0.75-19
pam-devel-0.75-19
pam_krb5-1.46-1
pam_smb-1.1.6-2
pan-0.9.7-2
parted-1.4.16-8
passwd-0.64.1-7
patch-2.5.4-10
pax-1.5-4
pciutils-2.1.8-23
pciutils-devel-2.1.8-23
pcre-3.4-2
pcre-devel-3.4-2
perl-5.6.1-26.72.3
perl-CGI-2.752-26.72.3
perl-CPAN-1.59_54-26.72.3
perl-DateManip-5.39-5
perl-DB_File-1.75-26.72.3
perl-Digest-MD5-2.13-1
perl-HTML-Parser-3.25-2
perl-HTML-Tagset-3.03-3
perl-libnet-1.0703-6
perl-libwww-perl-5.53-3
perl-libxml-enno-1.02-5
perl-libxml-perl-0.07-5
perl-MIME-Base64-2.12-6
perl-NDBM_File-1.75-26.72.3
perl-Parse-Yapp-1.04-3
perl-SGMLSpm-1.03ii-4
perl-Storable-0.6.11-6
perl-URI-1.12-5
perl-XML-Dumper-0.4-5
perl-XML-Encoding-1.01-2
perl-XML-Grove-0.46alpha-3
perl-XML-Parser-2.30-7
perl-XML-Twig-2.02-2
php-4.0.6-15
php-ldap-4.0.6-15
pidentd-3.0.14-1
pine-4.44-1.72.0
pinfo-0.6.1-2
playmidi-2.4-16
pmake-1.45-4
pnm2ppa-1.04-2
popt-1.6.4-7x
portmap-4.0-38
postgresql-7.1.3-2
postgresql-libs-7.1.3-2
procinfo-18-2
procps-2.0.7-11
psgml-1.2.1-13
psmisc-20.1-2
pspell-0.12.2-3
psutils-1.17-13
pwdb-0.61.1-3
pygnome-1.4.1-3
pygnome-libglade-1.4.1-3
pygtk-0.6.8-3
pygtk-libglade-0.6.8-3
python-1.5.2-35
python2-2.1.1-2
python2-devel-2.1.1-2
python-devel-1.5.2-35
python-popt-0.8.8-7.x.2
python-xmlrpc-1.5.1-7.x.3
PyXML-0.6.5-4
qt1x-1.45-16
qt1x-GL-1.45-16
qt-2.3.1-5
qt-designer-2.3.1-5
qt-devel-2.3.1-5
qt-Xt-2.3.1-5
quota-3.01pre9-3
radvd-0.6.2pl4-1
raidtools-0.90-24
rcs-5.7-15
rdate-1.0-8
rdist-6.1.5-16
readline-4.2-2
readline-devel-4.2-2
redhat-config-network-0.9.10-2
redhat-config-users-0.9.2-6
redhat-logos-1.1.3-1
redhat-release-7.2-1
reiserfs-utils-3.x.0j-2
rep-gtk-0.15-6
rep-gtk-gnome-0.15-6
rhn_register-2.7.9-7.x.2
rhn_register-gnome-2.7.9-7.x.2
ripperX-2.2-1
rmt-0.4b25-1.72.0
rootfiles-7.2-1
rpm-4.0.4-7x
rpm-build-4.0.4-7x
rpmdb-redhat-7.2-0.20010924
rpm-devel-4.0.4-7x
rpmfind-1.7-4.7x
rpm-python-4.0.4-7x
rsync-2.4.6-13
samba-2.2.1a-4
samba-client-2.2.1a-4
samba-common-2.2.1a-4
sawfish-0.38-11
scotty-2.1.11-2.asp
screen-3.9.9-3
scrollkeeper-0.2-6
SDL-1.2.2-3
SDL-devel-1.2.2-3
SDL_image-1.2.0-3
SDL_mixer-1.2.0-4
SDL_net-1.2.2-1
sed-3.02-10
serviceconf-0.6.6-1
setserial-2.17-4
setup-2.5.7-1
setuptool-1.8-2
sgml-common-0.5-7
sgml-tools-1.0.9-12
shadow-utils-20000902-4
shapecfg-2.2.12-7
sharutils-4.2.1-8
sh-utils-2.0.11-5
slang-1.4.4-4
slang-devel-1.4.4-4
slocate-2.6-1
smpeg-0.4.4-3
smpeg-xmms-0.3.4-3
sndconfig-0.65.2-1
snort-1.8.3-5snort
snort-plain繗놭1.8.3-5snort
snort-postgresql-1.8.3-5snort
snort-postgresql繗놭1.8.3-5snort
snort-snmp-1.8.3-5snort
snort-snmp繗놭1.8.3-5snort
sox-12.17.1-4
stat-2.5-2
strace-4.3-2
stunnel-3.22-1
sudo-1.6.4-0.7x.2
swig-1.1p5-10
switchdesk-3.9.7-1
symlinks-1.2-13
sysklogd-1.4.1-4
syslinux-1.52-2
sysstat-4.0.1-2
SysVinit-2.78-19
tamago-4.0.6-5
tar-1.13.19-6
tcl-8.3.3-65
tcpdump-3.6.2-9
tcp_wrappers-7.6-19
tcsh-6.10-6
telnet-0.17-20
termcap-11.0.1-10
tetex-1.0.7-38.2
tetex-afm-1.0.7-38.2
tetex-dvilj-1.0.7-38.2
tetex-dvips-1.0.7-38.2
tetex-fonts-1.0.7-38.2
tetex-latex-1.0.7-38.2
tetex-xdvi-1.0.7-38.2
texinfo-4.0b-3
textutils-2.0.14-2
time-1.7-14
timeconfig-3.2.2-1
tix-8.2.0b1-65
tk-8.3.3-65
tkinter-1.5.2-35
tmpwatch-2.8.1-1
traceroute-1.4a12-1
tree-1.2-13
tripwire-2.3.1-5
ttfonts-1.0-4
ttfonts-ja-1.0-7
ucd-snmp-4.2.3-1.7.2.3
ucd-snmp-libs-4.2.3-1
ucd-snmp-utils-4.2.3-1.7.2.3
umb-scheme-3.2-21
units-1.55-10
unix2dos-2.2-12
unzip-5.42-1
up2date-2.7.61-7.x.2
up2date-gnome-2.7.61-7.x.2
urw-fonts-2.0-12
usbview-1.0-2
usermode-1.46-1
utempter-0.5.2-6
util-linux-2.11f-17
VFlib2-2.25.1-20
VFlib2-devel-2.25.1-20
vim-common-6.0-7.13
vim-enhanced-6.0-7.13
vim-minimal-6.0-7.13
vim-X11-6.0-7.13
vixie-cron-3.0.1-63
VMwareWorkstation-3.0.0-1455
VMwareWorkstationKernelModules-3.0.0-1491
vnc-3.3.3r2-18.4
vnc-doc-3.3.3r2-18.4
vnc-server-3.3.3r2-18.4
vorbis-1.0rc2-1
w3c-libwww-5.2.8-10
watanabe-vf-1.0-5
wget-1.7-3
which-2.12-3
whois-1.0.9-1
wine-20010822-1
Wnn6-SDK-1.0-14
words-2-17
wu-ftpd-2.6.1-20
Xaw3d-1.5-10
Xaw3d-devel-1.5-10
xawtv-3.54-5
xcdroast-0.98a9-2
Xconfigurator-4.9.39-2
xcpustate-2.5-11
xdelta-1.1.1-11
xemacs-21.1.14-23.7.2
xemacs-el-21.1.14-23.7.2
xemacs-info-21.1.14-23.7.2
xforms-0.88-9
XFree86-100dpi-fonts-4.1.0-15
XFree86-4.1.0-15
XFree86-devel-4.1.0-15
XFree86-ISO8859-15-100dpi-fonts-4.1.0-15
XFree86-ISO8859-15-75dpi-fonts-4.1.0-15
XFree86-libs-4.1.0-15
XFree86-xdm-4.1.0-15
XFree86-xfs-4.1.0-15
xine-0.9.7-fr1
xinetd-2.3.3-1
xinitrc-3.20-1
xloadimage-4.1-21
xmms-1.2.5-7
xmms-devel-1.2.5-7
xmms-skins-1.2.5-7
xmp-2.0.5-5mdk
xmps-0.2.0-4
xmps-opendivx-plugin-0.0.2-1
xosview-1.7.3-5
xpdf-0.92-5
xscreensaver-3.33-4
xsri-2.0.3-1
xtraceroute-0.9.0-3
xv-3.10a-23
zebra-0.91a-6
zip-2.3-10
zlib-1.1.3-25.7
zlib-devel-1.1.3-25.7
Comment 1 Need Real Name 2002-03-29 13:22:39 EST
Created attachment 51404 [details]
strace output from startx
Comment 2 Havoc Pennington 2002-03-31 15:03:57 EST
Probably need an strace of Enlightenment rather than startx. "strace -f" on
startx should get you that.

Enlightenment is not in current Rawhide, though, so if this is a bug in E (vs.
one of the 7.2 updates), it probably won't be fixed.
Comment 3 Havoc Pennington 2002-04-01 11:02:15 EST
Ah, it's imlib.

*** This bug has been marked as a duplicate of 62078 ***

Note You need to log in before you can comment on or make changes to this bug.