Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623465 - tomcat5 upgrade to tomcat5 causes exception at start
tomcat5 upgrade to tomcat5 causes exception at start
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tomcat5 (Show other bugs)
5.5.z
x86_64 Linux
high Severity urgent
: rc
: ---
Assigned To: David Knox
qe-baseos-daemons
: Regression, ZStream
: 623813 (view as bug list)
Depends On: 659287
Blocks: 627507
  Show dependency treegraph
 
Reported: 2010-08-11 16:25 EDT by James E. Blair
Modified: 2015-11-01 19:15 EST (History)
11 users (show)

See Also:
Fixed In Version: tomcat5-5.5.23-0jpp.16.el5
Doc Type: Bug Fix
Doc Text:
Still has startup issues (http404) on first request. The second request will return http200.See comment 15. We will continue to track this down.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 19:09:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dknox: needinfo+
pm-rhel: needinfo+


Attachments (Terms of Use)
context.xml that triggers problem (1.09 KB, text/xml)
2010-08-11 19:56 EDT, James E. Blair
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0138 normal SHIPPED_LIVE tomcat5 bug fix update 2011-01-12 14:26:40 EST

  None (edit)
Description James E. Blair 2010-08-11 16:25:53 EDT
Description of problem:

Upgraded to tomcat5-5.5.23-0jpp.9.el5_5, and on restart, the following is logged:

Aug 11, 2010 12:13:54 PM org.apache.catalina.core.ContainerBase
addChildInternal
SEVERE: ContainerBase.addChild: start:
LifecycleException:  Error initializaing :  java.lang.NullPointerException
       at
org.apache.catalina.core.StandardContext.start(StandardContext.java:3986)
       at
org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:760)
       at
org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:740)
       at
org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)
...

Version-Release number of selected component (if applicable):

 tomcat5-5.5.23-0jpp.9.el5_5
Comment 1 David Knox 2010-08-11 17:01:08 EDT
Please see rhbz#623254 

RHEL-5-5-Z:

https://brewweb.devel.redhat.com//taskinfo?taskID=2676377

cvs tag: tomcat5-5_5_23-0jpp_10_el5_5
Comment 2 James E. Blair 2010-08-11 19:56:18 EDT
Created attachment 438310 [details]
context.xml that triggers problem
Comment 3 James E. Blair 2010-08-11 19:59:40 EDT
I don't think it's the same as the StackOverflow problem, since this is a NullPointerException.

We have tomcat running several applications, and we're only seeing this on ones that use a $THOME/conf/Catalina/localhost/<context>.xml file to set database connection information, etc.  I attached a sample (with passwords redacted).
Comment 4 David Knox 2010-08-12 11:37:21 EDT
Thanks. Could you also attach a complete log file including the exception, please?
Comment 5 David Knox 2010-08-12 17:12:37 EDT
Confirmed. the problem is related to the existence of a $CAT_HOME/conf/Catalina/localhost/context.xml. 

Any empty context.xml in that specific location will cause the same problem. The same context.xml in /etc/tomcat5/ will not produce the problem. Changing the context path (path="/foo") also produces the problem.
Comment 6 Jim Roland, RHCE 2010-08-20 13:41:55 EDT
Same issue here with context tags but in a different file.  I'm an RHCE and have worked with 2 other RHCEs at RH ending up with the same result.  32-bit or 64-bit system, using GCJ Java or our requirement for Sun Java 1.6.0.

I have RH case # 2050882 open as well.  This problem is not specific to the webapp's context.xml either, if you put in a global context in /usr/share/tomcat5/conf/server.xml, 0.jpp9 and 0.jpp10 will also crash, remove the context tags and tomcat starts up.  The crash on startup leaves the ports open, but tomcat is unresponsive on his http port.  A ps listing shows tomcat running but it does not respond when you post a "GET /webapplication/ HTTP/1.0" when attempting a connection to port 8080.

Thanks,
Jim Roland, RHCE
Comment 7 David Knox 2010-08-20 14:01:01 EDT
FYI, a Context element in server.xml is no longer considered appropriate. The recommendation is to put a <context>.xml in conf (for a default) or in Catalina/<host>/<context>.xml 

That said, it doesn't change the issue, which has been narrowed down to a particular place. I don't have an eta yet, but am working on it.
Comment 8 Jeff Bastian 2010-08-20 14:24:47 EDT
*** Bug 623813 has been marked as a duplicate of this bug. ***
Comment 17 Jim Roland, RHCE 2010-08-25 11:06:01 EDT
What is the status on fixing this issue?
Comment 21 Jim Roland, RHCE 2010-09-29 09:45:43 EDT
Are you guys waiting on me to QA this or are you in QA yourselves?  Just asking if you need anything from me in the next several days?
Comment 25 David Knox 2010-12-01 14:39:39 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Still has startup issues (http404) on first request. The second request will return http200.See comment 15. 

We will continue to track this down.
Comment 30 errata-xmlrpc 2011-01-13 19:09:36 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0138.html

Note You need to log in before you can comment on or make changes to this bug.