Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623813 - tomcat crashing on startup after upgrading to tomcat5-5.5.23-0jpp.9.el5_5
tomcat crashing on startup after upgrading to tomcat5-5.5.23-0jpp.9.el5_5
Status: CLOSED DUPLICATE of bug 623465
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tomcat5 (Show other bugs)
5.5
All Linux
high Severity high
: rc
: ---
Assigned To: David Knox
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-12 16:49 EDT by Jeff Bastian
Modified: 2015-11-01 19:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 14:24:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2010-08-12 16:49:07 EDT
Description of problem:
Tomcat is crashing on startup after upgrading to tomcat5-5.5.23-0jpp.9.el5_5.  Downgrading to tomcat5-5.5.23-0jpp.7.el5_3.2 fixes the problem.

It crashes with the error:
SEVERE: Catalina.start:
LifecycleException:  Error initializaing :  java.lang.NullPointerException

See below for full logs.

Tried removing wars out of the /var/lib/tomcat5/webapps directory to eliminate the possibility of it being a coding issue but the fault remains. 


Version-Release number of selected component (if applicable):
tomcat5-5.5.23-0jpp.9.el5_5

How reproducible:
not sure

Steps to Reproduce:
1. upgrade to 
2. restart tomcat
  
Actual results:
tomcat crashes on startup

Expected results:
tomcat works normally

Additional info:

The following packages were updated:

Aug 06 11:48:48 Updated: 1:java-1.6.0-sun-1.6.0.21-1jpp.2.el5.i586
Aug 06 11:48:52 Updated: 1:java-1.6.0-sun-devel-1.6.0.21-1jpp.2.el5.i586
Aug 06 11:49:03 Installed: kernel-2.6.18-194.8.1.el5.i686
Aug 06 11:49:10 Installed: kernel-xen-2.6.18-194.8.1.el5.i686
Aug 06 11:49:10 Updated: kernel-headers-2.6.18-194.8.1.el5.i386
Aug 06 11:49:11 Updated: tomcat5-servlet-2.4-api-5.5.23-0jpp.9.el5_5.i386
Aug 06 11:49:11 Updated: tomcat5-jasper-5.5.23-0jpp.9.el5_5.i386
Aug 06 11:49:12 Updated: tomcat5-server-lib-5.5.23-0jpp.9.el5_5.i386
Aug 06 11:49:13 Updated: tomcat5-jsp-2.0-api-5.5.23-0jpp.9.el5_5.i386
Aug 06 11:49:13 Updated: tomcat5-common-lib-5.5.23-0jpp.9.el5_5.i386
Aug 06 11:49:14 Updated: tomcat5-5.5.23-0jpp.9.el5_5.i386
Aug 06 11:49:14 Updated: tomcat5-admin-webapps-5.5.23-0jpp.9.el5_5.i386
Aug 06 11:49:16 Updated: tomcat5-webapps-5.5.23-0jpp.9.el5_5.i386


Restarting tomcat produces the following error in /var/log/tomcat5/catalina.out

Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JRE_HOME:
06-Aug-2010 16:24:55 org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-1.6.0-sun-1.6.0.21/jre/lib/i386/server:/usr/lib/jvm/java-1.6.0-sun-1.6.0.21/jre/lib/i386:/usr/lib/jvm/java-1.6.0-sun-1.6.0.21/jre/../lib/i386:/usr/java/packages/lib/i386:/lib:/usr/lib
06-Aug-2010 16:24:55 org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
06-Aug-2010 16:24:55 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 600 ms
06-Aug-2010 16:24:55 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
06-Aug-2010 16:24:55 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.23
06-Aug-2010 16:24:55 org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
06-Aug-2010 16:24:55 org.apache.catalina.startup.Catalina start
SEVERE: Catalina.start:
LifecycleException:  Error initializaing :  java.lang.NullPointerException
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:3986)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
      at org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
      at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
      at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
      at org.apache.catalina.core.StandardService.start(StandardService.java:448)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)
06-Aug-2010 16:24:55 org.apache.catalina.startup.Catalina start
INFO: Server startup in 102 ms
Comment 1 David Knox 2010-08-12 17:15:38 EDT
This looks like : https://bugzilla.redhat.com/show_bug.cgi?id=623465
Comment 2 Jeff Bastian 2010-08-12 19:33:20 EDT
Indeed it does.  I did a search on tomcat5 bugs yesterday about noon, and this bug was opened after that.  I should have done another search before opening this one!
Comment 3 Jeff Bastian 2010-08-20 14:24:47 EDT
Closing as duplicate of 623465

*** This bug has been marked as a duplicate of bug 623465 ***

Note You need to log in before you can comment on or make changes to this bug.