Bug 623562 - [RFE] As a beaker admin, I would like to find out which systems have been reserved for too long
Summary: [RFE] As a beaker admin, I would like to find out which systems have been res...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
(Show other bugs)
Version: 0.7
Hardware: All Linux
high
high vote
Target Milestone: 22.0
Assignee: Roman Joost
QA Contact: tools-bugs
URL:
Whiteboard: UX
Keywords: FutureFeature, Patch
: 598881 1279463 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-12 06:58 UTC by Nilesh Patil
Modified: 2016-03-16 08:10 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 05:33:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
WIP showing with test data. I've added additional columns to be displayed by default: Loaned To, Pools. The reserve report is now a custom version of the system search. (49.08 KB, image/png)
2015-12-09 03:44 UTC, Roman Joost
no flags Details
WIP illustrating the improved reserve report (47.27 KB, image/png)
2015-12-09 03:45 UTC, Roman Joost
no flags Details

Description Nilesh Patil 2010-08-12 06:58:34 UTC
Description of problem:
Separate column to display system "reserve time/date". It will be helpful to see if someone has reserved the box for long and doesn't turn back. We can always talk to respective person if he can free up the system so we can work on it. 

This is what the problem gss lab associate facing. They search for specific hardware and find out that its already reserved by the person for say 14 days. We believe that person might have used the system and done with his work and forgot to unreserve it. We ask associate to talk to respective person and use system.    

Version-Release number of selected component (if applicable):
NA

How reproducible:
NA

Steps to Reproduce:
1.
2.
3.
  
Actual results:
NA

Expected results:
A column added to existing beaker inventory list page. 

Additional info:

Comment 1 Raymond Mancy 2010-11-11 05:51:15 UTC
You can also see this info by going to the History tab  on the system details page.

Comment 5 Roman Joost 2015-11-23 00:18:58 UTC
Acceptance criteria:

* open the systems grid, enable the "Reserved Since" column from the "Toggle Result Columns" widget and it shows the systems list with timestamp information since the system was reserved
* clicking the "Reserved Since" column header sorts the grid by reserved time

Comment 6 Roman Joost 2015-11-24 04:09:02 UTC
*** Bug 598881 has been marked as a duplicate of this bug. ***

Comment 7 Roman Joost 2015-12-08 00:35:41 UTC
Patch available on gerrit:

https://gerrit.beaker-project.org/#/c/4501/

Comment 8 Roman Joost 2015-12-09 03:44 UTC
Created attachment 1103780 [details]
WIP showing with test data. I've added additional columns to be displayed by default: Loaned To, Pools. The reserve report is now a custom version of the system search.

Comment 9 Roman Joost 2015-12-09 03:45 UTC
Created attachment 1103781 [details]
WIP illustrating the improved reserve report

WIP showing with test data. I've added additional columns to be displayed by default: Loaned To, Pools. The reserve report is now a custom version of the system search.

Comment 10 Roman Joost 2015-12-11 00:33:17 UTC
*** Bug 1279463 has been marked as a duplicate of this bug. ***

Comment 11 Roman Joost 2015-12-21 01:25:28 UTC
Moved patch set to develop branch:

https://gerrit.beaker-project.org/#/c/4551

Comment 14 Dan Callaghan 2016-01-14 05:33:19 UTC
Beaker 22.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.