Bug 623572 - lm_sensors doesn't find/ load coretemp module automatically
lm_sensors doesn't find/ load coretemp module automatically
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
13
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
:
Depends On: 611144
Blocks: 623587
  Show dependency treegraph
 
Reported: 2010-08-12 04:04 EDT by David Kovalsky
Modified: 2014-03-31 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: lm_sensors-3.1.2-2.svn5857.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 611144
: 623587 (view as bug list)
Environment:
Last Closed: 2010-09-14 00:58:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2010-08-12 04:04:41 EDT
+++ This bug was initially created as a clone of Bug #611144 +++

Created an attachment (id=429308)
/proc/cpuinfo

For Core i7 processors and running sensors-detect, coretemp module is not loaded automatically and temperatures not shown. If I manually modprobe coretemp, I see the output.

[test@kovinek ~]$ sensors
thinkpad-isa-0000
Adapter: ISA adapter
fan1:       3563 RPM
temp1:       +78.0°C                                    
temp2:        +0.0°C                                    
temp3:        +0.0°C                                    
temp4:        +0.0°C                                    
temp5:        +0.0°C                                    
temp6:        +0.0°C                                    
temp7:        +0.0°C                                    
temp8:        +0.0°C                                    

(coretemp module which I don't see without manually modprobing coretemp)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:      +76.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0001
Adapter: ISA adapter
Core 1:      +76.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0002
Adapter: ISA adapter
Core 2:      +77.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0003
Adapter: ISA adapter
Core 3:      +77.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0004
Adapter: ISA adapter
Core 4:      +78.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0005
Adapter: ISA adapter
Core 5:      +78.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0006
Adapter: ISA adapter
Core 6:      +77.0°C  (high = +84.0°C, crit = +100.0°C)  

coretemp-isa-0007
Adapter: ISA adapter
Core 7:      +77.0°C  (high = +84.0°C, crit = +100.0°C)  


[test@kovinek ~]$ cat /etc/sysconfig/lm_sensors 
# Generated by sensors-detect on Thu Jul  1 13:38:56 2010
# This file is sourced by /etc/init.d/lm_sensors and defines the modules to
# be loaded/unloaded.
#
# The format of this file is a shell script that simply defines variables:
# HWMON_MODULES for hardware monitoring driver modules, and optionally
# BUS_MODULES for any required bus driver module (for example for I2C or SPI).

HWMON_MODULES="sbs"

# For compatibility reasons, modules are also listed individually as variables
#    MODULE_0, MODULE_1, MODULE_2, etc.
# You should use BUS_MODULES and HWMON_MODULES instead if possible.

MODULE_0=sbs








Adding coretemp to the above file works, so this seems to be only a matter of sensors-detect.

lm_sensors-3.1.2-2.fc13.x86_64
lm_sensors-libs-3.1.2-2.fc13.x86_64
lm_sensors-sensord-3.1.2-2.fc13.x86_64
Comment 1 David Kovalsky 2010-08-12 04:50:54 EDT
Talking to Nikola via IRC, the CPU model 30(0x1e) is not in sensors-detect.
Comment 2 David Kovalsky 2010-08-12 09:56:59 EDT
Adding the value ($probecpu->{model} == 0x1e) into coretemp_detect function of /usr/sbin/sensors-detect did do the trick.
Comment 3 Fedora Update System 2010-09-03 07:52:28 EDT
lm_sensors-3.1.2-2.svn5857.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/lm_sensors-3.1.2-2.svn5857.fc12
Comment 4 Fedora Update System 2010-09-03 07:52:34 EDT
lm_sensors-3.1.2-2.svn5857.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/lm_sensors-3.1.2-2.svn5857.fc13
Comment 5 Fedora Update System 2010-09-03 07:52:39 EDT
lm_sensors-3.1.2-2.svn5857.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/lm_sensors-3.1.2-2.svn5857.fc14
Comment 6 Fedora Update System 2010-09-03 12:42:53 EDT
lm_sensors-3.1.2-2.svn5857.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lm_sensors'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/lm_sensors-3.1.2-2.svn5857.fc14
Comment 7 Fedora Update System 2010-09-14 00:58:48 EDT
lm_sensors-3.1.2-2.svn5857.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-09-15 01:31:17 EDT
lm_sensors-3.1.2-2.svn5857.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-09-15 01:45:41 EDT
lm_sensors-3.1.2-2.svn5857.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.