Bug 62369 - xcdroast xcdroast-0.98a9-7 does not work with pam_xauth
Summary: xcdroast xcdroast-0.98a9-7 does not work with pam_xauth
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: xcdroast (Show other bugs)
(Show other bugs)
Version: fisher
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 64500 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-30 18:11 UTC by Dale Stimson
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-20 13:42:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dale Stimson 2002-03-30 18:11:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
xcdroast-0.98a9-7 does not work with pam_xauth.  Specifically, when doing "su -"
from a user account an attempt by the resulting process to connect with the X
server gets "connection refused by server".  This functionality _did_ work with
7.2 and xcdroast-0.98a9-2.

The problem seems to be that xcdroast does not look in the pam_xauth
file ~/.xauth* for its xauth keys.  However, if the ~/.xauth* file created by
pam_xauth is copied into ~/.Xauthority, xcdroast will run OK.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.From a user account, "su -" (or, presumably, "su - anywhere")
2.Enter command "xcdroast"
3.
	

Actual Results:  Xlib: connection to ":0.0" refused by server

Expected Results:  xcdroast should have connected to the X server and begun
execution.

Additional info:

Other X programs (such as xterm) work OK in the scenario given above.
This problem is specific to (at least) xcdroast.
If I copy pam_xauth's file ~/.xauth* into ~/.Xauthority, xcdroast
works OK.  This leads me to the conclusion that xcdroast is not looking in all
the places that it should for the xauth keys.

This bug report came about as a result of a submission to skipjack-list mailing
list by Joey Grasty <w.grasty@attbi.com>.

Comment 1 Tim Waugh 2002-05-02 13:42:03 UTC
If you change 'SESSION=false' to 'SESSION=true' in 
/etc/security/console.apps/xcdroast, does that fix it for you?

Comment 2 Dale Stimson 2002-05-02 21:12:36 UTC
Yes.  Changing 'SESSION=false' to 'SESSION=true' in
/etc/security/console.apps/xcdroast does make it work.

Is the content of that file documented anywhere?
I'm curious what the parameters mean.

Comment 3 Tim Waugh 2002-05-07 07:28:56 UTC
*** Bug 64500 has been marked as a duplicate of this bug. ***

Comment 4 Tim Waugh 2002-06-20 13:41:57 UTC
Fixed in xcdroast-0.98a9-11.


Note You need to log in before you can comment on or make changes to this bug.