Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623811 - anaconda should use liblvm and libcryptsetup to get data area starts
anaconda should use liblvm and libcryptsetup to get data area starts
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
:
Depends On: 623808 651069
Blocks: 647893 705163 756082 761078
  Show dependency treegraph
 
Reported: 2010-08-12 16:38 EDT by Mike Snitzer
Modified: 2011-12-23 12:16 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-30 11:55:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Snitzer 2010-08-12 16:38:40 EDT
Description of problem:
Anaconda should use liblvm and libcryptsetup to determine the data area start location for any volumes it will create.

liblvm must provide access to what a particular PV's pe_start will be (bug 623808).

libcryptsetup must provide access to what a particular LUKS device's 'Payload offset' will be.

Additional info:
improving anaconda in this manner will enable more comprehensive "I/O topology awareness" at install time.
Comment 1 Chris Lumens 2010-08-12 16:58:21 EDT
Do you have a pointer to documentation for using those libraries?
Comment 3 David Cantrell 2011-05-26 14:49:25 EDT
anaconda changes are blocked by upstream acceptance of the as-yet-to-be-completed work described in bug #623808.  Once those are done, we can work on changing anaconda.
Comment 6 David Cantrell 2011-08-10 10:14:13 EDT
Since bug #623808 is currently in ON_QA for 6.2 and the devel freeze is 4 business days away, I'm moving this bug to 6.3.
Comment 7 David Lehman 2011-08-10 12:16:50 EDT
Anaconda is a python application. Until/unless liblvm provides python bindings this is a non-starter.
Comment 9 David Cantrell 2011-11-30 11:49:36 EST
Based on comment #7 and where things stand right now with liblvm, I really don't see this happening in the 6.3 timeframe.  Rather than carry this forward forever, I'm going to set devel_ack-.
Comment 10 RHEL Product and Program Management 2011-11-30 11:55:23 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 11 Mike Snitzer 2011-11-30 14:01:23 EST
Fair enough... but be aware that dropping this may lead to misaligned root volumes in the future.

liblvm and libcryptsetup were thought to be a means to an end for fixing the general issue of making anaconda "I/O topology aware".  That they have been deemed inadequate doesn't change the fact that anaconda is lacking said awareness.

Note You need to log in before you can comment on or make changes to this bug.