This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 651069 - [RFE] python bindings for liblvm/lvm2app
[RFE] python bindings for liblvm/lvm2app
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 623811
  Show dependency treegraph
 
Reported: 2010-11-08 13:51 EST by David Lehman
Modified: 2010-12-14 03:58 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-14 03:58:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2010-11-08 13:51:05 EST
Description of problem:
Python bindings for liblvm would be of great use to anaconda. It would allow us to remove several unreliable calculations of things like available space in not-yet-created VGs and pe_start. Since anaconda is written in python, a C header file is not particularly useful.

Version-Release number of selected component (if applicable):
lvm2-2.02.70-1
Comment 1 Petr Rockai 2010-12-13 11:36:47 EST
Surely python has some sort of FFI? Why can't you simply call the C functions from python? And, if there was to be a python binding to LVM, presumably it would live in a separate package anyway (I don't think it is a good idea for LVM to build-depend on python...).
Comment 2 David Lehman 2010-12-13 11:46:34 EST
Anaconda using an FFI to interface/wrap liblvm puts us in the position of maintaining a relatively low-level interface to your library, which makes no sense. We don't have the extra cycles to maintain an lvm-specific library. For liblvm to be of use for anaconda it needs to provide a reasonably stable python interface. If the lvm team wants to use an FFI to generate this, fine.
Comment 3 Petr Rockai 2010-12-14 03:58:43 EST
Well, we don't have those extra cycles either. As long as it's easier for you to call command line tools than it is to call C, I guess you should stick with the former. We can revisit this when we have some extra manpower on liblvm/lvm2app. Maybe if this is still valid in six months from now, you can try reopening and we'll see if any free cycles on the lvm side have materialised by then (but I wouldn't set my hopes too high on that).

Note You need to log in before you can comment on or make changes to this bug.