Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 623995 - [or_IN] Oriya (or-IN) fonts do not render correctly.
[or_IN] Oriya (or-IN) fonts do not render correctly.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lohit-oriya-fonts (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 623990 627171 639977
  Show dependency treegraph
 
Reported: 2010-08-13 07:41 EDT by Ankit Patel
Modified: 2010-10-14 19:00 EDT (History)
13 users (show)

See Also:
Fixed In Version: lohit-oriya-fonts-2.4.3-5.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 623990
: 627171 639977 (view as bug list)
Environment:
Last Closed: 2010-09-23 08:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot from RHEL6-Beta (442.54 KB, image/png)
2010-08-13 07:45 EDT, Manoj Kumar Giri
no flags Details
lohit oriya fonts with fix for qt (96.82 KB, application/octet-stream)
2010-08-20 06:44 EDT, Pravin Satpute
no flags Details
Screenshot showing some rendering issues. (152.28 KB, image/png)
2010-08-23 03:48 EDT, Manoj Kumar Giri
no flags Details

  None (edit)
Description Ankit Patel 2010-08-13 07:41:09 EDT
Created attachment 438662 [details]
A screenshot from Fedora 13 (broken)

A screenshot from Fedora 13 (broken)

Description of problem:
conjunction characters do not appear correctly in KDE applications, like kedit, kwrite, etc. while it gets rendered properly in GTK based applications.

Try typing following three words in GTK and QT based editors.
ବିଜ୍ଞାନ ( keysequence (inscript - Oriya): yf%ev )
ସିଦ୍ଧାନ୍ତ ( keysequence (inscript - Oriya): mfodOevdl )
ସାକ୍ଷର ( keysequence (inscript - Oriya): me&j )

How reproducible:
Everytime

Steps to Reproduce:
1. Open gedit & after enabling Oriya (Inscript) type the mentioned words using given key sequences.
2. Open kedit/kwrite & after enabling Oriya (Inscript) type the mentioned words using given key sequences.
3. Open openoffice & after enabling Oriya (Inscript) type the mentioned words using given key sequences.
  
Actual results:
gedit and openoffice.org renders mentioned words correctly, while kedit/kwrite is not

Expected results:
gedit and openoffice.org and kde/kwrite should render mentioned words correctly
Comment 2 Pravin Satpute 2010-08-17 00:50:30 EDT
need a fix from qt. moving component to qt
Comment 3 Pravin Satpute 2010-08-19 06:30:52 EDT
ସିଦ୍ଧାନ୍ତ  
ବିଜ୍ଞାନ
ସାକ୍ଷର	
କ୍କ
କ୍ତ
କ୍ତ୍ର
କ୍ବ
କ୍ବ
କ୍ଳ  
କ୍ଷ୍ଣ
କ୍ଷ୍ମ
କ୍ସ
ଗ୍ଦ
ଗ୍ଧ
ଗ୍ନ
ଗ୍ଳ
ଘ୍ନ
ଙ୍କ  ଙ୍କ୍ତ ଙ୍କ୍ଷ
ଙ୍ଖ ଙ୍ଗ ଙ୍ଘ
ଚ୍ଚ ଚ୍ଛ 
ଜ୍ଜ ଜ୍ଜ୍ବ  ଜ୍ଝ ଜ୍ବ ଞ୍ଚ ଞ୍ଛ ଞ୍ଜ ଞ୍ଝ ଟ୍ଟ ଡ୍ଗ ଡ୍ଡ ଣ୍ଟ ଣ୍ଠ ଣ୍ଡ  ଣ୍ଡ୍ର ଣ୍ଢ ଣ୍ଣ ତ୍କ ତ୍ତ  ତ୍ତ୍ବ ତ୍ତ୍ର ତ୍ଥ ତ୍ନ ତ୍ପ ତ୍ବ ତ୍ମ  ତ୍ମ୍ଯ ତ୍ସ  ତ୍ସ୍ଯ ତ୍ସ୍ନ  ଦ୍ଗ ଦ୍ଘ ଦ୍ଦ ଦ୍ଧ  ଦ୍ଧ୍ବ ଦ୍ବ ଦ୍ଭ 
ଧ୍ବ ଧ୍ଯ ନ୍ତ ନ୍ତ୍ଯ  ନ୍ତ୍ର ନ୍ତ୍ବ ନ୍ଥ ନ୍ଦ ନ୍ଦ୍ର  ନ୍ଦ୍ବ ନ୍ଧ ନ୍ଧ୍ବ  ନ୍ଧ୍ର ନ୍ନ ପ୍ତ ପ୍ପ ପ୍ଳ ପ୍ସ ବ୍ଜ ବ୍ଦ ବ୍ଧ  ମ୍ପ ମ୍ପ୍ର  ମ୍ଫ ମ୍ବ ମ୍ଭ  ମ୍ମ  ଳ୍କ ଳ୍ଭ   ଳ୍ଳ ଳ୍ପ   ଳ୍ଫ ଲ୍କ ଲ୍ଗ ଲ୍ଲ  ଶ୍ଚ 
ଶ୍ଛ ଶ୍ବ  ଶ୍ଳ ଷ୍କ ଷ୍କ୍ର ଷ୍ଟ ଷ୍ଟ୍ର ଷ୍ଠଷ୍ଣ ଷ୍ପ ଷ୍ପ୍ର ଷ୍ଫ ସ୍କ ସ୍ଖ ସ୍ତ ସ୍ତ୍ର ସ୍ଥ ସ୍ନ ସ୍ପ ସ୍ଫ ସ୍ବ ସ୍ମ ହ୍ନ  ହ୍ମ ହ୍ଲ 

ସାକ୍ଷର	କ୍ଷ୍ଣ

these many strings are broken
Comment 4 Pravin Satpute 2010-08-20 01:45:57 EDT
while more debugging on this i found, most of the prebase combinatoins are kept in above base gsub feature in lohit oriya, which is not as per http://www.microsoft.com/typography/otfntdev/oriyaot/features.aspx

don't know but it still works with all other rendering engine

so i will update lohit oriya fonts so it will work with qt as well.
Comment 5 Pravin Satpute 2010-08-20 06:44:35 EDT
Created attachment 439906 [details]
lohit oriya fonts with fix for qt

I have updated lohit oriya as per ot specs, 
i.e added half and pres feature

please test it and let me know if any problem, so i can modify it accordingly

if no problem i will build it
Comment 6 Manoj Kumar Giri 2010-08-23 03:48:00 EDT
Created attachment 440312 [details]
Screenshot showing some rendering issues.

I've tested the new font. By doing random test i found some issues in kwrite & lokalize. Please checkout the attachment.
Comment 7 Pravin Satpute 2010-08-23 04:34:43 EDT
(In reply to comment #6)
> Created attachment 440312 [details]
> Screenshort showing some rendering issues.

hmm, these combinations were not in my test cases, will be happy if you do some more testing and let me know if there are any other issue

since we should make a decision whether these are from rendereing engine or from fonts

problems mentioned in bug summaries and #3 are clearly from font side, will be happy if you test those and let me know whether they are now working properly or not?

so i can build for at least for earlier mentioned issue and start working on newly test cases given by you
Comment 8 Manoj Kumar Giri 2010-08-23 05:24:57 EDT
(In reply to comment #7)
> problems mentioned in bug summaries and #3 are clearly from font side, will be
> happy if you test those and let me know whether they are now working properly
> or not?
> 
> so i can build for at least for earlier mentioned issue and start working on
> newly test cases given by you

Everything in this list are working fine except  ଙ୍କ୍ଷ
Comment 9 Pravin Satpute 2010-08-25 04:50:52 EDT
(In reply to comment #6)
> Created attachment 440312 [details]
> Screenshot showing some rendering issues.
> 
> I've tested the new font. By doing random test i found some issues in kwrite &
> lokalize. Please checkout the attachment.


i tried for this and this is problem from qt and should fix in qt

i will build lohit with the fix i have given, please report new bug against qt for these test cases
Comment 10 Fedora Update System 2010-08-25 05:38:27 EDT
lohit-oriya-fonts-2.4.3-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lohit-oriya-fonts-2.4.3-5.fc13
Comment 11 Fedora Update System 2010-08-25 05:39:00 EDT
lohit-oriya-fonts-2.4.3-5.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/lohit-oriya-fonts-2.4.3-5.fc14
Comment 12 Fedora Update System 2010-08-25 09:31:58 EDT
lohit-oriya-fonts-2.4.3-5.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lohit-oriya-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/lohit-oriya-fonts-2.4.3-5.fc14
Comment 13 Fedora Update System 2010-09-23 08:34:31 EDT
lohit-oriya-fonts-2.4.3-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Pravin Satpute 2010-10-04 00:42:23 EDT
please reopen bug if still any problem
Comment 15 Manoj Kumar Giri 2010-10-04 06:38:00 EDT
(In reply to comment #14)
> please reopen bug if still any problem

comment #8 reported issue ( ଙ୍କ୍ଷ) is not yet resolved with gtk, but looks to be fixed with qt. Do I have to file a new bug for this?
Comment 16 Pravin Satpute 2010-10-04 06:55:31 EDT
yes, do report
i dont see this is problem from font, as it works with qt
report to pango and see if anything comes up
Comment 17 Ankit Patel 2010-10-04 07:10:02 EDT
Hi,

[test@fedora13 ~]$ # THIS IS WHERE ଙ୍କ୍ଷ was working with GTK but not with QT
[test@fedora13 ~]$ rpm -q pango qt lohit-oriya-fonts
pango-1.28.0-1.fc13.i686
qt-4.6.3-8.fc13.i686
lohit-oriya-fonts-2.4.3-4.fc13.noarch

[test@fedora14 ~]$ # THIS IS WHERE ଙ୍କ୍ଷ is working with QT but not with GTK
[test@fedora14 ~]$ rpm -q pango qt lohit-oriya-fonts
pango-1.28.1-4.fc14.i686
qt-4.7.0-3.fc14.i686
lohit-oriya-fonts-2.4.3-5.fc14.noarch

During this transition (from fedora13 to fedora14), lohit-oriya-fonts were also modified to fix reported Oriya issues.

Pravin, could you please help us finding whether this issue is actually with rendering engines (pango/qt) or with lohit fonts? So that bug could be filed accordingly.

Thanks!
Ankit
Comment 19 Manoj Kumar Giri 2010-10-04 07:53:09 EDT
Hi Ankit/Pravin,

I am using Fedora 14 machine. I have uninstalled lohit-oriya-fonts-2.4.3-5.fc14.noarch and installed lohit-oriya-fonts-2.4.3-4.fc13.noarch without touching pango or qt packages. After this downgrade ଙ୍କ୍ଷ started showing absolutely correct both in QT and GTK (Pango).

Manoj.
Comment 20 A S Alam 2010-10-04 08:27:54 EDT
(In reply to comment #19)
> Hi Ankit/Pravin,
> 
> I am using Fedora 14 machine. I have uninstalled
> lohit-oriya-fonts-2.4.3-5.fc14.noarch and installed
> lohit-oriya-fonts-2.4.3-4.fc13.noarch without touching pango or qt packages.
> After this downgrade ଙ୍କ୍ଷ started showing absolutely correct both in QT and
> GTK (Pango).
> 

Please file a NEW bug against lohit-oriya-fonts.

Thanks
Comment 21 Pravin Satpute 2010-10-04 08:38:52 EDT
(In reply to comment #20)
> (In reply to comment #19)
> > Hi Ankit/Pravin,
> > 
> > I am using Fedora 14 machine. I have uninstalled
> > lohit-oriya-fonts-2.4.3-5.fc14.noarch and installed
> > lohit-oriya-fonts-2.4.3-4.fc13.noarch without touching pango or qt packages.
> > After this downgrade ଙ୍କ୍ଷ started showing absolutely correct both in QT and
> > GTK (Pango).
> > 
> 
> Please file a NEW bug against lohit-oriya-fonts.

yep, go ahead
Comment 22 Manoj Kumar Giri 2010-10-04 08:54:46 EDT
(In reply to comment #21)
> (In reply to comment #20)
> > (In reply to comment #19)
> > > Hi Ankit/Pravin,
> > > 
> > > I am using Fedora 14 machine. I have uninstalled
> > > lohit-oriya-fonts-2.4.3-5.fc14.noarch and installed
> > > lohit-oriya-fonts-2.4.3-4.fc13.noarch without touching pango or qt packages.
> > > After this downgrade ଙ୍କ୍ଷ started showing absolutely correct both in QT and
> > > GTK (Pango).
> > > 
> > 
> > Please file a NEW bug against lohit-oriya-fonts.
> 
> yep, go ahead

If we file a new bug this entire discussion will be gone away and we will have to come to this bug again for the reference. Also the research we have done for this bug will also be lost too. Filing a new bug is not a problem for me, but I don't understand why this issue has to be a new bug while it was already part of this bug as per comment #3 and comment #8.

Moreover, as per comment #16 "this is not a font problem" and comment #21 suggest me to go ahead and file a new bug against font.

This is confusing for a LM!

Manoj
Comment 23 Pravin Satpute 2010-10-04 09:20:32 EDT
see https://bugzilla.redhat.com/show_bug.cgi?id=623995#c0

it was mentioned earlier this is not working on kwrite and now the problem it is not working on gedit

if the originally filed bug case and present problem are same please reopen this bug else open new bug

i agreed on https://bugzilla.redhat.com/show_bug.cgi?id=623995#c21, since that is first step to start digging on problem, even if one first report in pango or fonts, or gnome, input method

fix will go in component where it is required and bugzilla has given us excellent options of changing component

i am perfectly fine with all the case report bug or not, when i will get time i will fix bug and for keeping reference will report bug if there is not.
Comment 24 A S Alam 2010-10-04 09:29:01 EDT
> 
> If we file a new bug this entire discussion will be gone away and we will have
> to come to this bug again for the reference. Also the research we have done for
> this bug will also be lost too. Filing a new bug is not a problem for me, but I
> don't understand why this issue has to be a new bug while it was already part
> of this bug as per comment #3 and comment #8.

I think if 'clone' bug 'entire discussion will be there. (bug #639977 clone of this bug)

> 
> Moreover, as per comment #16 "this is not a font problem" and comment #21
> suggest me to go ahead and file a new bug against font.
> 
 with comment #19, you did a very helpful work to confirm it is font issue.
Rendering bugs are always confusing not only for LM, but QA and developer also.
Comment 25 Manoj Kumar Giri 2010-10-04 09:48:57 EDT
Thanks a lot Alam!
Comment 26 Fedora Update System 2010-10-14 19:00:44 EDT
lohit-oriya-fonts-2.4.3-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.