Bug 624047 - SELinux is preventing /bin/login "remove_name" access on 5.
Summary: SELinux is preventing /bin/login "remove_name" access on 5.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:01626509ecc...
Keywords:
: 624049 624050 624051 624052 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-13 14:10 UTC by Gavin Romig-Koch
Modified: 2010-09-01 06:03 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-09-01 06:03:21 UTC


Attachments (Terms of Use)

Description Gavin Romig-Koch 2010-08-13 14:10:52 UTC
Summary:

SELinux is preventing /bin/login "remove_name" access on 5.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by login. It is not expected that this access is
required by login and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:local_login_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cgroup_t:s0
Target Objects                5 [ dir ]
Source                        login
Source Path                   /bin/login
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           util-linux-ng-2.18-3.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.8.8-10.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35-3.fc14.x86_64 #1 SMP Fri
                              Aug 6 19:41:28 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Thu 12 Aug 2010 01:33:57 PM EDT
Last Seen                     Thu 12 Aug 2010 01:33:57 PM EDT
Local ID                      1d7962f4-9e4f-45d3-a9ad-71ddb9bd8204
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1281634437.187:129): avc:  denied  { remove_name } for  pid=1147 comm="login" name="5" dev=cgroup ino=58375 scontext=system_u:system_r:local_login_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1281634437.187:129): avc:  denied  { rmdir } for  pid=1147 comm="login" name="5" dev=cgroup ino=58375 scontext=system_u:system_r:local_login_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1281634437.187:129): arch=c000003e syscall=84 success=yes exit=0 a0=13f9160 a1=0 a2=13f917c a3=8 items=0 ppid=1 pid=1147 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=5 comm="login" exe="/bin/login" subj=system_u:system_r:local_login_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,login,local_login_t,cgroup_t,dir,remove_name
audit2allow suggests:

#============= local_login_t ==============
allow local_login_t cgroup_t:dir { remove_name rmdir };

Comment 1 Daniel Walsh 2010-08-13 17:15:31 UTC
*** Bug 624049 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Walsh 2010-08-13 17:15:43 UTC
*** Bug 624050 has been marked as a duplicate of this bug. ***

Comment 3 Daniel Walsh 2010-08-13 17:15:54 UTC
*** Bug 624051 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Walsh 2010-08-13 17:16:04 UTC
*** Bug 624052 has been marked as a duplicate of this bug. ***

Comment 5 Daniel Walsh 2010-08-13 18:11:58 UTC
You can add these rules for now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Fixed in selinux-policy-3.8.8-14.fc14

Comment 6 Fedora Update System 2010-08-25 03:11:37 UTC
selinux-policy-3.8.8-20.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/selinux-policy-3.8.8-20.fc14

Comment 7 Fedora Update System 2010-08-25 13:31:22 UTC
selinux-policy-3.8.8-20.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.8.8-20.fc14

Comment 8 Fedora Update System 2010-08-26 18:37:42 UTC
selinux-policy-3.8.8-20.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.8.8-20.fc14

Comment 9 Fedora Update System 2010-09-01 06:01:59 UTC
selinux-policy-3.8.8-20.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.