Bug 624051 - SELinux is preventing /bin/login "setattr" access on 5.
SELinux is preventing /bin/login "setattr" access on 5.
Status: CLOSED DUPLICATE of bug 624047
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
14
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:70d6db63ba0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-13 10:12 EDT by Gavin Romig-Koch
Modified: 2010-08-13 13:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 13:15:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gavin Romig-Koch 2010-08-13 10:12:16 EDT
Summary:

SELinux is preventing /bin/login "setattr" access on 5.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by login. It is not expected that this access is
required by login and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:local_login_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cgroup_t:s0
Target Objects                5 [ dir ]
Source                        login
Source Path                   /bin/login
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           util-linux-ng-2.18-3.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.8.8-10.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35-3.fc14.x86_64 #1 SMP Fri
                              Aug 6 19:41:28 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Thu 12 Aug 2010 11:57:08 AM EDT
Last Seen                     Thu 12 Aug 2010 01:33:53 PM EDT
Local ID                      e9a07263-d7c8-40aa-b1a4-0fea124b4d1c
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1281634433.265:122): avc:  denied  { setattr } for  pid=1147 comm="login" name="5" dev=cgroup ino=58375 scontext=system_u:system_r:local_login_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1281634433.265:122): arch=c000003e syscall=90 success=yes exit=0 a0=13f4210 a1=1ed a2=0 a3=ffffffff items=0 ppid=1 pid=1147 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=tty2 ses=5 comm="login" exe="/bin/login" subj=system_u:system_r:local_login_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,login,local_login_t,cgroup_t,dir,setattr
audit2allow suggests:

#============= local_login_t ==============
allow local_login_t cgroup_t:dir setattr;
Comment 1 Daniel Walsh 2010-08-13 13:15:54 EDT

*** This bug has been marked as a duplicate of bug 624047 ***

Note You need to log in before you can comment on or make changes to this bug.