Bug 624180 - Unable to start file-roller
Summary: Unable to start file-roller
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: file-roller
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 624202 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-13 22:40 UTC by Vaclav "sHINOBI" Misek
Modified: 2010-08-17 17:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-17 17:05:05 UTC
Type: ---


Attachments (Terms of Use)
Traceback from gdb (1.89 KB, text/plain)
2010-08-14 10:00 UTC, Martin Sourada
no flags Details

Description Vaclav "sHINOBI" Misek 2010-08-13 22:40:02 UTC
Description of problem:
File-roller can't be run.

Version-Release number of selected component (if applicable):
file-roller-2.31.5-2.fc14

How reproducible:
Start file-roller from terminal.

Actual results:
$ file-roller 
Gtk-Message: Failed to load module "atk-bridge": libatk-bridge.so: cannot open shared object file: No such file or directory

(file-roller:5492): Bonobo-WARNING **: Bonobo must be initialized before use

GLib-GIO-ERROR **: Settings schema 'org.gnome.nautilus.preferences' is not installed

aborting...
Trace/breakpoint trap

Comment 1 Gene Snider 2010-08-13 23:28:32 UTC
I see the same failure here after today's update.  Since both file-roller and nautilus were updated, I'm not sure which package is at the root of the problem.

Gene

Comment 2 Gene Snider 2010-08-13 23:42:48 UTC
Downgrading nautilus, nautilus-extensions, and file-roller restores the functionality of file-roller.

Gene

Comment 3 Martin Sourada 2010-08-14 10:00:49 UTC
Created attachment 438790 [details]
Traceback from gdb

Here's the traceback from gdb. Apparently the scheme file is not installed -- perhaps a bug in the said scheme file, or in installing it in post?

Comment 4 Matthias Clasen 2010-08-16 14:31:30 UTC
This is caused by nautilus going back to using gconf in 2.32.
It will be fixed in the next release of file-roller

Comment 5 Matthias Clasen 2010-08-16 14:34:10 UTC
*** Bug 624202 has been marked as a duplicate of this bug. ***

Comment 6 Martin Sourada 2010-08-17 10:45:29 UTC
Seems to be fixed in file-roller-2.31.90-1.fc14.i686.

Comment 7 Nicolas Mailhot 2010-08-17 17:05:05 UTC
Confirmed, thanks


Note You need to log in before you can comment on or make changes to this bug.