Bug 624493 - Unable copy rebuild images from remote client.
Summary: Unable copy rebuild images from remote client.
Status: CLOSED DUPLICATE of bug 524983
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness)   
(Show other bugs)
Version: 5.3
Hardware: All Linux
low
urgent
Target Milestone: ---
: 6.0
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-16 16:08 UTC by chau nguyen
Modified: 2011-04-27 15:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-27 15:41:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
FV_Network test output (1.27 KB, application/octet-stream)
2010-08-16 18:12 UTC, chau nguyen
no flags Details

Description chau nguyen 2010-08-16 16:08:05 UTC
Description of problem:  
Unable copy rebuild images from remote client.  All fv tests have no access to download rebuild images from remote client that cause the test to be fail with 403 Forbidden error message. 

We would like to know what is correct way to create remote client that allow downloading rebuild images from test server.

How reproducible:
1.  Install RH 6 snapshot 8 x86 on remote client
2.  Install v7 (version 7-1.2-12)test kit
3.  Run the command <v7 server start>.
4.  Copy rebuild images to /var/v7/fv-images
5.  Open Firefox
6.  Type http://localhost/v7/fv-images and got 403   
    Forbidden error message.


Steps to Reproduce:
1.  Install RH 6 snapshot 8 x86 on remote client
2.  Install v7 (version 7-1.2-12)test kit
3.  Run the command <v7 server start>.
4.  Copy rebuild images to /var/v7/fv-images
5.  Open Firefox
6.  Type http://localhost/v7/fv-images and got 403   
    Forbidden error message.


Actual results:  
   Not allow access to rebuild images from network 
   client

Expected results:
    Allow access to rebuild images from network 
    Client

Additional info:
Configuration
System:  ML370 G7
System BIOS: P63 05/14/2010
OS:  Rathat 6 snapshot 8
Test version: v7-1.2.12

Here are configurations that we have tried on remote client:
- RH 5.4 x86 with v7-1.1-23 ---Failed
- RH 5.4 x86 with v7-1.1-24 ---Failed
- RH 5.5 x86 with v7-1.1-24 ---Failed
- RH 6 SS8 x86 with v7-1.2-12 ---Failed

Comment 4 chau nguyen 2010-08-16 18:12:21 UTC
Created attachment 439003 [details]
FV_Network test output

Comment 6 Greg Nichols 2010-08-16 19:02:30 UTC
Please try setting the selinux context via:

> chcon -R -t httpd_sys_content_t /var/v7

Thanks!

Comment 11 chau nguyen 2010-08-20 20:33:29 UTC
Workaround fixed this issue.  Thank

Comment 15 Greg Nichols 2011-04-27 15:41:29 UTC

*** This bug has been marked as a duplicate of bug 524983 ***


Note You need to log in before you can comment on or make changes to this bug.