Bug 62453 - rsync crashes on an attempt to run rsh.
rsync crashes on an attempt to run rsh.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rsync (Show other bugs)
7.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
: 62452 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-01 01:16 EST by Dan Naumov
Modified: 2014-03-16 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 11:32:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Naumov 2002-04-01 01:16:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020314

Description of problem:
rsync-2.4.6-13 crashes on an attempt to connect to an anonymous FTP site when
using the "-vr --delete" options.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enter the following into a term: "rsync -vr --delete
ftp://anonymous@ftp.funet.fi:21/pub/mirrors/ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/


Actual Results:  Got an error:

Failed to exec rsh : No such file or directory
unexpected EOF in read_timeout

Expected Results:  Expected Results:  Should've connected and downloaded the
files ? I dunno, I just tryed rsync for the first time and it broke on me :o

Additional info:

I believe this problem is related to Bug #62452
(http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=62452) which I reported
earlier when I ran into a similar problem, but only with a newer rsync package
from rawhide.
Comment 1 Bill Nottingham 2002-04-01 11:32:46 EST
*** Bug 62452 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2002-04-01 11:33:03 EST
That means it couldn't exec rsh to connect to the other end, most likely because
you don't have it installed.

Note You need to log in before you can comment on or make changes to this bug.