This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 624773 - Failed to load configuration for NetworkManager-by-dbus.service: No such file or directory
Failed to load configuration for NetworkManager-by-dbus.service: No such file...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 625386 625837 (view as bug list)
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-08-17 14:03 EDT by Nicolas Mailhot
Modified: 2011-04-20 17:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-20 17:55:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-08-17 14:03:17 EDT
On boot:

Aug 17 19:51:50  init[1]: Failed to load configuration for NetworkManager-by-dbus.service: No such file or directory
Aug 17 19:51:50  init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
Aug 17 19:51:50  kernel: init[1]: Failed to load configuration for NetworkManager-by-dbus.service: No such file or directory
Aug 17 19:51:50  kernel: init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
Aug 17 19:51:53  dbus: [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.62" (uid=500 pid=1925 comm="nautilus) interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply=0 destination=":1.20" (uid=0 pid=1519 comm="/usr/sbin/console-kit-daemon))
Aug 17 19:52:48 arekh init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
Aug 17 19:52:48 arekh kernel: init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument

Version-Release number of selected component (if applicable):
dbus-1.3.2-0.1.885483.fc14.x86_64
dbus-c++-0.5.0-0.11.20090203git13281b3.fc13.x86_64
dbus-glib-0.86-4.fc14.x86_64
dbus-libs-1.3.2-0.1.885483.fc14.x86_64
dbus-python-0.83.0-7.fc14.x86_64
dbus-x11-1.3.2-0.1.885483.fc14.x86_64
NetworkManager-0.8.1-4.git20100817.fc14.x86_64
NetworkManager-glib-0.8.1-4.git20100817.fc14.x86_64
NetworkManager-gnome-0.8.1-4.git20100817.fc14.x86_64
systemd-7-3.fc14.x86_64
systemd-gtk-7-3.fc14.x86_64
systemd-sysvinit-7-3.fc14.x86_64
systemd-units-7-3.fc14.x86_64
Comment 1 Joachim Frieben 2010-08-18 05:19:45 EDT
Apart from message

  NetworkManager-by-dbus.service: No such file or directory

same issue here. The latest update of NetworkManager fails to bring up the network

  init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
  kernel: init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
  NetworkManager[2814]: <info> NetworkManager (version 0.8.1-4.git20100817.fc14) is starting...
  NetworkManager[2814]: <info> Read config file /etc/NetworkManager/NetworkManager.conf
  NetworkManager[2814]: <info> trying to start the modem manager...
  modem-manager: ModemManager (version 0.4-4.git20100720.fc14) starting...
  init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
  kernel: init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
Comment 2 Joachim Frieben 2010-08-18 05:25:00 EDT
Downgrading package NetworkManager to version 0.8.1-1.fc14 allows to restore network connectivity.
Comment 3 Vaclav "sHINOBI" Misek 2010-08-18 06:43:36 EDT
BTW NetWorkManager can be started through "service NetworkManager start", only systemd integration is broken.
Comment 4 atswartz 2010-08-18 13:43:50 EDT
I am also getting this on rawhide: NetworkManager-0.8.1-4.git20100817.fc15.x86_64
init[1]: Failed to load configuration for NetworkManager-by-dbus.service: No such file or directory
init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
kernel: init[1]: Failed to load configuration for NetworkManager-by-dbus.service: No such file or directory
kernel: init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
kernel: init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
kernel: init[1]: D-Bus activation failed for NetworkManager-by-dbus.service: Invalid argument
# /etc/rc.d/init.d/NetworkManager restart
Stopping NetworkManager daemon:                            [FAILED]
Setting network parameters...                              [  OK  ]
Starting NetworkManager daemon:                            [  OK  ]
Comment 5 Rahul Sundaram 2010-08-19 07:28:57 EDT
Workaround

# systemctl enable NetworkManager.service
# systemctl start NetworkManager.service
Comment 6 Joachim Frieben 2010-08-19 10:48:08 EDT
No problems anymore after upgrading to NetworkManager-0.8.1-5.git20100818.fc14.
Comment 7 atswartz 2010-08-19 11:06:07 EDT
(In reply to comment #5)
> Workaround
> 
> # systemctl enable NetworkManager.service
> # systemctl start NetworkManager.service

This does work.
Comment 8 Vaclav "sHINOBI" Misek 2010-08-19 12:08:22 EDT
NetworkManager-0.8.1-5.git20100818.fc14 fixed the problem for me as well
Comment 9 Fedora Update System 2010-08-19 16:22:05 EDT
NetworkManager-0.8.1-5.git20100818.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-5.git20100818.fc14
Comment 10 Rahul Sundaram 2010-08-20 16:42:14 EDT
*** Bug 625837 has been marked as a duplicate of this bug. ***
Comment 11 Rahul Sundaram 2010-08-20 16:42:25 EDT
*** Bug 625386 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2010-08-23 21:19:58 EDT
NetworkManager-0.8.1-5.git20100818.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Stefan Becker 2010-08-25 09:16:34 EDT
Just did a fresh preupgrade from F13 -> F14 and a yum update after that:

NetworkManager-0.8.1-5.git20100818.fc14.i686
NetworkManager-glib-0.8.1-5.git20100818.fc14.i686
NetworkManager-gnome-0.8.1-5.git20100818.fc14.i686
NetworkManager-vpnc-0.8.1-1.fc14.i686
systemd-7-3.fc14.i686
systemd-sysvinit-7-3.fc14.i686

I have the latest NetworkManager package but the problem still exists.

/var/log/messages after boot:

Aug 25 15:42:47 l3f1199 init[1]: Failed to load configuration for dbus-org.freedesktop.NetworkManager.service: No such file or directory
Aug 25 15:42:47 l3f1199 init[1]: D-Bus activation failed for dbus-org.freedesktop.NetworkManager.service: Invalid argument
Aug 25 15:42:47 l3f1199 kernel: init[1]: Failed to load configuration for dbus-org.freedesktop.NetworkManager.service: No such file or directory
Aug 25 15:42:47 l3f1199 kernel: init[1]: D-Bus activation failed for dbus-org.freedesktop.NetworkManager.service: Invalid argument
Aug 25 15:42:49 l3f1199 init[1]: D-Bus activation failed for dbus-org.freedesktop.NetworkManager.service: Invalid argument
Aug 25 15:42:49 l3f1199 kernel: init[1]: D-Bus activation failed for dbus-org.freedesktop.NetworkManager.service: Invalid argument

The systemctl workaround works for me too. I still have to test if it fixes the problem permanently, i.e. after a reboot.
Comment 14 Will Woods 2010-08-25 10:35:09 EDT
Just doing a yum update isn't going to cause NetworkManager to magically start up. You'll need to reboot after the update to NetworkManager-0.8.1-5.git20100818.fc14 to actually see the fix.
Comment 15 Stefan Becker 2010-08-25 11:09:05 EDT
Sorry, I forgot to mention that I *did* reboot after "yum update" and still the problem wasn't fixed. Only the manual systemctl commands fixed it for my machine.
Comment 16 Dan Williams 2011-04-20 17:55:33 EDT
Not an issue anymore as f14 didn't ship with systemd, and this issue is not present on F15 where systemd is used.

Note You need to log in before you can comment on or make changes to this bug.