Bug 624817 - jboss-as-5 plugin: JmxConnectionHelper.loadConnection() should set JAR_TEMP_DIR EMS control prop to PC temp dir even when PC is running in embedded mode (i.e. in the admin-console)
Summary: jboss-as-5 plugin: JmxConnectionHelper.loadConnection() should set JAR_TEMP_D...
Status: CLOSED WONTFIX
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
(Show other bugs)
Version: 3.0.0
Hardware: All All
high
high vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon30-bugs
TreeView+ depends on / blocked
 
Reported: 2010-08-17 20:34 UTC by Ian Springer
Modified: 2013-08-06 00:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 648783 (view as bug list)
Environment:
Last Closed: 2011-09-27 01:49:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Springer 2010-08-17 20:34:00 UTC
Otherwise, EMS defaults to using /tmp for its temporary per-classloader copy of the ems-impl-XXX.jar, which is bad, because it makes it hard to define an access control policy for that jar.

Comment 1 Ian Springer 2010-08-17 20:42:09 UTC
Fixed in master (ed986ce) and release-3.0.0 (c450bad).

Comment 2 Corey Welton 2011-01-04 04:38:55 UTC
Need repro steps - possibly on EC team's plate?

Comment 3 Ian Springer 2011-01-04 15:12:23 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=648783 has repro steps and was QA'ed by Ondra. We will not be able to QA the fix that went into master until embjopr is upgraded to depend on RHQ 4.0.x. I'll switch this issue back to ON_DEV for now.

Comment 4 Corey Welton 2011-01-06 15:18:06 UTC
removing blocker against jon241 version of this bug


Note You need to log in before you can comment on or make changes to this bug.