Bug 648783 - JON241: jboss-as-5 plugin: JmxConnectionHelper.loadConnection() should set JAR_TEMP_DIR EMS control prop to PC temp dir even when PC is running in embedded mode (i.e. in the admin-console)
JON241: jboss-as-5 plugin: JmxConnectionHelper.loadConnection() should set JA...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
All All
low Severity low (vote)
: ---
: ---
Assigned To: Charles Crouch
Ondřej Žižka
:
Depends On:
Blocks: 725852 jon241-bugs
  Show dependency treegraph
 
Reported: 2010-11-02 01:27 EDT by Charles Crouch
Modified: 2015-02-01 18:26 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 624817
Environment:
Last Closed: 2013-08-31 07:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2010-11-02 01:27:04 EDT
+++ This bug was initially created as a clone of Bug #624817 +++

Otherwise, EMS defaults to using /tmp for its temporary per-classloader copy of the ems-impl-XXX.jar, which is bad, because it makes it hard to define an access control policy for that jar.

--- Additional comment from ian.springer@redhat.com on 2010-08-17 16:42:09 EDT ---

Fixed in master (ed986ce) and release-3.0.0 (c450bad).
Comment 1 Charles Crouch 2010-11-02 01:27:25 EDT
Test for JON2.4.1
Comment 2 Rajan Timaniya 2010-11-08 05:25:51 EST
Hi Ian,

Can you please provide steps to test the bug and expected result?
Comment 3 Ian Springer 2010-11-08 08:30:21 EST
Though this change was in the RHQ plugin container, it only changes behavior when the plugin container is deployed inside EmbJopr (i.e. the JBAS admin console); there is no change in behavior when deployed inside the RHQ Agent, so there's nothing to test on that end.
Comment 4 Charles Crouch 2010-11-09 19:39:36 EST
Ondrej 
Can you test that this bug is fixed in the EAP5.1 release of the console?
Thanks
Comment 5 Ondřej Žižka 2010-11-11 07:02:25 EST
Charles, I'll need test instructions for this, thx.
Comment 6 Corey Welton 2010-11-17 16:23:18 EST
Ian, can you provide repro steps?
Comment 7 Ian Springer 2010-12-02 10:41:44 EST
REPRO STEPS
-----------
1) Start up EAP 5.1.
2) Log into admin console.
3) Select the JBoss AS Server resource in the admin console.
4) Look in JBOSS_HOME/server/default/tmp/embjopr/ and confirm that there's an org-mc4j-ems-implXXXXXX.jar file in there, e.g.:

org-mc4j-ems-impl1256585583900479844.jar


If you see that jarfile under /tmp instead, then the issue has not been fixed.
Comment 8 Sunil Kondkar 2010-12-06 04:31:30 EST
Verified on Jon241 build#35

Stated EAP5.1 and logged in to the admin console. After login observed that the directory JBOSS_HOME/server/default/tmp/embjopr gets created and it displays below file:
org-mc4j-ems-impl2348731868522119396.jar

The /tmp directory does not display above file.
Marking this as verified.

Note You need to log in before you can comment on or make changes to this bug.