Bug 624925 - Update V2V documentation in light of BZ 617635
Summary: Update V2V documentation in light of BZ 617635
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Virtualization_Administration_Guide   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: David Jorm
QA Contact: ecs-bugs
URL:
Whiteboard:
Keywords: Documentation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-18 05:59 UTC by David Jorm
Modified: 2014-10-21 00:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 15:37:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Jorm 2010-08-18 05:59:24 UTC
Request email from Matthew Booth:

David,

I'm just about to submit a build including a fix for:
https://bugzilla.redhat.com/show_bug.cgi?id=617635

This unfortunately impacts the documentation in a few ways. Firstly
Windows drivers are no longer shipped in the virt-v2v package: they are
now provided by the virtio-win package. They are, however, referenced in
the updated default configuration file. If the user attempts to convert
a Windows guest, but doesn't have virtio-win installed, they will get an
error message about missing files. Ideally, virtio-win would be a
dependency of virt-v2v, but we can't do this because virtio-win is in
RHEL 6 Supplementary. This means we need to highlight this requirement
in the documentation.

Secondly, the official virtio-win package doesn't include a driver for
Windows XP. This means we don't support Windows XP.

Lastly, an incompatible change is required to the default configuration
file. This won't impact new installations, but anybody upgrading from a
beta will be impacted. I suggest a release note for this.

The most important change is obviously the first one. Will you be able
to get this in?

Thanks,

Matt
-- 
Matthew Booth, RHCA, RHCSS
Red Hat Engineering, Virtualisation Team

GPG ID:  D33C3490
GPG FPR: 3733 612D 2D05 5458 8A8A 1600 3441 EA19 D33C 3490

Comment 2 David Jorm 2010-08-19 03:33:33 UTC
1) The virtio-win requirement has been listed under both "Preparing to convert
a virtualized guest running Windows" and "Configuration changes for Windows
virtualized guests", alongside the libguestfs-winsupport requirement.

2) The list of supported Windows platforms is now:
Windows Vista, Windows 7, Windows Server 2003 and Windows Server 2008

3) Release notes for RHEL 6 are handled by a separate team. I am advised by
them that this will be a technical note rather than a release note. BZ#617635
has good technical notes filled in and technical_note? set - this is all you
need to do, it will be automatically included in the RHEL 6 technical notes.

The updated guide is now up on doc stage:
http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Virtualization/chap-Virtualization-v2v-migration.html

Brew build ID: Red_Hat_Enterprise_Linux-Virtualization-6-web-en-US-0-67.el5

Changes committed to git.

Comment 3 Matthew Booth 2010-08-19 08:32:34 UTC
Thanks, David. Looks good.

Comment 4 Andrew Ross 2010-08-19 21:24:49 UTC
In light of comment#3 will move to verified.

Red_Hat_Enterprise_Linux-Virtualization-6-web-en-US-0-67.el5

Comment 5 releng-rhel@redhat.com 2010-11-11 15:37:44 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.