Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 624999 - condor_job_server exits without JOB_SERVER_LOG configured
condor_job_server exits without JOB_SERVER_LOG configured
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor-qmf (Show other bugs)
1.3
All Linux
low Severity medium
: 1.3.2
: ---
Assigned To: Matthew Farrellee
Jan Sarenik
: Reopened
: 616727 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-18 06:29 EDT by Jan Sarenik
Modified: 2011-02-15 07:16 EST (History)
2 users (show)

See Also:
Fixed In Version: condor-qmf-7.4.5-0.1
Doc Type: Bug Fix
Doc Text:
Previously, condor_job_server could have exited with an exception. This occurred if no JOB_SERVER_LOG value was defined. With this update, JOB_SERVER_LOG contains a default setting and there is no need to configure the parameter.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-15 07:16:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0217 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging and Grid bug fix and enhancement update 2011-02-15 07:10:15 EST

  None (edit)
Description Jan Sarenik 2010-08-18 06:29:21 EDT
# condor_job_server 
ERROR "No 'JOB_SERVER_LOG' parameter specified." at line 161 in file dprintf_config.c
Aborted (core dumped)

condor-qmf-7.4.4-0.9.el5

How reproducible: 100%
Comment 1 Matthew Farrellee 2010-08-18 07:37:37 EDT
Were you using wallaby to configure the JobServer?

If not, you must specify JOB_SERVER_LOG in configuration yourself.

Note:
 o The condor-qmf package could lay down config that has JOB_SERVER_LOG set
 o The core probably comes from ABORT_ON_EXCEPTION, please verify
Comment 2 Jan Sarenik 2010-08-18 07:49:29 EDT
I am aware of not using wallaby. The main reason for reporting
it is the coredump. I do not think condor_job_server operates
accordingly to the problem and that it uses the right way to
say a line in config file is missing.
Comment 3 Jan Sarenik 2010-08-18 08:27:55 EDT
Yes, it is exception, GDB backtrace says:

Thread 1 (Thread 3965):
#0  0x00002b673e927265 in raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00002b673e928d10 in abort () at abort.c:88
#2  0x00000000004a2d31 in _EXCEPT_ (
    fmt=0x546513 "No '%s' parameter specified.") at except.c:89
#3  0x00000000004a4c5a in dprintf_config (subsys=0x4f27c90 "JOB_SERVER")
    at dprintf_config.c:161
#4  0x000000000049dbf5 in main (argc=1, argv=0x7fffe2a454e8)
    at daemon_core_main.cpp:1850
Comment 4 Matthew Farrellee 2010-08-18 09:42:07 EDT
core is a false positive because of ABORT_ON_EXCEPTION=TRUE

The condor-qmf package should provide config that avoids this EXCEPT.
Comment 5 Jan Sarenik 2010-08-18 09:48:21 EDT
Aah, thank you for explanation. Closing as NOTABUG.
Comment 6 Jan Sarenik 2010-08-18 09:50:11 EDT
Sorry, only when you wrote about it I realized that lately
I added line "ABORT_ON_EXCEPTION=True" to the config file...
Comment 7 Jan Sarenik 2010-08-18 09:54:26 EDT
Ressurecting as this bug will serve "as an RFE for better OOTB config"
as Matt wrote.
Comment 8 Matthew Farrellee 2010-11-03 12:23:43 EDT
*** Bug 616727 has been marked as a duplicate of this bug. ***
Comment 9 Matthew Farrellee 2010-11-03 12:24:31 EDT
Related - https://condor-wiki.cs.wisc.edu/index.cgi/tktview?tn=61
Comment 10 Matthew Farrellee 2010-11-18 11:59:22 EST
Following patch will be in a build post 7.4.4-0.17, with the next pull of the V7_4-QMF-branch

commit 490ff70cd9cb56e7f2574ca677fc2d2843d0c760
Author: Matthew Farrellee <matt@redhat>
Date:   Thu Nov 18 11:58:14 2010 -0500

    Added a JOB_SERVER_LOG default to 60condor-qmf.conf, for BZ624999

diff --git a/src/condor_examples/60condor-qmf.config b/src/condor_examples/60condor-qmf.conf
index d6303af..1351268 100644
--- a/src/condor_examples/60condor-qmf.config
+++ b/src/condor_examples/60condor-qmf.config
@@ -18,3 +18,8 @@ SCHEDD.PLUGINS = $(LIB)/plugins/MgmtScheddPlugin-plugin.so
 
 # condor_startd: advertises slots
 STARTD.PLUGINS = $(LIB)/plugins/MgmtStartdPlugin-plugin.so
+
+
+# Defaults needed for the JOB_SERVER
+JOB_SERVER_LOG = $(LOG)/JobServerLog
+
Comment 11 Matthew Farrellee 2010-11-18 17:04:57 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
C: No default exists for JOB_SERVER_LOG
C: The condor_job_server will exit without a configured JOB_SERVER_LOG
F: The packaged /etc/condor/config.d/60condor-qmf.config provides a default JOB_SERVER_LOG of $(LOG)/JobServerLog
R: There is no need to configure a JOB_SERVER_LOG
Comment 13 Jan Sarenik 2011-01-12 09:14:59 EST
Verified in condor-qmf-7.4.5-0.6.el5

$ cat /etc/condor/config.d/60condor-qmf.config | grep JOB
# Defaults needed for the JOB_SERVER
JOB_SERVER_LOG = $(LOG)/JobServerLog
Comment 14 Eva Kopalova 2011-02-09 11:33:31 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1 @@
-C: No default exists for JOB_SERVER_LOG
+Previously, condor_job_server could have exited with an exception. This occurred if no JOB_SERVER_LOG value was defined. With this update, JOB_SERVER_LOG contains a default setting and there is no need to configure the parameter.-C: The condor_job_server will exit without a configured JOB_SERVER_LOG
-F: The packaged /etc/condor/config.d/60condor-qmf.config provides a default JOB_SERVER_LOG of $(LOG)/JobServerLog
-R: There is no need to configure a JOB_SERVER_LOG
Comment 15 errata-xmlrpc 2011-02-15 07:16:46 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0217.html

Note You need to log in before you can comment on or make changes to this bug.