Bug 62525 - "man builtins" gets an error.
"man builtins" gets an error.
Status: CLOSED DUPLICATE of bug 19555
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-04-01 22:12 EST by Rich Morin
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-09-25 21:55:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rich Morin 2002-04-01 22:12:00 EST
From Bugzilla Helper:

User-Agent: Mozilla/4.0 (compatible; MSIE 5.13; Mac_PowerPC)

Description of problem:

Typing "man builtins" generates the error
"<standard input>:14: realpath on `bash.1' failed: No such file or directory"

This seems to be caused by the fact that builtins.1.gz contains
the line ".so bash.1", but there is no such file (only bash.1.gz).
My suspicion is that man(1) can handle a ".so" line when it is
the only line in the file, but has problems when there is some
preceding troff text (i.e., I think some kludge is incomplete. :-).

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:

1.man builtins




Actual Results:  <standard input>:14: realpath on `bash.1' failed: No such 
file or directory

BASH_BUILTINS(1)                                 BASH_BUILTINS(1)


       bash,  :,  .,  alias,  bg, bind, break, builtin, case, cd,

       command, continue, declare, dirs,  disown,  echo,  enable,


Expected Results:  The man page for bash(1) should have followed the 
page I saw.

Additional info:
Comment 1 Tim Waugh 2002-10-07 07:15:39 EDT

*** This bug has been marked as a duplicate of 19555 ***

Note You need to log in before you can comment on or make changes to this bug.