Bug 625505 - file /usr/share/foomatic/db/source/printer/Samsung-CLP-300.xml from install of foomatic-db-4.0-19.20100819.fc14.noarch conflicts with file from package foo2qpdl-0.20080826-3.fc11.x86_64
file /usr/share/foomatic/db/source/printer/Samsung-CLP-300.xml from install o...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: foomatic-db (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-08-19 12:37 EDT by Nicolas Mailhot
Modified: 2010-09-23 08:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: foomatic-db-4.0-20.20100819.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-17 14:25:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-08-19 12:37:52 EDT
Transaction Check Error:
  file /usr/share/foomatic/db/source/printer/Samsung-CLP-300.xml from install of foomatic-db-4.0-19.20100819.fc14.noarch conflicts with file from package foo2qpdl-0.20080826-3.fc11.x86_64
  file /usr/share/foomatic/db/source/printer/Samsung-CLP-315.xml from install of foomatic-db-4.0-19.20100819.fc14.noarch conflicts with file from package foo2qpdl-0.20080826-3.fc11.x86_64
Comment 1 Jiri Popelka 2010-08-20 07:06:01 EDT
Regression (bug #208851, comment #8).
Comment 2 Fedora Update System 2010-08-20 13:38:51 EDT
foomatic-db-4.0-20.20100819.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/foomatic-db-4.0-20.20100819.fc13
Comment 3 Fedora Update System 2010-08-20 13:47:34 EDT
foomatic-db-4.0-20.20100819.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/foomatic-db-4.0-20.20100819.fc14
Comment 4 Fedora Update System 2010-08-20 14:43:37 EDT
foomatic-db-4.0-20.20100819.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update foomatic-db'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/foomatic-db-4.0-20.20100819.fc14
Comment 5 Adam Williamson 2010-08-24 14:33:17 EDT
foo2qpdl doesn't seem to have been updated in a long time (see that it's an fc11 build from 2008). is just removing the definitions from foomatic-db the 'right' fix, given the apparently unmaintained state of foo2qpdl? or is this just a simple definition that's had no reason to change since 2008?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Tim Waugh 2010-08-25 04:52:26 EDT
It's had no reason to change.  It's also a question of data ownership -- strictly speaking, packages providing foomatic drivers also need to own the foomatic XML files describing them.

Unfortunately this was never really decided on upstream and so there is a lot of confusion about it, particular when it comes to XML describing printers only supported by particular drivers.

In general it's better to avoid writing foomatic drivers altogether: the CUPS native driver architecture is more clearly documented and works in a more straightforward fashion.
Comment 7 Fedora Update System 2010-09-17 14:25:47 EDT
foomatic-db-4.0-20.20100819.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-09-23 08:35:14 EDT
foomatic-db-4.0-20.20100819.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.