Bug 625529 - xterm escape codes in 'screen' session cause garbled display
xterm escape codes in 'screen' session cause garbled display
Status: CLOSED DUPLICATE of bug 624900
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-19 13:59 EDT by Matthew Miller
Modified: 2010-08-20 03:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 03:02:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2010-08-19 13:59:59 EDT
Some time starting recently in rawhide (could be mid-July update to ncurses), the "screen" command started behaving differently/badly. Specifically, the $PROMPT_COMMAND which contains sequences to change the xterm title doesn't work and instead causes garbled output on the display.

This problem happens regardless of where the screen session is running: same thing in an xterm, gnome-terminal, vt, or ssh'd in.

The screen program itself hasn't changed in over a year, which is why I'm wildly casting blame here.
Comment 1 Miroslav Lichvar 2010-08-20 03:02:13 EDT

*** This bug has been marked as a duplicate of bug 624900 ***

Note You need to log in before you can comment on or make changes to this bug.