Bug 624900 - Regression in screen with bash
Regression in screen with bash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
: 624671 625529 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 22:56 EDT by Pete Zaitcev
Modified: 2010-08-20 03:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 04:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2010-08-17 22:56:05 EDT
Description of problem:

After an upgrade (to setup-2.8.25-1.fc15.noarch), bash fails to print
a prompt when run under screen. Garbage appears on the screen in
gnome-terminal. On xterm, just nothing appears.

Downgrading to setup-2.8.22-1.fc14.noarch restores normal operation.

Version-Release number of selected component (if applicable):

setup-2.8.25-1.fc15.noarch

How reproducible:

100%

Steps to Reproduce:
1. Login from a remote system running gnome-terminal
2. screen
3. observe the garbage on screen
  
Actual results:

No bash prompt, binary characters on screen

Expected results:

Normal bash prompt

Additional info:

May be a regression caused by the fix for bug 620435.
Comment 1 Ondrej Vasik 2010-08-18 04:34:52 EDT
Thanks for report, my fault, fixed in setup-2.8.26-1.fc15. Closing RAWHIDE.
Comment 2 Miroslav Lichvar 2010-08-18 12:15:21 EDT
*** Bug 624671 has been marked as a duplicate of this bug. ***
Comment 3 Pete Zaitcev 2010-08-18 12:41:01 EDT
Confirmed fixed in 2.8.26-1.fc15 (from Koji).
Comment 4 Miroslav Lichvar 2010-08-20 03:02:13 EDT
*** Bug 625529 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.