Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 625904 - Changing Architectures of the RHEV-M Related Beta Channels
Changing Architectures of the RHEV-M Related Beta Channels
Status: CLOSED CANTFIX
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Rel-Eng (Show other bugs)
RHN Stable
All Linux
low Severity medium
: ---
: ---
Assigned To: Stephen Herr
Red Hat Network Quality Assurance
:
Depends On:
Blocks: 627357
  Show dependency treegraph
 
Reported: 2010-08-20 14:29 EDT by Jay Greguske
Modified: 2010-09-01 10:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-26 10:33:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Greguske 2010-08-20 14:29:47 EDT
RHN beta channels related to the RHEV-M product have an incorrect architecture: they are listed as x86_64 but it should be IA-32/i386. The arch is also present in the channel labels (and their corresponding families) which is inconsistent and we'd like it to be fixed.

The channel labels that need to change are:
rhev-x86_64-m-d-2-beta ---> rhev-i386-m-d-2-beta
rhev-x86_64-m-s-2-beta ---> rhev-i386-m-s-2-beta

and the family labels that need to change are exactly the same:
rhev-x86_64-m-d-2-beta ---> rhev-i386-m-d-beta-2
rhev-x86_64-m-s-2-beta ---> rhev-i386-m-s-2-beta

These changes need to be replicated in stage and prod environments too.

We did this a while ago for the GA channels but skipped the beta ones because they had content in them and we didn't want to disrupt the beta program. RHEV is not in a beta program right now, so we have time to fix them. This change can't be accomplished using the RCM tooling, because the channel/family label is the *id* those tools work with.  Therefore, it must be done with SQL run against the DB.

My guess of the right SQL to run is below. I HAVE NOT VERIFIED THIS because I do not have DB access to any of the RHN environments.

update rhn.rhnchannel c
   set c.label = 'rhev-i386-m-d-2-beta'
 where c.label = 'rhev-x86_64-m-d-2-beta';

update rhn.rhnchannel c
   set c.label = 'rhev-i386-m-s-2-beta'
 where c.label = 'rhev-x86_64-m-s-2-beta';

update rhn.rhnchannelfamily cf
   set cf.label = 'rhev-i386-m-d-2-beta'
 where cf.label = 'rhev-x86_64-m-d-2-beta';

update rhn.rhnchannelfamily cf
   set cf.label = 'rhev-i386-m-s-2-beta'
 where cf.label = 'rhev-x86_64-m-s-2-beta';
Comment 1 Stephen Herr 2010-08-20 16:26:23 EDT
See BZ 511343 and https://www.re.redhat.com/cm/rfc/view/1269/ for the old issue / solution, this is virtually identical but with '-beta' at the end.
Comment 2 Stephen Herr 2010-08-26 10:33:00 EDT
On closer inspection this request is impossible, we cannot change channel family labels that have been released to customers. The other bug was okay because access had not been granted to anyone at that point. 

Reverting changes in webdev and webqa.

Note You need to log in before you can comment on or make changes to this bug.