Bug 626023 - anaconda fails to configure network on fixed IP networks
Summary: anaconda fails to configure network on fixed IP networks
Status: CLOSED DUPLICATE of bug 623937
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-21 14:24 UTC by Rich Johnson
Modified: 2010-08-23 15:58 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-08-23 08:27:15 UTC


Attachments (Terms of Use)
anaconda boot command (153.50 KB, image/jpeg)
2010-08-21 14:33 UTC, Rich Johnson
no flags Details
Attempt to use dhclient (25.57 KB, image/jpeg)
2010-08-21 14:39 UTC, Rich Johnson
no flags Details
NIC activation failure (38.04 KB, image/jpeg)
2010-08-21 14:41 UTC, Rich Johnson
no flags Details

Description Rich Johnson 2010-08-21 14:24:13 UTC
Fails to configure network on fixed IP networks.  
Loader insists on invoking dhclient despite IP configuration on command line

Version-Release number of selected component (if applicable):
RHEL6.0-20100811.2-Server-x86_64-DVD1.iso
anaconda-13.21.74-1.el6
kernel-2.6.32-63.el6
NetworkManager-0.8.1-5.el6

How reproducible:
Boot DVD with fixed IP and nfs: kickstart address  on a network w/o DHCP

Steps to Reproduce:
1.
2.
3.
  
Actual results:
  -" There was an error configuring your network interface"

Expected results:
  - Network configured, Installation proceeds


Additional info:
Regression from RHEL6.0-20100805-Server-x86_64-DVD1.iso
See attached screen shots

Comment 2 Rich Johnson 2010-08-21 14:33:57 UTC
Created attachment 440122 [details]
anaconda boot command

Comment 3 Rich Johnson 2010-08-21 14:39:22 UTC
Created attachment 440126 [details]
Attempt to use dhclient

Comment 4 Rich Johnson 2010-08-21 14:41:18 UTC
Created attachment 440128 [details]
NIC activation failure

Comment 5 Radek Vykydal 2010-08-23 08:27:15 UTC
This should be fixed in Snapshot #12.

*** This bug has been marked as a duplicate of bug 623937 ***


Note You need to log in before you can comment on or make changes to this bug.