Bug 623937 - Network doesn't start on installed system
Summary: Network doesn't start on installed system
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
urgent
high
Target Milestone: rc
: 6.0
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords: Regression
: 623926 623939 624992 625578 625610 625836 626023 (view as bug list)
Depends On:
Blocks: 551128 582286
TreeView+ depends on / blocked
 
Reported: 2010-08-13 08:02 UTC by Marian Ganisin
Modified: 2018-10-27 11:57 UTC (History)
17 users (show)

Fixed In Version: anaconda-13.21.76-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 19:52:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installation log files (Server variant) (200.00 KB, application/x-tar)
2010-08-13 08:02 UTC, Marian Ganisin
no flags Details
installation log files (Client variant) (430.00 KB, application/x-tar)
2010-08-13 08:03 UTC, Marian Ganisin
no flags Details
anaconda.syslog extracted from the archive (34.76 KB, text/plain)
2010-08-13 10:04 UTC, Radek Vykydal
no flags Details

Description Marian Ganisin 2010-08-13 08:02:44 UTC
Created attachment 438619 [details]
installation log files (Server variant)

On installed system:

[root@system1 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE="eth0"
HWADDR="52:54:00:12:34:56"
NM_CONTROLLED="yes"
ONBOOT="no"

Manual installation in virtual machine with network installation source.

I configured network just for an installation (as I did it with previous builds), that was dhcp configuration.

Not even network manager starts it automatically.

This is different behaviour in comparison to previous versions.

Comment 1 Marian Ganisin 2010-08-13 08:03:33 UTC
Created attachment 438621 [details]
installation log files (Client variant)

Comment 2 Marian Ganisin 2010-08-13 08:04:15 UTC
*** Bug 623926 has been marked as a duplicate of this bug. ***

Comment 3 Radek Vykydal 2010-08-13 09:44:43 UTC
(In reply to comment #1)
> Created an attachment (id=438621) [details]
> installation log files (Client variant)    

Marian, could you please post also /tmp/ifcfg.log grabbed from install environment before reboot? This is inconvenient, I should to send a patch for copying it to installed system as other log files.

Comment 4 Radek Vykydal 2010-08-13 10:04:10 UTC
Created attachment 438637 [details]
anaconda.syslog extracted from the archive

It seems that NM is not loading ifcfg-rh plugin (see bug #620823), so network is enabled even for our initial ifcfg file containing ONBOOT=no, and therefore it is not enabled later which would be done by writing out ONBOOT=yes to ifcfg file.

Comment 5 Radek Vykydal 2010-08-13 10:13:21 UTC
Dan, do you have any idea why ifcfg plugin wouldn't be loaded in recent builds? See comment #4 please.

Comment 7 Marian Ganisin 2010-08-13 13:18:45 UTC
Interesting. Network configuration dialog is not even displayed. Network is started in advance. When installer is asking 'Choose a Language' network is already up. 

Maybe related to change introduced in Bug 617860 or something similar.

Comment 8 Dan Williams 2010-08-13 16:20:23 UTC
Radek, does the system have /etc/NetworkManager/NetworkManager.conf, and if so, what's in it?

Comment 9 Dan Williams 2010-08-13 16:34:01 UTC
Yeah, so the issue here is that NM stopped shipping a deprecated config file (nm-system-settings.conf) in the RPM and now ships NetworkManager.conf, and I did not anticipate that the anaconda image creation code would need to be modified for this change as well.

anaconda-13.21.72/scripts/mk-images:    cp -a $IMGPATH/etc/NetworkManager/nm-system-settings.conf $MBD_DIR/etc/NetworkManager
anaconda-13.21.72/scripts/upd-instroot:etc/NetworkManager/nm-system-settings.conf

Comment 10 Chris Lumens 2010-08-13 17:45:37 UTC
*** Bug 623939 has been marked as a duplicate of this bug. ***

Comment 11 Chris Lumens 2010-08-17 17:02:18 UTC
*** Bug 620823 has been marked as a duplicate of this bug. ***

Comment 13 Alexander Todorov 2010-08-19 15:43:41 UTC
In snap #12:

# cat /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE="eth0"
BOOTPROTO="dhcp"
HWADDR="00:16:36:54:B2:EA"
IPVINIT="yes"
IPV6_AUTOCONF="yes"
NM_CONTROLLED="yes"
ONBOOT="yes"


ifconfig shows interface is up. ping command works. Moving to VERIFIED.

Comment 14 David Cantrell 2010-08-19 18:29:04 UTC
*** Bug 624992 has been marked as a duplicate of this bug. ***

Comment 15 Radek Vykydal 2010-08-20 12:41:23 UTC
*** Bug 625610 has been marked as a duplicate of this bug. ***

Comment 16 Chris Lumens 2010-08-20 15:13:29 UTC
*** Bug 625836 has been marked as a duplicate of this bug. ***

Comment 17 Radek Vykydal 2010-08-23 08:27:15 UTC
*** Bug 626023 has been marked as a duplicate of this bug. ***

Comment 18 John Jarvis 2010-08-23 16:40:45 UTC
*** Bug 625578 has been marked as a duplicate of this bug. ***

Comment 22 releng-rhel@redhat.com 2010-11-10 19:52:59 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.