This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 62612 - Spellchecker should be included.
Spellchecker should be included.
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: mozilla (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
http://spellchecker.mozdev.org/
:
: 68308 77407 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-02 22:32 EST by Aleksey Nogin
Modified: 2007-04-18 12:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-08 13:19:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mozdev spellchecker sources (for 1.4 branch) (286.12 KB, application/octet-stream)
2003-07-27 15:56 EDT, Aleksey Nogin
no flags Details
Mozdev spellchecker - the build patch to apply to the top level of Mozilla tree (5.66 KB, patch)
2003-07-27 15:57 EDT, Aleksey Nogin
no flags Details | Diff
Patch to the spec file (against the 1.4-12 that is in beta1 and current Rawhide) (3.34 KB, patch)
2003-07-27 16:00 EDT, Aleksey Nogin
no flags Details | Diff

  None (edit)
Description Aleksey Nogin 2002-04-02 22:32:15 EST
http://spellchecker.mozdev.org/ has a working spellchecker for Mozilla and
people are happily using it for quite a while (see also
http://bugzilla.mozilla.org/show_bug.cgi?id=56301 and
http://nogin.org/RPM/untested/moz/ByDate.html). Would you please consider
including it in RedHat's Mozilla before mozilla.org officially lets it in?

It may be not such a big priority for mozilla.org that does not (yet) seem to
consider Mozilla to really be an end-user product and Netscape does include its
own closed-source spellchecker, but for RedHat it would seem to be significantly
more important, especially if RedHat is planning to drop Netscape eventually.
Comment 1 Christopher Blizzard 2002-08-29 18:05:00 EDT
I'll include it once it's incorporated upstream.
Comment 2 Aleksey Nogin 2003-07-27 15:43:36 EDT
Most of the spellchecker code is already checking into the mozilla.org CVS (but
not yet turned on and not yet on the 1.4 branch). Is that good enough? 

I will attach all the files needed to include the spellcheker shortly.
Comment 3 Aleksey Nogin 2003-07-27 15:44:43 EDT
*** Bug 68308 has been marked as a duplicate of this bug. ***
Comment 4 Aleksey Nogin 2003-07-27 15:45:35 EDT
*** Bug 77407 has been marked as a duplicate of this bug. ***
Comment 5 Aleksey Nogin 2003-07-27 15:56:48 EDT
Created attachment 93179 [details]
Mozdev spellchecker sources (for 1.4 branch)

You can also check out the same thing yourself - run
cvs -d :pserver:guest@mozdev.org:/cvs co -r RELEASE_1_4 spellchecker/spellcheck

and then tar the spellcheck subdirectory.
Comment 6 Aleksey Nogin 2003-07-27 15:57:57 EDT
Created attachment 93180 [details]
Mozdev spellchecker -  the build patch to apply to the top level of Mozilla tree
Comment 7 Aleksey Nogin 2003-07-27 16:00:16 EDT
Created attachment 93181 [details]
Patch to the spec file (against the 1.4-12 that is in beta1 and current Rawhide)

This patch incorporates the previous two attachments (as "source30" and
"patch25" respectively) and makes sure mozilla-spellchecker package in built
along with the others.
Comment 8 Christopher Blizzard 2003-09-03 10:29:22 EDT
The spellchecker will be included in moz 1.4.1.  Once that comes out, I'll
enable the spellchecker.  Shouldn't be too long now...
Comment 9 Aleksey Nogin 2003-09-03 17:22:58 EDT
That's really good news, thanks!
Comment 10 Aleksey Nogin 2003-10-01 22:09:01 EDT
I see that Rawhide now includes mozilla-1.4.1-0, but spellchecker is still not
included.
Comment 11 Christopher Blizzard 2003-10-08 13:19:33 EDT
No, the spellchecker is just included as part of the mail package.  No seperate
package.
Comment 12 Aleksey Nogin 2003-10-08 20:54:26 EDT
> The spellchecker is just included as part of the mail package.

So, people who want to be able to check their spelling in HTML Composer, will
have to install the mail package?
Comment 13 Christopher Blizzard 2003-10-09 14:16:11 EDT
Woops, didn't realize that composer was using it too.  I've moved it into the
main package.

Note You need to log in before you can comment on or make changes to this bug.