Bug 626349 - [abrt] gwget-1.0.4-2.fc13: find_root: Process /usr/bin/gwget was killed by signal 11 (SIGSEGV)
[abrt] gwget-1.0.4-2.fc13: find_root: Process /usr/bin/gwget was killed by si...
Status: CLOSED DUPLICATE of bug 542393
Product: Fedora
Classification: Fedora
Component: gwget (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:dd9bfa6215dd09c1725ec663f6b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-23 05:53 EDT by bitu
Modified: 2010-11-28 04:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-27 16:46:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (13.48 KB, text/plain)
2010-08-23 05:53 EDT, bitu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 635954 None None None Never

  None (edit)
Description bitu 2010-08-23 05:53:40 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: gwget
component: gwget
crash_function: find_root
executable: /usr/bin/gwget
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: gwget-1.0.4-2.fc13
rating: 4
reason: Process /usr/bin/gwget was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1282555573
uid: 500
Comment 1 bitu 2010-08-23 05:53:42 EDT
Created an attachment (id=440347)
File: backtrace
Comment 2 Christoph Wickert 2010-09-08 11:47:36 EDT
What did you do when gwget crashed? Can you reproduce the crash reliably? If
so, how?
Comment 3 Christoph Wickert 2010-09-27 16:28:09 EDT
Any news on this bug? Can you please provide the info I asked for?
Comment 4 bitu 2010-09-29 04:45:21 EDT
Sorry for the delay!

I cannot remember exactly what I did, but I just tried to download something. The error is reproducible ALWAYS with ANY DOWNLOAD. So I did another try actually with a downloadd of fedora 13:
gwget  http://downlaod.fedoraproject.org/pub/fedora/linux/releases/13/Live/1686/fedora-13-i686-Live.iso

I get some equal lines of (german) messages in the console window:
Fehler unbekannter Fehler 73950K ... etc
(The german word Fehler translates to error, so in an US or Uk ysstem the message should probably read as follows: error unknown error ..etc) 
Than the download stops, say freezes, the OS is still usable. 

That bug, or whatever that is only concerns gwget, wget works well. So one might aergue that there is something wrong with GTK. The error message suggests that assumption:
(gwget:2869): Gtk-CRITICAL **:
gtk_list_store_set_valid:
assertion 'VALID_ITER(iter,list_stor)' failed

I argue that this error should reproduce on any system with any download. 

If you think the trigger is some uncommon costellation of my hardware (DELL inspirion), let me know the infos you need.
Comment 5 Christoph Wickert 2010-11-27 16:46:49 EST
(In reply to comment #4)
> Sorry for the delay!

Same here. :( This has dropped off my radar, sorry.

> (gwget:2869): Gtk-CRITICAL **:
> gtk_list_store_set_valid:
> assertion 'VALID_ITER(iter,list_stor)' failed

Save to ignore, this is not the root of the crash.

> I argue that this error should reproduce on any system with any download. 

I just tried to reproduce it with the URL you provided. Adding a download from the commandline does not work correctly (it wont show up and on the second attempt gwget complains that the download had already been added), but it does not crash, no matter what I do. I am using gwget quite frequently and I have never seen this crash.

I have to admit that I'm clueless about this one, so I have forwarded it to the upstrem developer for further investigation (in fact all ABRT reports should go to the developers directly). From now on, new comments shoud be added at
https://bugzilla.gnome.org/show_bug.cgi?id=635954

I will get back to you if I need info and inform you once the issue has been resolved in Fedora. Thanks for reporting this bug.
Comment 6 Christoph Wickert 2010-11-28 04:53:09 EST

*** This bug has been marked as a duplicate of bug 542393 ***

Note You need to log in before you can comment on or make changes to this bug.