Bug 626511 - pass through fails with KVM using Neterion Inc's X3100 Series 10GbE PCIe I/O in Multi function mode.
pass through fails with KVM using Neterion Inc's X3100 Series 10GbE PCIe I/O ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
high Severity urgent
: rc
: 5.7
Assigned To: Alex Williamson
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2 618260 635660 624790
  Show dependency treegraph
 
Reported: 2010-08-23 13:35 EDT by sivakumar
Modified: 2013-01-09 18:03 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-27 12:40:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sivakumar 2010-08-23 13:35:40 EDT
Description of problem:
pass through fails with KVM using Neterion Inc's X3100 Series 10GbE PCIe I/O
Virtualized Server Adapter in Multifunction mode.

Version-Release number of selected component (if applicable):
Redhat 5.5 

Steps to Reproduce:
1. Install Redhat 5.5 as VM on a host system which also has redhat 5.5
2. Shutdown VM.
2. Export one of the function of Neterion Inc's X3100 Series 10GbE PCIe I/O
Virtualized Server Adapter in Multifunction mode as pass through to the VM.
3. boot the VM.
  
Actual results:
1) I am able to see the exported device on VM through lspci. When do insmod, I am getting following error message in the log file of vm.
[root@Jelly ~]# tail -f /var/log/libvirt/qemu/redhat55.log
BUG: kvm_destroy_phys_mem: invalid parameters (slot=-1)
BUG: kvm_destroy_phys_mem: invalid parameters (slot=-1)
BUG: kvm_destroy_phys_mem: invalid parameters (slot=-1)

2) Then when I try to bring up the interface, the VM shutdown itself.




Additional info:
Comment 1 Jiri Denemark 2010-10-14 05:59:24 EDT
We have fixed some bugs in PCI assignment code in libvirt recently, could you test if using the latest development packages makes this any better? You can find the libvirt packages at http://people.redhat.com/jdenemar/libvirt/
Comment 6 Larry Troan 2010-11-21 15:55:25 EST
Unresolved issues with this NIC upstream and in RHEL6 per Enigneering.
Too late for 5.6. Pushing to 5.7.
Comment 7 sivakumar 2010-12-06 16:21:49 EST
I verified that the issue is still happening on redhat 5.6 snapshot3. The details as follow:

char device redirected to /dev/pts/1
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin HOME=/ QEMU_AUDIO_DRV=none /usr/libe
xec/qemu-kvm -S -M rhel5.4.0 -m 512 -smp 1,sockets=1,cores=1,threads=1 -name red
hat55 -uuid c89825a4-1744-d3ac-3ed8-453822c87d16 -monitor unix:/var/lib/libvirt/
qemu/redhat55.monitor,server,nowait -no-kvm-pit-reinjection -boot c -drive file=
/var/lib/libvirt/images/redhat55-1.img,if=virtio,boot=on,format=raw,cache=none -
drive if=ide,media=cdrom,bus=1,unit=0,readonly=on,format=raw -net nic,macaddr=54
:52:00:67:b9:ad,vlan=0,model=virtio -net tap,fd=18,vlan=0 -serial pty -parallel
none -usb -vnc 127.0.0.1:0 -k en-us -vga cirrus -pcidevice host=02:00.2 -balloon
 virtio
char device redirected to /dev/pts/1
BUG: kvm_destroy_phys_mem: invalid parameters (slot=-1)
BUG: kvm_destroy_phys_mem: invalid parameters (slot=-1)
BUG: kvm_destroy_phys_mem: invalid parameters (slot=-1)
BUG: kvm_destroy_phys_mem: invalid parameters (slot=-1)
BUG: kvm_destroy_phys_mem: invalid parameters (slot=-1)
BUG: kvm_destroy_phys_mem: invalid parameters (slot=-1)

The libvirt version :
-----------------------
[root@Nemo qemu]# rpm -qa | grep libvirt
libvirt-python-0.8.2-13.el5
libvirt-0.8.2-13.el5
libvirt-0.8.2-13.el5
[root@Nemo qemu]#
Comment 14 Alex Williamson 2011-07-27 12:40:36 EDT
The changes required to support this are too intrusive for RHEL5.  This has been fixed and does now work in RHEL6.1.

Note You need to log in before you can comment on or make changes to this bug.