Bug 626731 - Xorg -configure ends with Caught signal 11. Server aborting
Xorg -configure ends with Caught signal 11. Server aborting
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
: Triaged
Depends On:
Blocks: 680865
  Show dependency treegraph
 
Reported: 2010-08-24 05:02 EDT by Lubos Kocman
Modified: 2014-11-03 08:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 680865 (view as bug list)
Environment:
Last Closed: 2014-06-02 09:05:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg_configure log with backtrace (1.56 KB, text/plain)
2010-08-24 05:02 EDT, Lubos Kocman
no flags Details

  None (edit)
Description Lubos Kocman 2010-08-24 05:02:29 EDT
Created attachment 440601 [details]
xorg_configure log with backtrace

Description of problem:

If you'll execute Xorg -configure "from console" on RHEL 5.5 qemu-kvm guest  using spice (qxl driver) then you'll get "black console" with no output being showed.

However blind execution of /sbin/init 5 returns me back to the Xorg (so input works well).

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-.1.1.1-48.76.el5_5.1
xorg-x11-drv-qxl-0.0.12-1.2.el5

How reproducible:


Steps to Reproduce:
1. switch to the console
2. be sure that xorg is not running
3. run Xorg -configure
  
Actual results:

Backtrace:
0: Xorg(xf86SigHandler+0x71) [0x4958c1]
1: /lib64/libc.so.6 [0x31828302d0]
2: /usr/lib64/xorg/modules/drivers/qxl_drv.so [0x2b451a1330d8]
3: Xorg(DoConfigure+0xd4c) [0x47e30c]
4: Xorg(InitOutput+0x675) [0x463ee5]
5: Xorg(main+0x26f) [0x43358f]
6: /lib64/libc.so.6(__libc_start_main+0xf4) [0x318281d994]
7: Xorg(FontFileCompleteXLFD+0x241) [0x432a49]

Fatal server error:
Caught signal 11.  Server aborting

Console does not return any output

Expected results:

Server should not be killed. Console should return output as usually


Additional info:

Console is not returning any output after switching back to console.
Comment 1 Jonathan Blandford 2011-02-27 08:00:22 EST
Can you try again with the server and driver in 6.1?
Comment 2 Lubos Kocman 2011-02-28 03:44:51 EST
I run into the same issue with xorg-x11-drv-qxl-0.0.12-5.el6.x86_64, xorg-x11-server-Xorg-1.7.7-28.el6.x86_64 (@el6.1)

So it does happen also in 6.1
Comment 3 RHEL Product and Program Management 2014-03-07 07:41:46 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-02 09:05:04 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.