Bug 680865 - Xorg -configure ends with Caught signal 11. Server aborting
Xorg -configure ends with Caught signal 11. Server aborting
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Søren Sandmann Pedersen
desktop-bugs@redhat.com
: Triaged
: 679132 (view as bug list)
Depends On: 626731
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-28 03:46 EST by Lubos Kocman
Modified: 2014-06-18 05:14 EDT (History)
5 users (show)

See Also:
Fixed In Version: xorg-x11-drv-qxl-0.0.12-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 626731
Environment:
Last Closed: 2011-05-19 10:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Kocman 2011-02-28 03:46:27 EST
I run into the same issue with xorg-x11-drv-qxl-0.0.12-5.el6.x86_64, xorg-x11-server-Xorg-1.7.7-28.el6.x86_64 (@el6.1)


+++ This bug was initially created as a clone of Bug #626731 +++

Created attachment 440601 [details]
xorg_configure log with backtrace

Description of problem:

If you'll execute Xorg -configure "from console" on RHEL 5.5 qemu-kvm guest  using spice (qxl driver) then you'll get "black console" with no output being showed.

However blind execution of /sbin/init 5 returns me back to the Xorg (so input works well).

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-.1.1.1-48.76.el5_5.1
xorg-x11-drv-qxl-0.0.12-1.2.el5

How reproducible:


Steps to Reproduce:
1. switch to the console
2. be sure that xorg is not running
3. run Xorg -configure
  
Actual results:

Backtrace:
0: Xorg(xf86SigHandler+0x71) [0x4958c1]
1: /lib64/libc.so.6 [0x31828302d0]
2: /usr/lib64/xorg/modules/drivers/qxl_drv.so [0x2b451a1330d8]
3: Xorg(DoConfigure+0xd4c) [0x47e30c]
4: Xorg(InitOutput+0x675) [0x463ee5]
5: Xorg(main+0x26f) [0x43358f]
6: /lib64/libc.so.6(__libc_start_main+0xf4) [0x318281d994]
7: Xorg(FontFileCompleteXLFD+0x241) [0x432a49]

Fatal server error:
Caught signal 11.  Server aborting

Console does not return any output

Expected results:

Server should not be killed. Console should return output as usually


Additional info:

Console is not returning any output after switching back to console.

--- Additional comment from jrb@redhat.com on 2011-02-27 08:00:22 EST ---

Can you try again with the server and driver in 6.1?

--- Additional comment from lkocman@redhat.com on 2011-02-28 03:44:51 EST ---

I run into the same issue with xorg-x11-drv-qxl-0.0.12-5.el6.x86_64, xorg-x11-server-Xorg-1.7.7-28.el6.x86_64 (@el6.1)

So it does happen also in 6.1
Comment 2 Søren Sandmann Pedersen 2011-03-11 10:38:21 EST
*** Bug 679132 has been marked as a duplicate of this bug. ***
Comment 3 Jonathan Blandford 2011-03-11 11:23:31 EST
Will attempt to fix this.  We'll tentatively dev_ack it, but there's a chance we won't be able to.
Comment 4 RHEL Product and Program Management 2011-03-11 11:40:01 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 5 Søren Sandmann Pedersen 2011-03-20 13:19:17 EDT
Fixed in 0.0.12-6.el6
Comment 7 Lubos Kocman 2011-03-21 12:50:45 EDT
Verified on xorg-x11-drv-qxl-0.0.12-9.el6.{i686,x86_64}. Issue no longer occurs.
Comment 8 errata-xmlrpc 2011-05-19 10:23:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0756.html

Note You need to log in before you can comment on or make changes to this bug.