Bug 627153 - Anaconda fails to modify NTFS partition
Anaconda fails to modify NTFS partition
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
anaconda_trace_hash:f003b7cdb2f58b31e...
: CommonBugs
: 649029 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-25 04:31 EDT by Thomas Canniot
Modified: 2013-01-10 03:11 EST (History)
26 users (show)

See Also:
Fixed In Version: anaconda-15.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-04 08:21:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (678.54 KB, text/plain)
2010-08-25 04:31 EDT, Thomas Canniot
no flags Details
Attached traceback automatically from anaconda. (96.80 KB, text/plain)
2010-08-30 13:22 EDT, Michal Schmidt
no flags Details
Testing 627153.img anaconda updates (288.59 KB, application/xml)
2010-09-07 14:53 EDT, Thomas Canniot
no flags Details
Attached traceback automatically from anaconda. (560.64 KB, text/plain)
2010-10-10 18:35 EDT, loedur
no flags Details
Attached traceback automatically from anaconda. (141.53 KB, text/plain)
2010-10-27 20:02 EDT, Adam Williamson
no flags Details
Attached traceback automatically from anaconda. (249.95 KB, text/plain)
2010-11-01 17:23 EDT, dspikaman
no flags Details
Attached traceback automatically from anaconda. (489.72 KB, text/plain)
2010-11-02 15:59 EDT, Dale Stimson
no flags Details
Attached traceback automatically from anaconda. (516.36 KB, text/plain)
2010-11-03 09:53 EDT, Randall
no flags Details
Attached traceback automatically from anaconda. (295.99 KB, text/plain)
2010-11-05 14:34 EDT, Andrey
no flags Details
Attached traceback automatically from anaconda. (474.13 KB, text/plain)
2010-11-06 03:48 EDT, Ales Kozumplik
no flags Details
Attached traceback automatically from anaconda. (338.82 KB, text/plain)
2010-11-12 17:48 EST, louisgtwo
no flags Details
Attached traceback automatically from anaconda. (392.11 KB, text/plain)
2010-11-16 15:42 EST, Aleksey Mikhaylov
no flags Details
Attached traceback automatically from anaconda. (392.11 KB, text/plain)
2010-11-16 15:42 EST, Aleksey Mikhaylov
no flags Details
Attached traceback automatically from anaconda. (482.86 KB, text/plain)
2010-11-17 10:03 EST, Jaroslav Reznik
no flags Details
Attached traceback automatically from anaconda. (316.34 KB, text/plain)
2010-11-18 00:30 EST, David
no flags Details
Attached traceback automatically from anaconda. (459.73 KB, text/plain)
2010-11-20 15:54 EST, Robert N. Evans
no flags Details
Attached traceback automatically from anaconda. (442.18 KB, text/plain)
2010-11-21 13:27 EST, GeoffLeach
no flags Details
Attached traceback automatically from anaconda. (502.48 KB, text/plain)
2010-11-23 13:20 EST, hakusa
no flags Details
Attached traceback automatically from anaconda. (202.31 KB, text/plain)
2010-12-10 13:53 EST, Nathanael Noblet
no flags Details
Attached traceback automatically from anaconda. (451.98 KB, text/plain)
2011-01-08 11:40 EST, thundat00th
no flags Details
Attached traceback automatically from anaconda. (769.54 KB, text/plain)
2011-01-22 13:52 EST, starsareblueandfaraway
no flags Details
Attached traceback automatically from anaconda. (259.66 KB, text/plain)
2011-03-01 08:49 EST, Mariusz Libera
no flags Details
Attached traceback automatically from anaconda. (173.96 KB, text/plain)
2011-03-08 15:38 EST, Matthew Garrett
no flags Details
Attached traceback automatically from anaconda. (396.28 KB, text/plain)
2011-04-03 12:21 EDT, Tiago Vieira
no flags Details
Attached traceback automatically from anaconda. (355.15 KB, text/plain)
2011-04-14 22:56 EDT, VAMSI MADHAV
no flags Details
Attached traceback automatically from anaconda. (267.88 KB, text/plain)
2011-04-25 07:47 EDT, Ashok Varma
no flags Details
Attached traceback automatically from anaconda. (245.32 KB, text/plain)
2011-05-05 18:45 EDT, VAMSI MADHAV
no flags Details
Attached traceback automatically from anaconda. (383.13 KB, text/plain)
2011-05-14 07:16 EDT, Petr Berka
no flags Details
Attached traceback automatically from anaconda. (385.96 KB, text/plain)
2011-05-16 22:22 EDT, wen-en lu
no flags Details

  None (edit)
Description Thomas Canniot 2010-08-25 04:31:05 EDT
The following was filed automatically by anaconda:
anaconda 14.15 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/partition_ui_helpers_gui.py", line 237, in resizeOptionCB
    formatcb.set_sensitive(not widget.get_active())
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/partition_ui_helpers_gui.py", line 393, in createPreExistFSOptionSection
    resizeOptionCB(resizecb, (formatcb, resizesb))
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/partition_dialog_gui.py", line 514, in __init__
    (row, self.fsoptionsDict) = createPreExistFSOptionSection(self.origrequest, maintable, row, self.mountCombo, self.storage, luksdev=luksdev)
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1672, in editPartition
    isNew = isNew, restrictfs = restrictfs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1640, in editCB
    self.editPartition(device)
AttributeError: 'NoneType' object has no attribute 'set_sensitive'
Comment 1 Thomas Canniot 2010-08-25 04:31:11 EDT
Created an attachment (id=440861)
Attached traceback automatically from anaconda.
Comment 2 Thomas Canniot 2010-08-25 04:36:59 EDT
I chose Basic Storage then Cutom Layout for partionning.

Anaconda crashes when I wanted to modify the NTFS partition on my system /dev/sda10.

I used Fedora 14 Alpha GNOME Live CD.
Comment 3 Michal Schmidt 2010-08-30 13:22:36 EDT
Created an attachment (id=441993)
Attached traceback automatically from anaconda.
Comment 4 Chris Lumens 2010-09-02 10:08:48 EDT
Can you try with the non-livecd, add updates=http://clumens.fedorapeople.org/627153.img and see if that fixes this issue for you?  It would probably help to first verify you hit the problem on the non-livecd before attempting with the updates image.
Comment 5 Thomas Canniot 2010-09-04 07:32:30 EDT
I had the same problem with the F14 alpha DVD. What do we have to do with the .img file ? Thanks for explaining.
Comment 6 Chris Lumens 2010-09-07 10:45:36 EDT
https://fedoraproject.org/wiki/Anaconda/Updates#Updates_from_the_Network

should explain it.
Comment 7 Thomas Canniot 2010-09-07 14:53:34 EDT
Created attachment 445559 [details]
Testing 627153.img anaconda updates

Hello, the 627153.img does not work either. I took the debug file from anaconda. I stay tuned from other updates from you.
Comment 8 Chris Lumens 2010-09-07 15:37:26 EDT
Stupid typo.  Can you try again with the same URL?
Comment 9 Thomas Canniot 2010-09-07 16:33:23 EDT
It works better but not perfectly. I can now modifiy the NTFS partition information (mount point, shrink it and encrypt it) by selecting it and clicking on the Modify button.
However, anaconda does not take into account a mount point set in this dialog box. I want to mount this ntfs partition into a /data folder and anaconda does not seems to add this info. I have no error message however... and other tty seems OK to me.
Comment 10 Chris Lumens 2010-09-08 17:07:17 EDT
I think that's a separate issue, covered by bug 630140 and possibly bug 628301.
Comment 11 loedur 2010-10-10 18:35:01 EDT
Created attachment 452620 [details]
Attached traceback automatically from anaconda.
Comment 12 loedur 2010-10-10 18:49:37 EDT
Hello,

the error also happend with Fedora 14 Beta!
At first I selected my two linux partitions (ext4, ext2) and deleted them.
Now I created a new partition (filesystem: ext2, mountpoint: / ) from the free space.
Finally I choosed my existing ntfs-partition and clicked on [modify] the set the mountpoint in the options-dialog, yet the error occurred.

-> The crash report was generated.
Comment 13 Adam Williamson 2010-10-27 20:02:03 EDT
Created attachment 456119 [details]
Attached traceback automatically from anaconda.
Comment 14 Adam Williamson 2010-10-27 20:03:22 EDT
Owch! How was this fix not pulled into F14? :( We're probably missing tests for NTFS stuff and general interoperability with Windows systems...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Adam Williamson 2010-10-27 23:50:48 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 James Laska 2010-11-01 11:55:26 EDT
(In reply to comment #14)
> Owch! How was this fix not pulled into F14? :( We're probably missing tests for
> NTFS stuff and general interoperability with Windows systems...
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

Odd, a fix for this issue was included in F-14-RC1 according to http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=27c371907d7afa6be837f974c6670a9cdbfad723.  I also confirmed the fix is applied to anaconda-14.22-1.fc14.src.rpm.

Perhaps that doesn't resolve the issue as expected?   Moving back to ASSIGNED.
Comment 17 James Laska 2010-11-01 12:00:26 EDT
Added a stub to Common_F14_Bugs (https://fedoraproject.org/wiki/Common_F14_bugs#modify_ntfs) to document this failure and note any workarounds/updates.img's when available.
Comment 18 Adam Williamson 2010-11-01 12:57:21 EDT
That wasn't a fix for this issue. That was a fix for #637319. Different, unrelated bugs. I confirmed that this bug still exists in RC1.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 James Laska 2010-11-01 13:16:02 EDT
(In reply to comment #18)
> That wasn't a fix for this issue. That was a fix for #637319. Different,
> unrelated bugs. I confirmed that this bug still exists in RC1.

Ah apologies.  That commit I linked to is the only ntfs related commit I found when glancing at the git shortlog for anaconda.  Asking clumens for help locating the proper fix.  Once identified, I'll supply an updates.img and update the Common_F14_Bug doc.
Comment 20 Adam Williamson 2010-11-01 13:31:51 EDT
'unrelated' may be too strong, they may have some relation...but I was involved in testing both bugs and I confirmed that the other one is definitely fixed in rc1 and this one is definitely still present, at least. =)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 James Laska 2010-11-01 14:17:11 EDT
Clumens directed me to the correct fix for this issue (see http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=1010f3a7db9410c09b41595a3632d7f983a7e5a9).  I'll provide an updates.img for testing shortly.
Comment 22 James Laska 2010-11-01 16:22:28 EDT
I have uploaded an updates.img that includes the fix from comment#21 and is intended to be used with F-14-RC1.  The updates.img is available at http://jlaska.fedorapeople.org/updates/627153.img.  Instructions for how to use an updates.img are available at http://fedoraproject.org/wiki/Anaconda/Updates.

Is someone able to confirm that the updates.img resolves the reported problem?  Thanks!

AdamW: I'm tempted to close this issue as CLOSED RAWHIDE since it is fixed in rawhide and not intended to be resolved in F-14.  Is that the correct resolution?
Comment 23 dspikaman 2010-11-01 17:23:15 EDT
Created attachment 456998 [details]
Attached traceback automatically from anaconda.
Comment 24 Chris Lumens 2010-11-02 15:32:34 EDT
*** Bug 649029 has been marked as a duplicate of this bug. ***
Comment 25 Dale Stimson 2010-11-02 15:59:34 EDT
Created attachment 457268 [details]
Attached traceback automatically from anaconda.
Comment 26 Dale Stimson 2010-11-02 16:14:36 EDT
Anaconda -- Basic Storage, Custom Layout, selected an existing
NTFS partition, clicked "Edit", then it failed.
Comment 27 James Laska 2010-11-02 16:38:40 EDT
(In reply to comment #26)
> Anaconda -- Basic Storage, Custom Layout, selected an existing
> NTFS partition, clicked "Edit", then it failed.

Thanks for the feedback Dale.  Please see https://fedoraproject.org/wiki/Common_F14_bugs#modify_ntfs for further details on this issue.
Comment 28 Randall 2010-11-03 09:53:12 EDT
Created attachment 457444 [details]
Attached traceback automatically from anaconda.
Comment 29 Patrick C. F. Ernzer 2010-11-03 17:24:42 EDT
James,

(In reply to comment #22)

[...]
> http://jlaska.fedorapeople.org/updates/627153.img.
[...]
> Is someone able to confirm that the updates.img resolves the reported problem? 

I can confirm that with plain F14 release anaconda I have the same problem as described in comment #12. Using the updates image 627153.img allows me to double-click an NTFS partition and see the edit dialog. I did not attempt to change the partition as I have no need to shrink it.

side note: unrelated to this I have a RAID assembly problem, but that should not skew the results for this test as the NTFS partition is not even on the same disk as the raid members.

Long story short; your updates.img fixes this bug.
Comment 30 James Laska 2010-11-04 08:21:54 EDT
(In reply to comment #29)
> Long story short; your updates.img fixes this bug.

Thanks for the feedback Patrick.  This issue can probably be CLOSED NEXTRELEASE as we have no mechanism for fixing anaconda in F-14 already.  Although, I'm not sure whether we would want to push an update so future live images have this support (unclear).  I'll let the anaconda-devel folks weigh in on that.

Regardless, this issue will be resolved in rawhide and F-15.  Thanks!
Comment 31 Andrey 2010-11-05 14:34:32 EDT
Created attachment 458196 [details]
Attached traceback automatically from anaconda.
Comment 32 Ales Kozumplik 2010-11-06 03:48:00 EDT
Created attachment 458276 [details]
Attached traceback automatically from anaconda.
Comment 33 louisgtwo 2010-11-12 17:48:34 EST
Created attachment 460167 [details]
Attached traceback automatically from anaconda.
Comment 34 Aleksey Mikhaylov 2010-11-16 15:42:23 EST
Created attachment 460921 [details]
Attached traceback automatically from anaconda.
Comment 35 Aleksey Mikhaylov 2010-11-16 15:42:52 EST
Created attachment 460922 [details]
Attached traceback automatically from anaconda.
Comment 36 Jaroslav Reznik 2010-11-17 10:03:06 EST
Created attachment 461086 [details]
Attached traceback automatically from anaconda.
Comment 37 David 2010-11-18 00:30:18 EST
Created attachment 461216 [details]
Attached traceback automatically from anaconda.
Comment 38 Robert N. Evans 2010-11-20 15:54:53 EST
Created attachment 461764 [details]
Attached traceback automatically from anaconda.
Comment 39 GeoffLeach 2010-11-21 13:27:15 EST
Created attachment 461850 [details]
Attached traceback automatically from anaconda.
Comment 40 hakusa 2010-11-23 13:20:46 EST
Created attachment 462407 [details]
Attached traceback automatically from anaconda.
Comment 41 Nathanael Noblet 2010-12-10 13:53:39 EST
Created attachment 468034 [details]
Attached traceback automatically from anaconda.
Comment 42 thundat00th 2011-01-08 11:40:17 EST
Created attachment 472364 [details]
Attached traceback automatically from anaconda.
Comment 43 starsareblueandfaraway 2011-01-22 13:52:52 EST
Created attachment 474749 [details]
Attached traceback automatically from anaconda.
Comment 44 Mariusz Libera 2011-03-01 08:49:09 EST
Created attachment 481626 [details]
Attached traceback automatically from anaconda.
Comment 45 Matthew Garrett 2011-03-08 15:38:59 EST
Created attachment 483011 [details]
Attached traceback automatically from anaconda.
Comment 46 Tiago Vieira 2011-04-03 12:21:03 EDT
Created attachment 489668 [details]
Attached traceback automatically from anaconda.
Comment 47 VAMSI MADHAV 2011-04-14 22:56:16 EDT
Created attachment 492263 [details]
Attached traceback automatically from anaconda.
Comment 48 Ashok Varma 2011-04-25 07:47:24 EDT
Created attachment 494642 [details]
Attached traceback automatically from anaconda.
Comment 49 VAMSI MADHAV 2011-05-05 18:45:32 EDT
Created attachment 497237 [details]
Attached traceback automatically from anaconda.
Comment 50 Petr Berka 2011-05-14 07:16:23 EDT
Created attachment 498920 [details]
Attached traceback automatically from anaconda.
Comment 51 wen-en lu 2011-05-16 22:22:58 EDT
Created attachment 499259 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.