This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 627573 - Ensure that attachments are migrated together with Jira issues
Ensure that attachments are migrated together with Jira issues
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.6
All Linux
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Simon Green
:
: 670820 (view as bug list)
Depends On:
Blocks: JIRABZ
  Show dependency treegraph
 
Reported: 2010-08-26 09:02 EDT by Jiri Pechanec
Modified: 2014-10-12 18:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-09 12:26:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jiri Pechanec 2010-08-26 09:02:25 EDT
During the real migration it is necessary to guarantee that attachments are migrated together with issues and present in Jira bug.
Comment 2 Simon Green 2011-02-07 01:01:58 EST
*** Bug 670820 has been marked as a duplicate of this bug. ***
Comment 3 Simon Green 2011-02-07 18:38:36 EST
This has been committed to production and will be visible on all future migrations. Some things to note:

The largest attachment is currently just over 10MB. Production Bugzilla currently allows attachments up to 20MB in size so this shouldn't be a problem (The test server was set at 1MB, but I have changed this)

The attachments are grabbed using LWP (perl module to get files from the jira web server). On the basis of my testing, this will add approximately an extra 12 hours to the migration if we migrate all issues (this is based on a connection from Brisbane, it will probably be a little faster for the US server)

$ svn commit Bugzilla/Migrate/JIRA.pm bugzilla.spec.in
Sending        Bugzilla/Migrate/JIRA.pm
Sending        bugzilla.spec.in
Transmitting file data ..
Committed revision 2357.
Comment 4 Simon Green 2011-02-09 08:25:24 EST
This is now on the staging server. For example https://bz-web2-test.devel.redhat.com/show_bug.cgi?id=675093 (URL only valid until next database reload)

  -- simon
Comment 6 Simon Green 2011-03-02 02:09:56 EST
Reopening this bug. I'm changing the way that we process attachments. We will get them off the filesystem. This will be more reliable than getting them at run time (although that will still be a fallback)
Comment 7 Simon Green 2011-03-06 20:48:39 EST
Changes were made as part of revision 2366 this morning.

  -- simon
Comment 9 Mike Harvey 2011-03-09 12:02:54 EST
Conducting a random sample, I found attachments to be migrated.  Here's the two I looked at.

https://bz-web2-test.devel.redhat.com/show_bug.cgi?id=BRMS-412
https://bz-web2-test.devel.redhat.com/show_bug.cgi?id=680152

I could not find a way to easily verify a match of the record counts of all migrated attachments, comparing the bz test instance to the Jira instance.
Comment 10 Mike Harvey 2011-03-09 12:26:03 EST
closing

Note You need to log in before you can comment on or make changes to this bug.