This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 627602 - [abrt] kdebase-workspace-4.5.0-2.fc14: updateSplashImage: Process /usr/bin/ksplashx was killed by signal 11 (SIGSEGV)
[abrt] kdebase-workspace-4.5.0-2.fc14: updateSplashImage: Process /usr/bin/ks...
Status: CLOSED DUPLICATE of bug 632814
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
abrt_hash:c0171d376fe9339fe3dddbaf4d5...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-26 09:59 EDT by Michal Hlavinka
Modified: 2010-10-19 10:00 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-18 11:42:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (12.33 KB, text/plain)
2010-08-26 09:59 EDT, Michal Hlavinka
no flags Details

  None (edit)
Description Michal Hlavinka 2010-08-26 09:59:10 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: ksplashx Laughlin --pid
component: kdebase-workspace
crash_function: updateSplashImage
executable: /usr/bin/ksplashx
kernel: 2.6.35.2-9.fc14.x86_64
package: kdebase-workspace-4.5.0-2.fc14
rating: 4
reason: Process /usr/bin/ksplashx was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
How to reproduce: I've installed F-14 alpha, installed KDE, updated system, reboot and got this abrt report
time: 1282826815
uid: 500
Comment 1 Michal Hlavinka 2010-08-26 09:59:15 EDT
Created an attachment (id=441219)
File: backtrace
Comment 2 Michal Hlavinka 2010-08-26 10:05:07 EDT
I can reproduce by system settings-> workspace appearance -> splash screen ->test
"Default" works
Laughlin crashes

I've installed F-14 with Gnome and later installed kdm kdebase kdebase-workspace kdelibs and their dependencies, so maybe there is some package missing, but it should not crash imho
Comment 3 Michal Hlavinka 2010-08-26 10:08:12 EDT
# rpm -qa | grep laughlin gives me: laughlin-backgrounds-kde, laughlin-backgrounds-single, laughlin-backgrounds-gnome, laughlin-kde-theme
Comment 4 Kevin Kofler 2010-08-26 10:47:14 EDT
Most likely it's a bug in the Laughlin KSplash theme. KSplashX just segfaults if anything is wrong in the theme, there's little to no error checking.
Comment 5 Rex Dieter 2010-08-26 10:52:18 EDT
Agreed, let's triage this there for now, and test what went wrong.
Comment 6 Martin Sourada 2010-08-26 11:03:41 EDT
Well, but wouldn't laughlin-kde-theme be better? That's what contains the KSplash theme, AFAIK.
Comment 7 Rex Dieter 2010-08-26 11:09:01 EDT
Doh, of course.  sorry.
Comment 8 Jaroslav Reznik 2010-09-07 10:56:39 EDT
Do you use KVM? Laughlin KDE theme is just a Goddard port to use new wallpaper. Does Goddard works for you?
Comment 9 Michal Hlavinka 2010-09-07 11:47:15 EDT
> KVM? 
yes
>Goddart
I don't have it installed
Comment 10 Jaroslav Reznik 2010-09-08 11:08:14 EDT
Ok,
thanks.
It's the Qt/XOrg/KVM/Cirrus bug - related to wrong background colours etc. - improper 24 bit depth handling.
For me it isn't kde-45 or qt47 blocker - and it's related only to KVM with Cirrus graphics. Reassigning to Qt.
Comment 11 Rex Dieter 2010-09-29 10:06:49 EDT
Why not assigned to -cirrus ?
Comment 12 Rex Dieter 2010-10-18 11:42:34 EDT

*** This bug has been marked as a duplicate of bug 632814 ***
Comment 13 Rex Dieter 2010-10-18 11:43:41 EDT
fyi, the 'orange' thing is hopefully fixed in qt-4.7.0-6

%changelog
* Fri Oct 15 2010 Than Ngo <than@redhat.com> - 4.7.0-6
- apply patch to fix the color issue in 24bit mode (cirrus driver)
Comment 14 Ngo Than 2010-10-19 10:00:28 EDT
(In reply to comment #13)
> fyi, the 'orange' thing is hopefully fixed in qt-4.7.0-6
> 
yes, it's fixed in qt-4.7.0-6

Note You need to log in before you can comment on or make changes to this bug.