Bug 632814 - [abrt] kdebase-workspace-4.5.1-2.fc14: updateSplashImage: Process /usr/bin/ksplashx was killed by signal 11 (SIGSEGV)
Summary: [abrt] kdebase-workspace-4.5.1-2.fc14: updateSplashImage: Process /usr/bin/ks...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: laughlin-kde-theme
Version: 14
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:abec2c1429a70c2b3750144aaed...
: 627602 635439 (view as bug list)
Depends On:
Blocks: F14Blocker-kde
TreeView+ depends on / blocked
 
Reported: 2010-09-11 06:28 UTC by bankthis_2000
Modified: 2010-10-18 15:42 UTC (History)
16 users (show)

Fixed In Version: laughlin-kde-theme-13.92.0-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-05 13:16:45 UTC


Attachments (Terms of Use)
File: backtrace (11.47 KB, text/plain)
2010-09-11 06:28 UTC, bankthis_2000
no flags Details

Description bankthis_2000 2010-09-11 06:28:13 UTC
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: ksplashx Laughlin --pid
component: kdebase-workspace
crash_function: updateSplashImage
executable: /usr/bin/ksplashx
kernel: 2.6.35.4-12.fc14.i686
package: kdebase-workspace-4.5.1-2.fc14
rating: 4
reason: Process /usr/bin/ksplashx was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1284091245
uid: 500

Comment 1 bankthis_2000 2010-09-11 06:28:17 UTC
Created an attachment (id=446627)
File: backtrace

Comment 2 Orion Poplawski 2010-09-30 15:16:49 UTC
#0  0x080568b3 in updateSplashImage (img=..., x_pos=0, y_pos=0) at /usr/src/debug/kdebase-workspace-4.5.1/ksplash/ksplashx/splash.cpp:833
        x = <value optimized out>
        s = <value optimized out>
        d = <value optimized out>
        y = <value optimized out>
        pix = {hd = 136997248, w = <value optimized out>, h = <value optimized out>, d = <value optimized out>, optim = <value optimized out>, ximage = <value optimized out>}
        gc = <value optimized out>

Comment 3 Orion Poplawski 2010-09-30 15:17:30 UTC
*** Bug 635439 has been marked as a duplicate of this bug. ***

Comment 4 Orion Poplawski 2010-09-30 15:57:35 UTC
ksplashx is calling ksplashx_scale to scale an image.  In my case:

26300 execve("/usr/bin/ksplashx_scale", ["ksplashx_scale", "Laughlin", "laughlin.png", "/usr/share/kde4/apps/ksplash/Themes/Laughlin/1280x800/laughlin.png", "1536", "1152", "1024", "768", "1280754433", "no-locolor"], [/* 98 vars */]) = 0

This ends up producing:

/export/home/orion/.kde/cache-makani/ksplashx/Laughlin-1024x768-laughlin.png: PNG image data, 1536 x 1152, 8-bit/color RGB, non-interlaced

Which from the name I would expect to be 1024x768?

Comment 5 Orion Poplawski 2010-09-30 16:07:00 UTC
Removing /usr/share/kde4/apps/ksplash/Themes/Laughlin/1280x800/laughlin.png fixes it for me.

Comment 6 Orion Poplawski 2010-09-30 16:10:20 UTC
file -L /usr/share/kde4/apps/ksplash/Themes/Laughlin/1280x800/laughlin.png
/usr/share/kde4/apps/ksplash/Themes/Laughlin/1280x800/laughlin.png: PNG image data, 1920 x 1200, 8-bit/color RGB, non-interlaced

Shouldn't lie to it :-).

Comment 7 Orion Poplawski 2010-09-30 16:14:52 UTC
These are the sizes provided:

/usr/share/backgrounds/laughlin/default/normalish/laughlin.png: PNG image data, 1280 x 1024, 8-bit/color RGB, non-interlaced
/usr/share/backgrounds/laughlin/default/standard/laughlin.png:  PNG image data, 2048 x 1536, 8-bit/color RGB, non-interlaced
/usr/share/backgrounds/laughlin/default/wide/laughlin.png:      PNG image data, 1920 x 1200, 8-bit/color RGB, non-interlaced

Comment 8 Orion Poplawski 2010-09-30 16:24:30 UTC
With these

Comment 9 Fedora Update System 2010-09-30 16:41:44 UTC
laughlin-kde-theme-13.92.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/laughlin-kde-theme-13.92.0-1.fc14

Comment 10 Fedora Update System 2010-09-30 17:07:00 UTC
laughlin-kde-theme-13.92.0-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/laughlin-kde-theme-13.92.0-2.fc14

Comment 11 Orion Poplawski 2010-09-30 17:09:21 UTC
Here is a script to build the symlinks:

## KSplash
mkdir -p %{buildroot}%{_kde4_appsdir}/ksplash/Themes/
cp -rp ksplash/Laughlin/ %{buildroot}%{_kde4_appsdir}/ksplash/Themes/
for dir in %{_datadir}/backgrounds/laughlin/default/*
do
   size=$(file ${dir}/laughlin.png | sed -e 's/.*\( [0-9]* x [0-9]*\).*/\1/' -e 's/ //g')
   mkdir -p %{buildroot}%{_kde4_appsdir}/ksplash/Themes/Laughlin/${size}
   ln -s ../../../../../../backgrounds/laughlin/default/$(basename $dir)/laughlin.png %{buildroot}%{_kde4_appsdir}/ksplash/Themes/Laughlin/${size}/laughlin.png
done

Need to add:

BuildRequires:  laughlin-backgrounds-single

So that it can see what is there.

Comment 12 Fedora Update System 2010-09-30 21:19:08 UTC
laughlin-kde-theme-13.92.0-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update laughlin-kde-theme'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/laughlin-kde-theme-13.92.0-2.fc14

Comment 13 Adam Williamson 2010-10-01 17:33:22 UTC
This was discussed at the blocker review meeting of 2010-10-01. It was accepted as a blocker under the criterion "In most cases, there must be no SELinux 'AVC: denied' messages or abrt crash notifications on initial boot and subsequent login (see Blocker_Bug_FAQ)". If people could please test the update that'd be great. Thanks!

Comment 14 E.Patton 2010-10-02 19:52:15 UTC
Package: kdebase-workspace-4.5.1-3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Log into KDE from KDM
2. Reported by ABRT but not otherwise causing a problem
3.


Comment
-----
 Crash is not noticably affecting system operation (i.e. low priority) although login is slow

Comment 15 Rex Dieter 2010-10-02 20:20:05 UTC
Re: comment #14

rpm -q laughlin-kde-theme

please.  If not using laughlin-kde-theme-13.92.0-2.fc14 please update, and logout/login (or reboot) to test.

If still a problem, please report your screen size/dimensions (in pixels).

Comment 16 E.Patton 2010-10-02 21:31:21 UTC
[root@margrave10 ~]# rpm -q laughlin-kde-theme
laughlin-kde-theme-13.92.0-2.fc14.noarch

The  screen resolution is 1024x600.

Comment 17 Orion Poplawski 2010-10-03 03:32:16 UTC
Delete any files like ~/.kde/cache-<hostname>/ksplashx/Laughlin-1024x600-laughlin.png and try again.

Rex - I don't suppose there is any way we can automatically remove these bad cache images?

Comment 18 E.Patton 2010-10-03 09:06:17 UTC
Removing the file as suggested corrected the problem.

Comment 19 Fedora Update System 2010-10-05 13:16:40 UTC
laughlin-kde-theme-13.92.0-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Rex Dieter 2010-10-18 15:42:34 UTC
*** Bug 627602 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.