Bug 62763 - scanimage reads too much data, then wedges scanner
scanimage reads too much data, then wedges scanner
Status: CLOSED CANTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: sane-backends (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks: 61901 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-04-05 02:32 EST by Jonathan Kamens
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 03:33:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-04-05 02:32:00 EST
I have a Microtek ScanMaker E6.  I have sane-backends-1.0.7-6 and related
versions installed.  I am running kernel 2.4.18-ac3.

Every time I scan a LineArt image with scanimage, I get this message at the end:

scanimage: WARNING: read more data than announced by backend (4203960/4198236)

Then, the next time I attempt to use scanimage, the scanner clicks a couple of
times and does nothing, and then scanimage reports:

scanimage: sane_start: Error during device I/O

While this is happening, these messages show up in my dmesg output:

scsi0:0:4:0: Attempting to queue a TARGET RESET message
scsi0:0:4:0: Command not found
aic7xxx_dev_reset returns 0x2002
scsi: device set offline - not ready or command retry failed after bus reset:
host 0 channel 0 id 4 lun 0

The only way I've found to get the scanner working again at this point is to use
"echo scsi remove-single-device ... > /proc/scsi/scsi" and then "echo scsi
add-single-device ... > /proc/scsi/scsi".

Note: I don't know if the "read more data" problem is related to the other
problem, but I'm mentioning it just in case it is.

Note 2: The data read by the scanimage, when it's working, seems just fine.

Note 3: This happens whether I pass "--calib_once no" or "--calib_once yes" to
scanimage.
Comment 1 Tim Waugh 2002-05-02 09:50:04 EDT
Reported upstream: 
http://www.mostang.com/pipermail/sane-devel/2002-April/003206.html
Comment 2 Tim Waugh 2002-12-23 04:38:15 EST
Upstream URL seems to have changed:

http://www.mostang.com/pipermail/sane-devel/2002-April/013877.html

There have been no replies though. :-(
Comment 3 Nils Philippsen 2005-10-11 04:09:25 EDT
Is this problem present with current (FC4 or Rawhide) packages?
Comment 4 Jonathan Kamens 2005-10-14 05:31:03 EDT
There's no way for me to tell.  I don't use the ScanMaker E6 anymore and can't
even plug it in to test it because I no longer have a SCSI controller in my
current controller and the old computer with the SCSI controller doesn't work
with FC4 or Rawhide.

Sorry.
Comment 5 Nils Philippsen 2006-04-25 03:33:10 EDT
Closing as there is no way to test this with current versions (without the HW).

Note You need to log in before you can comment on or make changes to this bug.