Bug 627720 - system-config-display don't start in fc14
Summary: system-config-display don't start in fc14
Keywords:
Status: CLOSED DUPLICATE of bug 623742
Alias: None
Product: Fedora
Classification: Fedora
Component: pyxf86config
Version: 14
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-26 18:42 UTC by Wolfgang Ulbrich
Modified: 2010-10-28 22:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-29 14:04:45 UTC


Attachments (Terms of Use)

Description Wolfgang Ulbrich 2010-08-26 18:42:11 UTC
Description of problem:
system-config-display don't start in fc14. If i try to start it in a terminal i get python errors.

[rave@mother ~]$ system-config-display 
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 27, in <module>
    import xf86config
  File "/usr/lib64/python2.7/site-packages/xf86config.py", line 1, in <module>
    import ixf86config
ImportError: /usr/lib64/python2.7/site-packages/ixf86configmodule.so: undefined symbol: xstrtokenize


Version-Release number of selected component (if applicable):

system-config-display-2.2-3.fc14.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
get some python errors

Expected results:


Additional info:

Comment 1 hannes 2010-09-24 10:27:27 UTC
Another negative side-effect of this bug is that on f14 with a non-debug kernel the nvidia driver could not be started.
Output during startup:
Enabling the nvidia driver: Traceback (most recent call last):
  File "/usr/sbin/nvidia-config-display", line 28, in <module>
    import livnaConfigDisplay.ConfigDisplay
  File "/usr/lib/python2.7/site-packages/livnaConfigDisplay/ConfigDisplay.py", line 29, in <module>
    import xf86config
  File "/usr/lib64/python2.7/site-packages/xf86config.py", line 1, in <module>
    import ixf86config
ImportError: /usr/lib64/python2.7/site-packages/ixf86configmodule.so: undefined symbol: xstrtokenize
	[FAILED]

It is the same as above but the result is somehow more "drastic". 

uname -r                                                                          
2.6.35.5-32.fc14.x86_64


If you need more information, I would be glad to provide it!

Comment 2 Sandro Bonazzola 2010-09-29 13:53:12 UTC
see bug #624297

Comment 3 Adam Williamson 2010-09-29 14:04:45 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 623742 ***


Note You need to log in before you can comment on or make changes to this bug.