Bug 624297 - system-config-display is broken
system-config-display is broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-15 15:40 EDT by Dirk Nehring
Modified: 2010-12-07 23:36 EST (History)
27 users (show)

See Also:
Fixed In Version: pyxf86config-0.3.37-10.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-09 20:12:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xtokenize patch (1.71 KB, text/plain)
2010-08-23 03:31 EDT, Lubomir Rintel
no flags Details
One more fix to make it build (826 bytes, text/plain)
2010-08-23 03:32 EDT, Lubomir Rintel
no flags Details

  None (edit)
Description Dirk Nehring 2010-08-15 15:40:08 EDT
Description of problem:

[root@f14 ~]# system-config-display 
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 27, in <module>
    import xf86config
  File "/usr/lib/python2.7/site-packages/xf86config.py", line 1, in <module>
    import ixf86config
ImportError: /usr/lib/python2.7/site-packages/ixf86configmodule.so: undefined symbol: xstrtokenize
Comment 1 Dirk Nehring 2010-08-15 15:41:20 EDT
[root@f14 ~]# rpm -qf /usr/lib/python2.7/site-packages/ixf86configmodule.so
pyxf86config-0.3.37-8.fc14.i686
Comment 2 Lubomir Rintel 2010-08-23 03:31:44 EDT
Created attachment 440307 [details]
xtokenize patch
Comment 3 Lubomir Rintel 2010-08-23 03:32:23 EDT
Created attachment 440309 [details]
One more fix to make it build
Comment 4 Sandro Bonazzola 2010-09-27 08:43:42 EDT
Seems a duplicate of bug #627720 and bug #623742 and bug #634890.

As Lubomir Rintel figured out it's caused by xstrtokenize not present as symbol.
However, the patches he provided cause Segmentation Fault on my system.
Comment 5 Sandro Bonazzola 2010-09-29 09:50:14 EDT
It seems an error in xorg-server packaging: xstrtokenize is declared as extern in <xorg/misc.h> and the binary containing its implementation is libos.la that is not installed by the Makefile. Whoever use xstrtokenize from misc.h will have thise undefined symbol.

In the patch provided by Lubomir Rintel misc.h is included, declaring xstrtokenize as extern, then xstrtokenize is implemented locally. Maybe this can explain the segfault.

I think that may be better let xorg-server install libos library in a place like /usr/lib/xorg  and link against it.
Comment 6 Adam Williamson 2010-09-29 10:05:43 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 623742 ***
Comment 7 Lubomir Rintel 2010-11-07 16:10:25 EST
This time verified to work (with livna-config-display and psb driver).
Please pull from f14/user/lkundrak/xstrtokenize-624297

Built: http://koji.fedoraproject.org/koji/taskinfo?taskID=2585288

(Reopening this and closing the other bug as a duplicate, since there's too much useless chatter in the other one).
Comment 8 Lubomir Rintel 2010-11-07 16:11:04 EST
*** Bug 623742 has been marked as a duplicate of this bug. ***
Comment 9 Thorbjørn Lindeijer 2010-11-07 16:26:01 EST
It seems to me that by closing the older bug as the duplicate, around 30 people now have to subscribe to the newer bug to still be notified of updates...
Comment 10 Felix Miata 2010-11-07 18:38:49 EST
A-How did bug 623742, which is:

1- older

2-began life with equivalent summary: "system-config-display fails "

3-contains same comment 0 information as this

4-was directed to be filed by triagers on IRC

5-has 48 CCs

get marked a duplicate of this?

B-Why should I ever bother filing another bug?
Comment 11 Sandro Bonazzola 2010-11-08 02:29:09 EST
(In reply to comment #7)
> This time verified to work (with livna-config-display and psb driver).
> Please pull from f14/user/lkundrak/xstrtokenize-624297
> 
> Built: http://koji.fedoraproject.org/koji/taskinfo?taskID=2585288

I can confirm that this one work on my system.

> (Reopening this and closing the other bug as a duplicate, since there's too
> much useless chatter in the other one).

I doesn't agree with this. pyxf86config is fixed using a workaround for bug #623742 so that bug is still open for me while this could be resolved fixed by fixinf pyxf86config.
Comment 12 Adam Williamson 2010-11-08 11:17:32 EST
lubomir: are you able to submit that build as an update?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Daniel Arnold 2010-11-08 11:44:41 EST
what is the state of this Bug?

I got the error as well?
Comment 14 Göran Uddeborg 2010-11-08 16:23:29 EST
> How did bug 623742, which is: …
> get marked a duplicate of this?

Most likely because a poor chap trying to help out by triaging bugs made a mistake and mixed up original and duplicate.  Mistakes can happen the best of us.
Comment 15 Adam Williamson 2010-11-08 16:37:29 EST
"Most likely because a poor chap trying to help out by triaging bugs made a
mistake and mixed up original and duplicate.  Mistakes can happen the best of
us."

Nice guess, but no. Just look up at comment #7 for the actual answer. "(Reopening this and closing the other bug as a duplicate, since there's too much useless chatter in the other one)." And that's from Lubomir, who provided the patch, not a triager.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Wolfgang Ulbrich 2010-11-08 18:13:14 EST
(In reply to comment #7)
> (Reopening this and closing the other bug as a duplicate, since there's too
> much useless chatter in the other one).

discriminated fedora user, who used the abrt util to find an answer for a actual problem, as 'useless chatter' is not very friendly.
Thx for your ignorance
Comment 17 Fedora Update System 2010-11-09 14:01:49 EST
pyxf86config-0.3.37-10.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pyxf86config-0.3.37-10.fc14
Comment 18 Adam Williamson 2010-11-09 14:04:36 EST
Hey, everyone - I pushed Lubomir's fix out as a candidate update. Please install it and provide feedback when it's available, then it can go out as an official update. Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 nucleo 2010-11-09 14:24:56 EST
system-config-display-2.2-3.fc14
http://koji.fedoraproject.org/koji/buildinfo?buildID=186726

works fine with pyxf86config-0.3.37-10.fc14

Is system-config-display will be restored for F14+?
Comment 20 nucleo 2010-11-09 14:27:27 EST
looks like livna-config-display also work fine with pyxf86config-0.3.37-10.fc14.
Comment 21 Wolfgang Ulbrich 2010-11-09 14:35:59 EST
same by me. :-)
livna-config-display and also system-config-display working fine with pyxf86config-0.3.37-10.fc14.
Comment 22 Adam Williamson 2010-11-09 14:39:58 EST
great. If you guys could leave feedback at https://admin.fedoraproject.org/updates/pyxf86config-0.3.37-10.fc14 (I see you already did, nucleo, thanks!) that would really help to get the update pushed out. In case you don't know, log in with your FAS account by clicking the blue 'log in' link in the left-hand pane first, then post feedback.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 23 Adam Williamson 2010-11-09 14:52:08 EST
nucleo: "Is system-config-display will be restored for F14+?"

No. It was orphaned because ajax doesn't want to maintain it any more and more generally we think it's the wrong way to do stuff (TM). It wasn't orphaned because of this problem. (Actually it was orphaned before we knew about this problem.)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 Wolfgang Ulbrich 2010-11-09 14:53:18 EST
Anonymous Tester it's me. Don't know why it's anonymous.........
Comment 25 Fedora Update System 2010-11-09 20:12:46 EST
pyxf86config-0.3.37-10.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 John Bouras 2010-11-11 07:40:20 EST
Hi gang. I came over from Bug 623724. A recent update installed pyxf86config-0.3.37-10.fc14, but the error in the boot log still appears. Ask me anything (well, almost anything).
Comment 27 Adam Williamson 2010-11-11 11:50:27 EST
john: when you say 'error'...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 28 John Bouras 2010-11-13 13:29:29 EST
Sorry, error may be the wrong choice of words. When something says FAILED in the boot log, I simply characterized it as an error. The funny part is now it's gone. Maybe it is just that I did not restart after the update. Sorry...
Comment 29 John Bouras 2010-11-13 13:47:28 EST
This has to be the great thing I love about Linux. I don't know how microsoft works, but I imagine (with prejudice) that it works like this. 

That error reporting mechanism that started with xp sends an error to a tech at ms who looks at it and says: "Oh joy, an error? Well, 5:00 on Friday. I'll tend to it when I get back from my 6 mos vacation that ms has graciously allowed for being a top error procrastinator".

Linux, things are looked into quite fashionably, and everyone can help. I love that! Go Open Source! Go Red Hat and Fedora!

Note You need to log in before you can comment on or make changes to this bug.