Bug 627787 - kpackagekit software update view doesnt scroll to follow blue bar as moved by arrow keys
kpackagekit software update view doesnt scroll to follow blue bar as moved by...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
13
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-26 20:29 EDT by collura
Modified: 2010-10-08 13:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-08 13:04:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 249177 None None None Never

  None (edit)
Description collura 2010-08-26 20:29:35 EDT
Description of problem:

view doesnt scroll to follow highlighted blue bar when highlight is moved with arrow keys through the list of available updates.

in the software update part of kpackagekit with more than a window full of update items you can scroll through the list of items with the scroll bar just fine, but when you use arrow keys to move the blue highlight bar through the list the viewport doesnt scroll with the bar as it goes down the list.  

if you use arrow keys to move the bar off the sceen, then you can use the mouse to scroll down the list showing that the arrow keys did indeed move the blue bar down the list even though the view didnt scroll along with the blue bar.

Version-Release number of selected component (if applicable):

kpackagekit-0.6.0-2.fc13(x86_64)

How reproducible:

always

Steps to Reproduce:
1. open software management (kpackagekit)
2. go to the software updates screen
3. wait for it to automatically look or hit refresh to look for updates
(if there are more than a page full of updates then you have a place to scroll to)
4. use the down arrow to move the blue highlight bar down the list of updates.
5. notice that the blue bar will continue down the list out of view because the view doesnt scroll.
6. use the mouse and scroll bar to scroll the view down to catch up with the blue bar again.
7. repeat for fun and amusement.
  
Actual results:

arrow keys dont scroll the list of update items

Expected results:

arrow keys should scroll the list of update items so you shouldnt have to use the mouse and scrollbar to scroll down the list.

Additional info:
Comment 1 collura 2010-08-26 23:27:57 EDT
filed upstream as:

https://bugs.kde.org/show_bug.cgi?id=249177
Comment 2 collura 2010-08-27 11:08:11 EDT
upstream reports that this is fixed in kpackagekit-0.6.1 
(which i think was released only a few days ago, but might still be pending)

upstream link paraphrased:
https://bugs.kde.org/show_bug.cgi?id=249176
   Resolution:   FIXED
   Severity: 	 minor 
   Version Fixed In: 	0.6.1 
   -------  Comment #1 From Daniel Nicoletti  2010-08-27 05:53:31  -------
   This was already fixed in the new version



i can never find the roadmaps when needed but judging from mirrors 0.6.1 is not planned for adoption any time soon?

    http://mirror.fdcservers.net/fedora/development/14/x86_64/os/Packages/kpackagekit-0.6.0-0.9.20100301svn.fc14.x86_64.rpm

    http://mirror.fdcservers.net/fedora/development/rawhide/x86_64/os/Packages/kpackagekit-0.6.0-2.fc15.x86_64.rpm


can someone link me a roadmap so i know when 0.6.1 might make its way into fedora?
Comment 3 Rex Dieter 2010-08-27 11:14:06 EDT
Very soon, work to package up the new version is underway now.
Comment 4 collura 2010-08-27 11:42:14 EDT
doh, comment#1 is ok but there is a typo in comment#2 above

although the rest of the comment#2 is correct, 
the actual external link given in comment#2 
should be to kde-bug#249177 (not to kde-bug#249176)
so correct link to the fix notice in comment#2 should be:

https://bugs.kde.org/show_bug.cgi?id=249177

please resume your coffee.
Comment 5 collura 2010-08-27 11:43:31 EDT
regarding comment#3:  great, thanks :')
Comment 6 collura 2010-10-08 13:04:06 EDT
i can confirm that now the viewfinder correctly follows scrolling through list of updates with arrow keys.

tested with both:

kpackagekit-0.6.1-1.fc13 (x86_64)

and 

kpackagekit-0.6.1-1.fc14 (x86_64) in fc14-kde-beta 



thanks.

bye bye buggie.

closing.

Note You need to log in before you can comment on or make changes to this bug.