Bug 6278 - Install Error or Anaconda/Python bug using 6.1 errata boot-RHEA-1999:044.img
Install Error or Anaconda/Python bug using 6.1 errata boot-RHEA-1999:044.img
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-22 22:54 EDT by zito
Modified: 2015-01-07 18:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 13:55:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zito 1999-10-22 22:54:50 EDT
This seems to be the same old bug as 5555, 5944, 5875, 5789
I Downloaded the new boot-RHEA-1999:044.img and the install
again and the same "Exception Occured" as follows

                    Exception Occured

  Traceback (innermost last):
     File "/usr/bin/anaconda.real",
  line 225, in ?
       intf.run(todo, test = test)
     File
  "/tmp/lib/python1.5/site-packages/te
  xt.py", line 1000, in run
      rc=apply (step[1](), step[2])
     File
  "/mnt/redhat/comps/install/6.1/i386/
  misc/src/trees/hdimage/usr/lib/pytho
  n1.5/site-packages/textw/packages.py
  "line 10, in _ _call_ _
     File
  "tmp/lib/python1.5/site-packages/to
  do.py", line 930, in getHeaderList
      self.hdList=
  self.method.readHeaders()
     File
  "/tmp/lib/python1.5/site-packages/ha
  rddrive.py", line 45, in readHeaders
      isys.umount ("/tmp/hdimage")
     File
  "/tmp/lib/python1.5/site-packages/is
  ys.py", line 8, in umount
      return_isys.umount (what)
  System Error: (16, 'Device or
  resource busy')

            OK       Debug

 This was a Harddrive install from my "C" drive to my
"D" drive.  All non RedHat files (ftp) were removed from the
RedHat directories including the RPM directory!
Comment 1 adrian.lawrence 1999-10-30 07:12:59 EDT
The same bug seems to be in boot-RHEA-1999:045.img. Reported as #6481.
Sorry to add yet another bug report to the existing list. My original
search missed these.
Comment 2 richard.meer 1999-11-02 15:14:59 EST
Hi,
I've had this bug in the instalation of LINUX and some people advised
me to check the RPMS directory for anny files not ending with .RPM
I dis that and foun an log file from my FTP prog. deleted the file
and tryed the install agean, it still did'nt work ( for some other
people this did work !!) Then I compared the files in that dir with
the files on the FTP site and found out that a file called HOWTO-
corean..... something was'nt completly downloaded. I redownloaded
this file and the install worked well !! so check your RPMS dir, it
should be 555.198.893 bytes large, if it is'nt check your RPM files !!
Comment 3 zito 1999-11-02 21:37:59 EST
As explained above all non RPM files were removed. Also each and every
RPM was checked and compaired for size. All updated RPM's were
retrieved from "RedHat's Site". The install was also tried using the
new boot-RHEA-1999:045 with the following resaults:

                   Exception Occured

(Pdb) ignore
Traceback (innermost last):
   File "/usr/bin/anaconda.real", line 235, in ?
     pdb.post_mortem (tb)
   File "/var/tmp/pyton-root/usr/lib/python1.5/pdb.py", line 876, in
post_mortem
   File "/var/tmp/python-root/usr/lib/python1.5/pdb.py", line 113 in
inneraction
   File "/var/tmp/python-root/usr/lib/python1.5/cmd.py", line 77 , in
interaction
   File "/var/tmp/python-root/usr/lib/python1.5/cmd.py", line 115, in
onecmd
   File "/var/tmp/python-root/usr/lib/python1.5/pdb.py", line 371 in
do_ignore

   Index Error: list index out of range
   install exited abnormally
   sending termination signals...done
   sending Kill signals...done
   unmounting filesystems...
          /mnt/runtime
          /tmp/hdimage
          /dev/pts
          /proc
   you may safely reboot your system
Comment 4 Jay Turner 1999-11-30 13:43:59 EST
Try downloading the RPMs again.  It has been found that a corrupt RPM file can
result in the bug you are seeing.  There is information in bug #6438 which tells
of checking the contents of the /RedHat/RPMS directory to verify that it is all
there.

*** This bug has been marked as a duplicate of 6438 ***
Comment 5 zito 1999-11-30 14:09:59 EST
Over Thanksgiving I have downloaded all the RPMS Again from RedHats site to made
sure that they were good and got the same error.
Comment 6 Jay Turner 1999-11-30 15:53:59 EST
zito appears to be having a different problem than the one that the rest of the
people on the list are reporting.  You appear to have a comps list with
components for which there are not actual RPM files in /RedHat/RPMS

Please send the first python exception that you are sending and I will take a
look at it and see what I can glean from the message.
Comment 7 zito 1999-11-30 16:48:59 EST
Here is the whole thing. It seems to be identical to the Error above now that I
look at it. Once again this was using the Updates image by typing "linux updates
text" after booting with the boot-RHEA-1999:045 on floppy made from rawrite.
I choose "custom install", "hard drive install" and "Microsoft serial mouse".

I setup Disk Drudge
as follows
          hdb5  /                   256mb
          hdb6  /usr                242mb
          hdb7  /home               242mb
          hdb8  /var                242mb
          hdb9   swap                64mb

I then choose the option of installing the boot in the hdb.

all seem to go well until it read the RPMs
and then the followig:

                  Exception Occured

 (Pdb) ignore
 Traceback (innermost last):
    File "/usr/bin/anaconda.real", line 235, in ?
      pdb.post_mortem (tb)
    File "/var/tmp/pyton-root/usr/lib/python1.5/pdb.py", line 876, in
      post_mortem
    File "/var/tmp/python-root/usr/lib/python1.5/pdb.py", line 113 in
      inneraction
    File "/var/tmp/python-root/usr/lib/python1.5/cmd.py", line 77 , in
      interaction
    File "/var/tmp/python-root/usr/lib/python1.5/cmd.py", line 115, in
      onecmd
    File "/var/tmp/python-root/usr/lib/python1.5/pdb.py", line 371 in
      do_ignore


          OK          Debug

  (hitting either of the above gives me the following)

    Index Error: list index out of range
    install exited abnormally
    sending termination signals...done
    sending Kill signals...done
    unmounting filesystems...
           /mnt/runtime
           /tmp/hdimage
           /dev/pts
           /proc
    you may safely reboot your system

(It stays there until I hit Ctrl, Alt, Del)


Hope this helps, maybe I'll have to wait till the next version but in the mean
time I have once again deleted the RPM directory on my C: drive and am now down
loading it from RedHats sight, so it won't be until sometime tomarrow that I
will be able to try another install. I will also delete the base directory and
redown load that too.
Comment 8 zito 1999-12-07 23:25:59 EST
After downloading the RPMS again and the base directories, I tried the install
and got the exact same errors.
Comment 9 zito 1999-12-09 00:28:59 EST
I tried to install 6.1 again today, got the above error and this time hit Ctrl
Alt F4 (I think it might have been F3) and it said the following:

* probing buses
* finished bus probe
* found nothing
* 65 keymaps are available
* loaded 9 keymap tables
* going to insmod fat.o (path is NULL)
* going to insmod vfat.o (path is NULL)
* partition /dev/hda1 selected
* mounting device hda1 as vfat
* created inode
* done loading 4194304 bytes
* probing buses
* finished bus probe
* found sugesttion of Card:S3 ViRGE (generic)
* found nothing
* recursively coping /tmp/update-disk/lost+found
* recursively coping /tmp/update-disk/iw
* recursively coping /tmp/update-disk/textw
* going to ismod raidO.o (path is NULL)
* going to ismod raid1.o (path is NULL)
* going to ismod raid5.o (path is NULL)
* autopartitioning FAILED

I hope this helps
Comment 10 dwhitefield 2000-01-05 15:22:59 EST
How To Download Red Hat Linux 6.1
(http://www.redhat.com/download/howto_download.html#download) says:
	Download the entire contents of
               ftp://ftp.redhat.com/pub/redhat/current/i386/RedHat/RPMS into the
               RedHat/RPMS directory that you just created.


This should only include the rpm files and should explicitly exclude the files
"ls-lR" and "ls-lR.qz" even though these files are in the RPMS.  This probably
should be clarified in the manual or the files should be removed from the
directory.  Otherwise you get the python errors described by this bug report.

Also, I got python errors similar to the bug report's errors because my
RedHat/base/comps contains ^M in addition to the \n.  After looking at the debug
I believe this is due to using windows ftp to do the transfer which seemed to
insert the control M before the end of lines.

Once I removed ^Ms the installed made it past the python errors.
Comment 11 Jay Turner 2000-02-08 13:55:59 EST
It appears that you are not getting complete downloads.  The "index out of
range" error is generally thrown when the installer is looking for something
which is actually not there.  Try the latest RawHide and see if that installer
has a better time.

Note You need to log in before you can comment on or make changes to this bug.