This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 628024 - setting "Swap Ctrl and CapsLock" does not take effect
setting "Swap Ctrl and CapsLock" does not take effect
Status: CLOSED DUPLICATE of bug 628161
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-08-27 13:06 EDT by Mamoru TASAKA
Modified: 2010-08-29 22:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-29 22:03:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (94.68 KB, text/plain)
2010-08-27 13:06 EDT, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2010-08-27 13:06:20 EDT
Created attachment 441571 [details]
Xorg.0.log

Description of problem:
Even if I
- launch gnome-keyboard-properties
- Choose "Layouts -> Options -> Ctrl key position"
- and choose "Swap Ctrl and CapsLock"

Ctrl and CapsLock key positions are not swapped.

Version-Release number of selected component (if applicable):
control-center-2.31.90-1.fc14.i686
xorg-x11-server-Xorg-1.9.0-4.fc14.i686

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.
  
Actual results:
See above

Expected results:
Ctrl and CapsLock key position must be swapped

Additional info:
I don't know when this issue happened...

/etc/X11/xorg.conf empty
/var/log/Xorg.0.log attached
Comment 1 Mamoru TASAKA 2010-08-27 13:45:58 EDT
"setxkbmap -print" shows

$ setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+jp+jp:2+us:3+inet(evdev)"   };
        xkb_geometry  { include "pc(pc104)"     };
};
Comment 2 Mamoru TASAKA 2010-08-28 07:38:12 EDT
Well, after watching bug 628161:

With ibus-1.3.6-5.fc14.i686
$ setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+jp+jp:2+us:3+inet(evdev)+level3(ralt_switch_for_alts_toggle):3+group(alts_toggle)+ctrl(swapcaps)+shift(breaks_caps)+terminate(ctrl_alt_bksp)"     };
        xkb_geometry  { include "pc(pc104)"     };
};

However with ibus-1.3.7-{1,2}.fc14.i686:
$ setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+jp+jp:2+us:3+inet(evdev)"   };
        xkb_geometry  { include "pc(pc104)"     };
};

Once changing the component to ibus.
Comment 3 fujiwara 2010-08-29 22:03:14 EDT

*** This bug has been marked as a duplicate of bug 628161 ***

Note You need to log in before you can comment on or make changes to this bug.